Explore & discover

Helpful Links

iPhone MobileConfig Files Not Recognized By Safari


iPhone MobileConfig Files Not Recognized By Safari

I'm going to post this under business, because its an enterprise feature but I'm sorry if its not the right area.

I'm trying to distribute custom iPhone mobile config profiles from a web server, something that Apple says is perfectly acceptable. When I open the file through Safari, it says wants to open it with a 3rd party app and says there is no program on this iPhone that can open it. Here are the steps I've taken to try to troubleshoot:

  • Extensive Google Search
  • Signed the profile
  • Signed and encrypted the profile
  • Tried it on normal and SSL server
  • Tried it on two different iPhone 4s

Any ideas on why? Does anyone else have an issue like that? Thanks for thelp in advance.

Message 1 of 7

Re: iPhone MobileConfig Files Not Recognized By Safari

Distributing in email works fine, and it doesnt matter the content of the profile - I've tried more then one.

Message 2 of 7

Re: iPhone MobileConfig Files Not Recognized By Safari

I was looking into trying to do a configuration profile and found that after creating the configuration profile with the iPhone Configuration Utility, you need to make sure that the file is not compressed, here is where I found this info; http://manuals.info.apple.com/en_US/Enterprise_Deployment_Guide.pdf


Outside of that guide I couldn't find anything else.  So if it doesn't help, then I suggest contacting Apple.  It will probably be easier to just check the Apple discussion boards first and then calling AppleCare (1-800-my-iphone).

Message 3 of 7

Re: iPhone MobileConfig Files Not Recognized By Safari

Well, thanks for looking. Its been a couple of days of my reasearch as well - to no avail. Now, I called AppleCare yesterday, the Tier 1 agent didnt know what mobileconfig files were. The Tier 2 agent assumed the entire time that I was using the mobileconfigs for tethering, and told me I needed a jailbroken phone to do what I wanted to do. I told him Apple makes the iPhone Configuration Utility, but he wasnt aware.

I was provided the number to enterprise Apple Care. They told me that I had to pay per incident because I'm not a company, they wanted $199/incident. So I politely declined.

I finally figured it out (at least my specific issue). I've got two apps on the device that are multipurpose apps, they try to take association of files that the OS doesnt recognize. So, basically, safari doesnt recognize the mobileconfig and tries to pass it off to another app. But it fails here and doesnt tell you any info. Once I removed the apps, safari installed the mobileconfig. So maybe this is a bug with the OS, because I've had the same apps on for a while. It seems like the OS checks for the mobileconfig only if no other programs claims it can open it. But if the webserver is sending the right MIME type, and the extension is .mobileconfig - then the OS should not ask other apps.

I'm going to try to report this to Apple, we will see where it goes from there. I'll keep this thread posted so if other people search online or in the forum, they'll get the eventual answer. Thanks for your reply too!

Message 4 of 7
Accepted by Anonymous
Accepted by Anonymous
‎08-26-2015 1:25 AM

Re: iPhone MobileConfig Files Not Recognized By Safari

I'm having this problem trying to configure to get email from my company (not tethering!). What apps were causing the conflict?  how did you find them?  thanks!

Message 5 of 7

Re: iPhone MobileConfig Files Not Recognized By Safari

Sorry for the late response, I havnt checked this thread in a while!


I found them becuase when I tried to open the .mobileconfig it asked if I wanted to open the file in the particular app that was causing the problem. I finally removed that app (because I thought this was a fixable OS issue) and all of a sudden it worked.


Now, I tried this with 4.1 and it seems to not be a problem. I have both apps on my phone now and I'll be testing it a bit more.


I hope this helps!

Message 6 of 7

Re: iPhone MobileConfig Files Not Recognized By Safari

Unless something else arises this will be my last update.

The issue seems to be resolved with 4.1. I guess it was a iOS issue because none of my affected apps updated since then.

If anyone has any problems PM me and/or post here, I'll try to help.
Message 7 of 7
Share this topic
Share this topic

Check out our AT&T Business Instagram page by visiting us HERE. Don’t forget to follow for updates and insights!

Additional Support