Helpful Links

Wifi issue after 2.3.6 update on Atrix 4G

Teacher

Wifi issue after 2.3.6 update on Atrix 4G

My wifi keeps disconnecting after the new update any one else having this issue?
12,296 Views
Message 1 of 42
Explorer

Re: Wifi issue after 2.3.6 update on Atrix 4G

I'm with the others on this - while seeing the wi-fi drop from my phone is a very huge annoyance, even with wi-fi off the cell data will drop (signal strength meter goes gray even while reading 3-5 bars).

 

As for the wi-fi issues, this happens with every router I connect to (2 different routers at home, AT&T WIFI hotspots at multiple locations, and at work).  Trying to pin this problem that did not exist with 2.3.4 on the router side of the equation is the wrong thing to do.

 

Who do we need to contact at AT&T and at Motorola so that they get a fix out for this problem?  I did the "Email Us" through thte AT&T site, but never expect any real help from that.  The Motorola "support" link just sends you over to the AT&T site.

 

Maybe I should take the phone back to an AT&T store and tell them to swap it out, figuring a phone in the box will still be 2.3.4 which worked just fine. Smiley Happy

 

Message 31 of 42
Tutor

Re: Wifi issue after 2.3.6 update on Atrix 4G

@camattin - I wholeheartedly agree with your 'it's the phone's software' and 'not the router' assessment of the situ. I too did not have any problems until the update.

Keep after Motorola Mobility/Google about it and make sure you talk to a human - may be the best approach; don't know what AT&T will be able to do about it. Otherwise band-aid the problem as much as possible and wait for the Atrix ICS update, which is due in the next few months.
Message 32 of 42
Contributor

Re: Wifi issue after 2.3.6 update on Atrix 4G

Guys, I've been having the same issue with my home Belkin router since and before the update. I fixed it by switching to 64bit security and everything seems to be ok. Wpa/PSk wont work.
Tags (1)
Message 33 of 42
Tutor

Re: Wifi issue after 2.3.6 update on Atrix 4G

I am using a cisco router and am getting an error when trying to connect!

Message 34 of 42
Tutor

Re: Wifi issue after 2.3.6 update on Atrix 4G

Also, how do you update your phone if you don't have WIFI??? 

Message 35 of 42
Contributor

Re: Wifi issue after 2.3.6 update on Atrix 4G

I'm also having this same issue. Tried all the other fixes including factory reset and changed wif sleep - to never. Went to Motorola and they're no help. They want me to send it in for repair, but my phone is out of warranty so I'm not sure I'm willing to pay for the fix if it's really a software issue, which I believe it is since I am able to connect for a few seconds and then cuts off and resets my phone.
Message 36 of 42
Contributor

Re: Wifi issue after 2.3.6 update on Atrix 4G

Ask AT&T for a new phone. They offered me 3 different Samsung models; Captivate, Infuse and Galaxy 2 Skyrocket. I've had the Captivate and it's a wonderful phone. When the Atrix came out, I upgraded to that one because I'd had Motorolas in the past and loved them. I had 2 Atrixs in a span of 8 months, both lemons. The first one just started shutting down and restarting on it's own. The second had the Wifi error issue, which seems to be rampant worldwide. Obviously AT&T knows there is a problem because they did'nt send the paper work for me to send the phone back. I guess they consider it a Brick. So far, I'm very happy with the Skyrocket. 4G and LTE ( where available). My tv is a Samsung, bluray is Samsung. Samsung makes a great product.

Message 37 of 42

Re: Wifi issue after 2.3.6 update on Atrix 4G

motorola repair service fix my phone free of charge i also had the same problem u should join the motorola forums https://forums.motorola.com/hives/a3f29dc0f5/posts
Message 38 of 42
Contributor

Re: Wifi issue after 2.3.6 update on Atrix 4G

I've been having the same problem, and changing the lease duration on my (Belkin) router appears to have fixed it.

 

Shooting from the hip (and going slow for the non-geeks): when the lease duration is set to "forever" it is really set to a very large number measured in (likely) fractions of a second.  My router, for instance, was showing a lease expiration date in 2014 when set to "forever".  When writing software the developer has to specify how big a space to reserve for numerical values, and it seems to me that the WiFi routines in this update didn't use a large enough space for the number being used to represent "forever".  When the big number is being shoved into the too-small space, it's rolling over (like an odometer going from 999999 to 000000), probably several times, and ending up with a value that resolves to minutes instead of years.  This explains why some people are having the problem and not others, and only in some locations, as it would depend on what value any given router is sending for the lease duration, and why taking the phones apart doesn't help.

 

Given that the Atrix is yesterday's news I wouldn't expect this to be fixed any time soon.  If the rumored ICS upgrade comes through then perhaps it will be fixed then.

 

Message 39 of 42
Tutor

Re: Wifi issue after 2.3.6 update on Atrix 4G

Same annoying problem here, my phone has the 2.3.6 working since a while now, This happens regardless of where I'm located so I think that the Wi-Fi router has very little to do. In my settings the Wi-Fi is configured to NEVER go to sleep so there is no real explanation about why it should happen but I noticed the problem right after the AT&T Smart Wi-Fi application was installed in my ATRIX 4G. 

 

Sorry to hear that neither Motorola nor AT&T are addressing the issue properly. This not a phone malfunctioning, more likely a bug that nobody is in a rush to address because the market is moviing to new phone model.

 

AT&T should pay close attention because this problem may lead to a liability issue that stands behind the fact that Customers  may not realize they have this problem and can (very easily) exceed the data plan limit, therefore the budget that was planned for the service. This should be enough evidence for AT&T should consider in order to push Motorola fix the problem.

 

Regards

Message 40 of 42
Teacher

Re: Wifi issue after 2.3.6 update on Atrix 4G

Well after waiting months for the ics update hoping would fix these issues I'm having with the Atrix 4G. At&t and Motorola have now left us a phone with lots of problems and no support for a once flagship phone. Now that they have officially canceled the update. After dealing with at&t for months saying the update was coming my warranty is now up and at&t strung me along knowing this. When are contract is up soon I think we will have to move on to a better company that cares about it's customers.
Tags (1)
Message 41 of 42
Highlighted
Contributor

Re: Wifi issue after 2.3.6 update on Atrix 4G

Spoke with Motorola Mobilie today.  After some discussion we removed the "ATT Smart wifi"  App that was part of the 2.3.6 upgrade.  After removal, the original pasword appeared and re-set after shuting down WiFi.    Has only been a few hours....but all is well so far.  RG

Message 42 of 42
Share this topic
Announcements

Find out how to track your iPhone's delivery!

Have questions about International Plans? Get the answers on Wed. 10/25 at Hello World: International Plans, from 1-4pm ET / 10am-1pm PT!

Let us help you upgrade and activate your device!

Additional Support