Helpful Links

Solved - Not getting notification of text message received


Solved - Not getting notification of text message received

As the title says, no longer getting any notifications when receiving text messages. Using a Galaxy 3S running Android 4.1.2. Using default messaging app with Swype keyboard and default sounds. No 3rd party messaging apps used. Only using the apps the phone came with.

Problem started maybe 2-3 days ago. I no longer get the audio notification, the blue LED no longer blinks, and I do not get the little "text message received" icon in the title bar. None of the these 3 notifications work any more.

Things I've tried / verified:

Tried a "restart" on phone then did a full power off and back on. No help.

Went into the "Messaging" app settings and verified "Notifications" and "Preview Message" are turned on. Should play "Charming Bell". Also in these same settings, tried changing the "Text message limit" and "Multimedia message limit" to 5000 each. Tried turning off the "Delete old messages" option.

When none of that helped, went into the phone settings. Under "Device > Sound" verified "Default notifications" is set to Charming bell and verified the volume is set to about half. Under "Device>Display>LED Indicator", verified "Notifications" is turned on.

In the case of all of these settings, I would toggle the settings off and on just to see of that made any difference. It did not.

Any ideas?


Solved: After trying every possible solution I could find on the internet, I took the phone to Best Buy. The mobile tech worked with it for about 30-40 minutes before finding the problem. It turned out to be some sort of conflict between the default "Messaging" program and the "AT&T Messages" program. He uninstalled a recent auto-update made to AT&T Messages. Once that update was removed, everything started working normally.

Message 1 of 3
Former Employee

Re: Solved - Not getting notification of text message received

Thanks @Maggotry for coming back and posting the resolution! Hopefully no one else will experience the same issue, but if they do, your post can be helpful! 


Thank you! 

Message 2 of 3

Re: Solved - Not getting notification of text message received

Go to apps. Click on messages click on set as default then hit clear defaults. Problem solved

Message 3 of 3
Share this topic

Learn how you can order the new iPad 9.7-inch with Apple Pencil Support!

Additional Support