Explore & discover

Helpful Links

Sending Duplicate Texts


Sending Duplicate Texts

After running an update on my Samsung Note 4, whenever I text, the text is sent in duplicate. I don't know if the update is responsible, I would like a resolution, though. Thanks.
Message 1 of 4
Accepted by topic author
Accepted by pjk001
‎06-14-2017 8:44 AM

Re: Sending Duplicate Texts

Hello @pjk001,


Thank you for reaching out to our Community Forums! I understand how inconvenient sending duplicate texts can be, but not to worry. We will get this taken care of!


Duplicate texts can be the result of an issue with connecting to a nearby tower. You can try removing and reinserting your SIM card to reestablish your connection to a tower.


To do this you can use our Device Support Tool! All you have to do is select your make and model device, then select View All Solutions. After this, select About your device under Device Topics on the left side. Lastly, pick Insert SIM & Memory Card. Please, make sure your device is off when you do this.


Confirm if this issue exists only with the default messaging app or a third-party one. If the app is third-party make sure it is up-to-date by checking it in the Google Play Store.


You can also try turning Advanced Messaging off. Though this has cool features, it can also interfere with some of the basic functions. To do this go into your Messages App > Select the 3 dots > Settings > Advanced Messaging > Off.


I hope you found this useful. Have a great rest of your day!


Jordan, AT&T Community Specialist

Need help?
Ask a question to get help from the AT&T Community or support from AT&T specialists. If this reply helped you please use Accept solution to mark it as an Accepted Solution.
*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Tags (1)
Message 2 of 4

Re: Sending Duplicate Texts

My Samsung galaxy s10 plus keeps sending duplicate texts, but only when it has emojis. How do I fix this?

Message 3 of 4

Re: Sending Duplicate Texts

Go into the Messages settings and click on More Settings and then Text Messages and change the Input Mode to Automatic and this solved it for me


Message 4 of 4
Share this topic
Share this topic

Do you need to fix, replace or track a device? We Can Help With That!

Additional Support