S4 Does not remember WIFI passwords

Teacher

S4 Does not remember WIFI passwords

Suddenly my S4 has stopped remebering wifi passwords of routers i frequent, asks for password every time.  This just started.  Also am unable to connect to KIES to trouble shoot  just says Connecting then times out,  windows can see the device but I cannot open any locations as well.

 

I did a factory reset and this did not change the behavior

 

I have checked all of the appropriate settings as well and they are set to remember the WIFI routers

Message 1 of 7 (24,422 Views)

Re: S4 Does not remember WIFI passwords

Kites like the MTP error is due to windows remembering drivers that are crap.  So even when you clear your phone and plug it into your computer, or connect via wifi, its still drawing on bad drivers.  You need to delete all drivers out of your computer that are used in kies and usb to phone, and registry for that matter.

TO do this
 check this guide

PnP driver disabled

From there you can try this

go back to device manager

in device manager go to view.

show hidden drivers

in Non-Plug in Play drivers

disable hardware policy (right click properties)

save, reboot

Let windows load, turn off Internet

plug in phone, it will load base driver.

Then try it out.  Connect to Internet all that.

If this does not work, download newest drive for kies, from manafucture.  Dont run it just save it.

Do the same steps, but after the base is loaded, run new drivers.  (if you need to connect to internet do so)

If none of this works then you need to delete the registry values for kies, and start this all over.  But if you dont know how to do that dont do it.  Get some more help at xda-developer.com.  But you need to read the guides first

good luck

 


burdulis wrote:

Suddenly my S4 has stopped remebering wifi passwords of routers i frequent, asks for password every time.  This just started.  Also am unable to connect to KIES to trouble shoot  just says Connecting then times out,  windows can see the device but I cannot open any locations as well.

 

I did a factory reset and this did not change the behavior

 

I have checked all of the appropriate settings as well and they are set to remember the WIFI routers




Message 2 of 7 (24,346 Views)

Re: S4 Does not remember WIFI passwords

also, you wifi, check to see if router has new firmware update.  Also what wifi adapter are you using.  Windows or is someone other software running it for you.  IT HP, or Dell, Intell.  whoever.  Those have to be updated as well.

good luck

Message 3 of 7 (24,345 Views)
Highlighted
Mentor
Solution
Accepted by ATTJulieCS (Community Support)
‎09-30-2015 1:39 AM

Re: S4 Does not remember WIFI passwords

Hi,

Found this on another site:

 

I've seen this in my S4, and found a fix. Go to your Wi-Fi settings, too the page showing available connections, and press the menu button, and select Advanced. Turn off the option for "Check for Internet service."

 

I found that as I walked out of range of my home or work router, the phone was detecting the connection didn't work any longer - but instead of just figuring out i was out of range, it was marking it internally as a bad connection! That kept it from automatically reconnecting the next time i was in range, and forced me to re-enter the password when I manually tried to connect. I turned off that setting, and haven't had a lost access point yet.

Message 4 of 7 (24,303 Views)
Contributor

Re: S4 Does not remember WIFI passwords

I actually had this setting off and the wifi networks were not remembering my password. Does anyone else have any expereience with the setting off and still experiencing the issue?

Message 5 of 7 (19,494 Views)

Re: S4 Does not remember WIFI passwords

I have the same problem.  I tried your suggestion, but in Advanced there is no option 'Check for Internet Service', unless that's the one labeled 'Always allow scanning' which is turned off on my Galaxy.

 

-Nigel

Message 6 of 7 (19,105 Views)
Contributor

Re: S4 Does not remember WIFI passwords

Checking off the option to check for internet connection did not solve this issue for me.  What did work was disabling AT&T Smart Wifi app.  To do this, I had to launch the AT&T Smart Wifi app and within the app click on the "Enabled" button so that it is disabled.  A message will appear that says this will turn off wifi and not connect to any AT&T hotspots.  Hit OK, then close the app.  Then turn Wifi back on using the normal Android settings menu instead of using AT&T Smart Wifi.  After doing this, now wifi passwords are remembered with no problem. 

Message 7 of 7 (15,764 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.