S3 MMS come through anonymous/message not found

Highlighted
Voyager

S3 MMS come through anonymous/message not found

When someone sends me a picture it comes through as anonymous sender and in the message itself "message not found". This happens whether its from an iphone user or an android user more than 50% of the time. I have already unregistered my old iphone, tried sms apps (they freeze or crash), tried suggestions on the 3 whole google hits I found with the same issue, and compared my settings to my husband's s3 (He rarely has this happen) none have fixed the issue. Any ideas/suggestions before I give up and just reset the phone, start from scratch and pray it works? Thanks!
7,177 Views
Message 1 of 2
Contributor

Re: S3 MMS come through anonymous/message not found

the fix for this is to disable the AT&T messenger app. go to settings on your android, manage applications > all > at&T messenger > force stop > disable

Also delete the anonymous message thread
Message 2 of 2
You must type a description before you click preview or reply.
Share this topic
Announcements

Are you looking to upgrade and activate your device?

Let us help make Ordering, Upgrading and Activating easy!

Additional Support