Explore & discover

Helpful Links

Not receiving messages

Tutor

Not receiving messages

Hello

 

I have a Google Pixel 2 XL fully updares. I'm being informed by multiple friends that I haven't received their MMS message, missing multiple messages on group chats and now just not receiving texts from 1 on 1 conversations. I thought it was the texting app but I downloaded a new one and same problem. What can I do?

36,013 Views
Message 1 of 138
Tutor

Re: Not receiving messages

I was so happy to find this thread.  I've been having the issue for about the past week.....

 

Turning off "enhanced LTE mode" seems to have fixed it, but that's a pretty crappy fix.

 

I have a Pixel 2, bought from Google, and I first went through their full troubleshooting.  At this point, they have stated it's AT&T's fault.  I hope something gets addressed.  I'm not on a contract with at&t, so perhaps it's time to explore verizon?

Message 121 of 138
Tutor

Re: Not receiving messages

I'm having this issue on my new Razer Phone 2.  Missed messages of all kinds.  

 

I lucked up and got a knowledgeable and helpful phone rep when I called AT&T.  He said he did a lot of things to my account and he ordered me a new SIM to be delivered at no charge.

 

When I asked him about disabling enhanced LTE, he specifically said it would not matter.

 

I've rolled back my Google Messages to 3.9 and disabled enhanced LTE anyway.  The new SIM is supposed to arrive tomorrow.  Fingers crossed!

Message 122 of 138
Contributor

Re: Not receiving messages

I'm so frustrated, again, with AT&T. I'm using an unlocked Pixel 2 XL and running into the same issues with group messaging others have described. Disabling enhanced LTE services has allowed me to start receiving group messages that I wasn't with it enabled, but what a terrible workaround. I'm seriously considering moving my family over to Google Fi at this point. I think I'm ready to be done with AT&T treating us Pixel users like second-class citizens.

Message 123 of 138
Tutor

Re: Not receiving messages

Gboybama, can you update us after you get the Sim card?

Message 124 of 138
Highlighted

Re: Not receiving messages

Folks,

Go back to page 8 of this thread and read my replies to this thread.

Message 125 of 138
Tutor

Re: Not receiving messages

Hello,

 

I am\was having the same exact issue.  I have a Pixel 2 XL.  I first reset Wi-Fi, mobile, and Bluetooth under System -< Reset Options.  It seemed to help but didn't fix the issue.  I now turned off Enhanced 4G LTE Mode, which seems to have helped the most.  I've had it off for a day and I believe I have received all group text.  Not an easy way to verify it, but at least I can follow the conversations when they are happening where previously I could not.  I may enable Enhanced 4G LTE Mode as a test to see if it was a coincidence that it worked and maybe they fixed the issue, or not.

 

I wish AT&T would comment.  I am also out of contract and exploring my options if my test above shows that the root cause isn't fixed yet.

Message 126 of 138
Tutor

Re: Not receiving messages

@milkthese193 I'd seen some reports of people having this issue on other carriers, including Fi, in the past as well

Message 127 of 138
Tutor

Re: Not receiving messages

@Electrohead yeah I saw your response and hear you, but right now that's not an option.  

Truth be told, I get enough flack for simply not having an iphone and using my pixel instead.  There's no way people in my sphere will start using alternative apps.

 

I seem to be still be getting group messages today, along with other messages so disabling that enhanced option might have fixed the issue.  I'd like to stop into the at&t store and talk to an actual person when I have time, but I'd like to see an at&t comment show up here too.  At least acknowledge the issue.

Message 128 of 138
Tutor

Re: Not receiving messages

I haven't installed that new SIM card yet, but here's something that's super anecdotal.

 

Was anyone else recently pushed a Google carrier services app, or something like that?  It popped up as a Google background framework update in my Play store yesterday and the description on there was very vague.  Something about fixing bugs (no details) and helping Google to better utilize carrier services.

 

Any small chance they're working on this or even that it could be fixed if we're on the latest everything and reset everything?

 

I hate to throw out false hope or invite placebo effect observations, but I thought it was better to share than to withhold.

Message 129 of 138
Tutor

Re: Not receiving messages

@gboybama I got that update yesterday around 4:30 PM EST.  I made the Enhanced LTE switch earlier in the day, but no a lot of group chat happening.  Maybe that fixed the issue as well.

Message 130 of 138
Contributor

Re: Not receiving messages

Dude, what is up with the reviews in the Play Store for the Carrier Services app? I searched for it to see if I had it installed/up to date and it looks like the app had been disabled (the only option I have is to enable it). I decided to check the reviews for it and they're all super weird, which makes me hesitant to enable it.

 

I'm in the same boat as everyone. Just yesterday I noticed I could not receive picture messages from other Android devices also on AT&T. But, I can send pictures just fine. Super weird. I've had my Pixel 2 XL since launch, I install all pushed updates and security patches the moment I get a notification for them, I've never had problems with picture messaging (or group messaging, even with iPhone users) before yesterday. I turned off Enhanced LTE and I was able to receive a test MMS earlier from my friend using an AT&T branded Samsung device - the same friend who I used to have no problems sending pictures to for the last year and a half from this device. iirc Enhanced LTE has been enabled since i got the phone, so I don't know why this would suddenly be preventing me from receiving MMS now.

 

Does Enhanced LTE even give us any benefits anyway, being a non AT&T branded device? I'm getting super fed up with AT&T treating us like this just because we bought an unlocked device, and they decided to be the only US carrier to not partner with Google and sell Pixel devices. We all pay for these features we don't get (HD Voice, WiFi calling, AT&T Video Call, etc) despite the Pixel supporting them. Calling AT&T customer service is a waste of time because most of them don't understand what you're asking for anyway, or will say the phone doesn't support those features because they don't know anything about it. The last time I tried calling them about it I was put on hold for 30 minutes and then hung up on. I'm considering switching by mid summer. It's 2019, we should not have to deal with problems like this, especially not from - arguably - the top US network provider and using the top Google flagship device - it's honestly ridiculous. 

Message 131 of 138
Tutor

Re: Not receiving messages

@osirhc  I guess the weird reviews are a result of folks seeing their phone downloading the app with no explanation for what it does.

 

But hey, my approach is that I live in the cloud and if anybody wants to "get me," they probably can.  I'm not going to live in fear of installing a possible fix on my phone.  I install any framework app they tell me I need, hoping it's got at least something to do with improving the experience.  

Message 132 of 138
Contributor

Re: Not receiving messages

Turned off LTE Enhanced

 

And 

 

Created Custom APN with Same Settings as Default APN but IPv4 only on both IP settngs. This has seemed to work for me.

 

4G APN Settings: https://apn-settings.com/us/att-apn-settings/

 

 

Message 133 of 138

Re: Not receiving messages

I dealt with this during the initial problem, and was very active on the
thread. I also experienced the recent resurgence of the issue. Turning off
enhanced LTE did the trick for me this time.

Last time, I had to call into AT&t and have them totally turn off voice
over LTE services on their end.
Message 134 of 138
Contributor

Re: Not receiving messages

@osirhc We do get HD voice with enhanced LTE services enabled on Pixel 2 and newer (not the original Pixel). My wife had to have her SIM card replaced for it to start working for her though...mine worked right away.

 

We both experienced the MMS issue this thread is complaining about though, so now we both have enhanced LTE turned off, so no more HD voice.

Message 135 of 138
Share this topic
Share this topic
Announcements

Do you need to fix, replace or track a device? We Can Help With That!

Additional Support