Explore & discover

Helpful Links

Re: Not receiving messages

Tutor

Not receiving messages

Hello

 

I have a Google Pixel 2 XL fully updares. I'm being informed by multiple friends that I haven't received their MMS message, missing multiple messages on group chats and now just not receiving texts from 1 on 1 conversations. I thought it was the texting app but I downloaded a new one and same problem. What can I do?

38,023 Views
Message 1 of 138

Re: Not receiving messages

I've had this issue with a Pixel 2 XL since I've owned it, starting Christmas. I've tried everything (i.e. sim card, reset, clear cache, APN, etc.). Nothing worked. So I disabled Enhanced LTE as per many suggestions on forums here and Reddit. I thought that did the trick - until today. Missed an original multi person text. The only reason I knew I missed it, is because a reply from one of the people showed up. So disabling Enhanced LTE did not solve the issue. ATT tells me that they do not guarantee that ALL featured will work on a "unsupported" phone. Google support is saying they will document the issue LOL. My only other option is to get a replacement phone. But I hate to do that because Google doesn't send you a new phone, which I paid $1000 for - they send you a refurbished one. The other option is to go back to an iPhone, which worked fine up to me switching to Pixel 2 XL.

Message 91 of 138
Teacher

Re: Not receiving messages

According to Google, this issue is now fixed. Look at Pankaj Kanwar's last post today. I'm hoping my pixel2 will be great again.

 

https://productforums.google.com/forum/#!topic/phone-by-google/BwyxuNcJj-U

Message 92 of 138

Re: Not receiving messages

Not fixed. I've been missing group texts all morning so far. Done all the
suggestions and even had AT&T turn off VoLTE. Also AT&T said they put an
urgent ticket in and I would receive a call back within 24hours from a
higher level tech....1week later and still waiting for the call 😤
Message 93 of 138
Tutor

Re: Not receiving messages

Odd. I called AT&T yesterday and had them turn my Enhanced LTE back on,
re-enabled on my phone, & rebooted.

After that my tests so far have been successful.

Message 94 of 138
Tutor

Re: Not receiving messages

The issue has been fixed. Make sure you are on the latest Android Messages
App which is 3.0.039 and it will work.
Message 95 of 138
Tutor

Re: Not receiving messages

I'm using Textra and it seems to be working fine now.
Message 96 of 138
Tutor

Re: Not receiving messages

Yep, as long as you updated the stock Messages app it will work with any
texting app.
Message 97 of 138
Highlighted
Contributor

Re: Not receiving messages

I'm using Textra and it seemed like my phone was fixed for a day - I received a photo in a group chat whereas before I wasn't!  But now I''m back to not receiving messages in group chats. When that happened, I updated the stock messaging app, and I turned off enhanced 4g LTE. Still, no MMS. I even checked my APN and I don't have any extra ones there. 

Message 98 of 138
Tutor

Re: Not receiving messages

I've definitely had dropped MMS since the supposed fix. Is the consensus here that AT&T has no interest in acknowledging or fixing this, and that Google tried but failed?

Message 99 of 138

Re: Not receiving messages

Am I the only one still having these isuses? I'm completely updated to the newest version of messaging app, new sim, truned off enhanced LTE, had at and t turn off VoLTE. I'm beyond frustrated at this point.

Message 100 of 138
Tutor

Re: Not receiving messages

No, @CHumphries! I am still having this issue as well. I'm updated on the Messages app and have now submitted bug reports to Google.

 

This is so frustrating! It's now been about 6 weeks that that has been happening!

Message 101 of 138

Re: Not receiving messages

Just watching the threads here and on Reddit and waiting. Still not working for me. For example, I SMS/MMSed a photo to a friend today, on an existing one-on-one text thread. He didn't get it. He had no idea I send it. How do I know? I asked him when I saw him in person a short time after I send the message. He showed me his phone (iPhone) - nothing.

 

How is it that we are asked to pay the full price for our monthly service, yet we don't get 100% of the service we pay for??? ATT's b@@lsh!t reply that "Pixels are not a supported phone and thus do not guarantee 100% compatibility" is a complete cop out. In essence it's extortion! Meaning - use our phones or we will not guarantee compatibility with BASIC functionality like MMS.

 

What if every Pixel owner on ATT switched to Verizon? Would they notice then? I'm so tired of YEARS of ATT's crap. Ugh.

 

 

Message 102 of 138
Teacher

Re: Not receiving messages

Yep, its still a problem. Same traffic on the google product forum:

 

https://productforums.google.com/forum/#!topic/phone-by-google/BwyxuNcJj-U

 

Personally, I am giving this issue a few more weeks to get addressed. If it is not, I am switching to Project FI to try that. 

Message 103 of 138
Contributor

Re: Not receiving messages

I have been experiencing the same on my Pixel 2 from AT&T for almost a month now. Spent several hours on the phone with AT&T changing settings and setting up new Access Point Names. It seemed to improve the issue but not fix it completely. AT&T told me there was nothing else they could do for my unlocked phone but I did qualify to buy a new phone under my plan. (My Pixel 2 is literally 4 mos old). HA. 

 

It's without a doubt an AT&T issue. I have Android using friends (using AT&T's device supported Samsungs) that are also have the same issue. It seems to be when messages come in from iPhone users. I just had an update to my phone this morning and was hopeful it would fix the issue...but nope, no such luck. SO. FRUSTRATING.

 

I too am about to switch to Project FI, I've heard nothing but great things. 

Message 104 of 138
Tutor

Re: Not receiving messages

This issue is STILL happening to me, more than two months later. I got an undownloadable message from an unknown sender as recently as last night. I was able to confirm the undownloadable message was a message in a group text that I had literally received messages without problem in merely minutes earlier.

 

How has this been going on for OVER TWO MONTHS at this point, with no solution in sight??

 

This is ridiculous! Do I really have to go sink a bunch more money into a different phone because my current phone is lacking a very basic function, when both the carrier and the company who makes the phone haven't presented a solution? This is simply not acceptable!

Message 105 of 138
Share this topic
Share this topic
Announcements

Do you need to fix, replace or track a device? We Can Help With That!

Additional Support