Explore & discover

Helpful Links

Impacted by the government shutdown? AT&T can help.  Learn more

Galaxy S3 won't totally sync with Google Calendar

Highlighted
Scholar

Galaxy S3 won't totally sync with Google Calendar

We just just upgraded 2 phones,  to the  Galaxy S3 on May 8,  2013.  My wife and I just noticed our Google calendars only show events from the last week of April.  (We've had AT&T and used the Google calendar since Sept. 2011).

 

All contacts transferred just fine and gmail works well.  Anything I add to Google Calendar on PC shows on S3, but what I enter on S3 won't show in Google calendar on PC.  I've checked other blogs and  other people are compalining about calendar sync. Our phones came with 4.11 software.

 

Any help would be great.

 

Thx,  Bill

12,852 Views
Message 1 of 5
Contributor

Re: Galaxy S3 won't totally sync with Google Calendar

It is the Samsung Calander that doesn't sync with google. I had to disable the samsung calander app (I have disabled most of the samsung apps) and get the actual google calander from the Play Store. Once I did that everything worked great.

Message 2 of 5
Scholar

Re: Galaxy S3 won't totally sync with Google Calendar

Thanks,  In the meantime I did more reasearch and I realized I had  "MY CALENDAR" checked.  After unchecking it, and checking my gmail account,   I could sync in both directions.  What I still can't do,  is look back more than 60 days into my Google calendar.

 

I didn't realize the calendar app on the S3 is Samsung.  I'll dnload the Google calendar app and report my success.

 

Bill

Message 3 of 5
Scholar

Re: Galaxy S3 won't totally sync with Google Calendar

Zeekster,  I'm using the Google calendar app and it still doesn't show any entries more than about 60 days ago.

 

Looking at the month as a whole,  nothing can be read without tapping a specific day.

Message 4 of 5
Scholar
Solution
Accepted by topic author
Accepted by tucson146
‎09-30-2015 1:39 AM

Re: Galaxy S3 won't totally sync with Google Calendar

Problem Solved.  I found this procedure on another blog:

 

I did some Googlin' and my memory was jogged. I ran into this same problem when I got my first smartphone (a Droid Inc) a couple years ago. I don't think this is a platform-specific issue as I saw it on that Incredible. Google defaults to sync'ing events that are less than a month old. The work-around that I have successfully used on the Inc and now my S3 is to export and re-import your calendar(s) that you want sync'ed past the previous several weeks.

To do this, you'll need to go to open your Google Calendar with a browser and go to the settings page. Once there, hit the "Calenders" tab. From there, click the link "Export calendars" and save the zip file to your computer. Unzip the file. For each calendar you want to reimport, click the "Import calendar" link, select the appropriate unzipped .ics file and the appropriate target. It sounds a little scary but this process did not screw up any of my events or create any duplicates. The theory is that it updates the modified timestamp of all events so they'll be sync'ed to your phone.

Here's the post I found that helped jog my memory:



As with all web-advice, YMMV and proceed with appropriate caution. This was the second time I've had this problem with 2 different phones and both times, the export/import method worked for me without screwing up my data.

Tags (1)
Message 5 of 5
Share this topic
Share this topic
Additional Support