Explore & discover

Helpful Links

Call forwarding just does not work

Highlighted
Teacher

Call forwarding just does not work

I have had a perennial issue with call forwarding for the last 2 years and it has become a real pain, so I'm looking to finally solve it this time, if one of the AT&T support guys can help. Each time I go abroad, I want to just forward my wireless number to another line (in the U.S.) and turn off my phone, but up to this point it has never worked. I have a Samsung Galaxy S8+, and have tried both of the following methods:

 

  • **21*[number]#
  • Go to settings->Supplementary Services->call Forwarding->Always Forward, turn on and add the number

Both methods have exactly the same effect, they say that the phone has been forwarded unconditionally (MMI is successful), and I even get an icon in my notification panel stating that call forwarding is on unconditionally. Now my phone never rings.

 

So, here's the problem....if I call my number from another phone it just goes straight to voicemail. I have tried all of the following with no success:

  • Leave the phone switched on and on the network: It doesn't matter how long I leave it on for, the call forwarding never goes anywhere, all calls just go directly to voicemail, and not to the number I forwarded to
  • Turn the phone off completely....same as above, it doesn't help
  • Forward to several different numbers including another AT&T wireless number and even a landline...It doesn't matter where I try to forward to, as soon as I turn on call forwarding all incoming calls just go directly to voicemail and not to the number I forwarded to.

Am I missing something here? As far as I can tell, call forwarding just plain doesn't work on AT&T, any attempt to turn on call forwarding will say it is on and then just forward all calls directly to voicemail.

 

Pleease help, I'm getting desperate.

 

Thanks

1,952 Views
Message 1 of 3
Administrator

Re: Call forwarding just does not work

Hi, @balst01,

 

We'd love to help with this. When you set up call forwarding before leaving the US, you don't suspend your service for the duration? If so, that would be the reason it isn't working. If that isn't the case, sign into your myAT&T account, go into the AT&T Troubleshoot & Resolve Tool (Call Forwarding), click on Next step, and follow the steps provided. If this doesn't help find the cause and solution, please let us know so that we can investigate further.

 

Have a great day!

 

James, AT&T Community Specialist


Need help?
Ask a question to get help from the AT&T Community or support from AT&T specialists. If this reply helped you please use Accept solution to mark it as an Accepted Solution.
*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 2 of 3
Teacher
Solution
Accepted by topic author
Accepted by balst01
‎07-19-2019 9:52 AM

Re: Call forwarding just does not work

After some playing around I managed to fix this problem.

 

The issue appears to be a forwarding priority problem. There are 4 types of call forwarding which are supported by AT&T and most devices, they are:

 

  • unconditional call forwarding
    Forward on busy
    Forward on unanswered
    Forward on unreachable

 

According to some earlier posts in other threads on this forum it is currently impossible to set anything other than unconditional yourself (even for unconditional I'm not sure, although it appears to work), apparently AT&T disabled this some time ago citing security concerns. So, in order to set the others, you need to call 611 and ask AT&T to do it for you.

 

So, to the issue. In my case (and I believe in most cases), the default call forwarding number for all of the various types of call forwarding is the voicemail number for AT&T (starts with 415 area code). What appears to happen if you try to set unconditional call forwarding yourself is that it appears to have worked, but when someone makes a call to the number, AT&T defines the phone to be unreachable, so, instead of forwarding to the unconditional call forwarding number, it forward directly to the unreachable call forwarding number, which is set to the voice-mail number, and the caller is directed immediately to voice-mail.

 

The way to fix this is to change the call forwarding for "unreachable", but as I mentioned earlier, you can't do this yourself; I have tried with both the phone settings and the MMI number (which BTW is very hard to find), both return some kind of error indicating that it cannot be done. So, you need to call AT&T and tell them, very specifically, that you would like to set *ONLY* your "forward on unreachable" to the number that you actually want to forward to. Now, when the caller calls the number, if you have set unconditional call forwarding, or you turn off your phone, or you set it to Airplane mode, or you take the SIM out and go to another country, your calls will be correctly forwarded directly to the "forward on unreachable" number, which is correctly set.

 

I have done this, and it works perfectly...it's easy to test, you just need to put your phone in airplane mode. 

 

To any Google Voice users, I have set mine to a Google Voice number, and it works perfectly. Now, if I have WiFi access in another country, or I put another SIM in my phone that has internet, I will be able to answer calls that come in to my AT&T wireless number on my Google Voice number.

 

Beware that the level 1 staff at the 611 line are completely clueless about this and they will try to send you a link to the set of instructions to do it yourself...they don't work; you need to insist that you want them to do it, and try to talk to one of the wireless experts who can actually set the correct call forwarding at their end. Be prepared with your IMEI number, they asked me for it for both lines.

Tags (1)
Message 3 of 3
Share this topic
Share this topic
Announcements

Do you need to fix, replace or track a device? We Can Help With That!

Additional Support