Explore & discover

Helpful Links

Set up auto pay, card was charged, but payment not credited to my prepaid account. Phone's shut off

Highlighted
Contributor

Set up auto pay, card was charged, but payment not credited to my prepaid account. Phone's shut off

I set up auto pay on my prepaid account on 11/19, my card was charged but my phone is now shut off and saying that my bill for 11/20 wasn't paid. I have proof from my bank as well as the automatic service (*611) that the payment was processed. What the heck is going on???

346 Views
Message 1 of 3
ACE - Sage

Re: Set up auto pay, card was charged, but payment not credited to my prepaid account. Phone's shut

You have to contact ATT for help. 

 

(The following is included after all posts to save typing) I don’t work for AT&T. My replies are based on experience and reading content available on the website. Our answers are honest, but not always appreciated. If you posted personal information, please edit and remove.
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 2 of 3
ACE - Expert

Re: Set up auto pay, card was charged, but payment not credited to my prepaid account. Phone's shut

Check your account to see how much is needed to renew. We have heard of autopay incorrectly charging what is needed to renew. It is possible autopay did work but just didn’t charge enough to cover taxes and fees. 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 3 of 3
Share this topic
Share this topic
Help with PREPAID phones & plans. View AT&T PREPAID Help!
Additional Support