Explore & discover

Helpful Links

New sim activation problems

Highlighted
Contributor

New sim activation problems

I just bought a sim for my phone and the 40$ AT&T prepaid subscription. Iv put the sim into my phone and have followed the instructions on on the back of the card but when I enter my pin number after typing *888*, it says invalid MMI number or connection problem. i don't think it is a connection problem as my phone indicates I have connection.

340 Views
Message 1 of 2
Administrator
Solution
Accepted by Administrator (Administrator)
Accepted by ATTKevin
‎07-01-2019 3:09 PM

Re: New sim activation problems

Hello, @goreilly121,

 

We'd love to help with this. Here are the steps to activate your new prepaid SIM and account. Click on the preceding link and follow the steps under Activate physical SIM online. If this doesn't help you, you will want to try to go to an AT&T Store for assistance.

 

Have a great week!

 

James, AT&T Community Specialist


Need help?
Ask a question to get help from the AT&T Community or support from AT&T specialists. If this reply helped you please use Accept solution to mark it as an Accepted Solution.
*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Tags (1)
Message 2 of 2
Share this topic
Share this topic
Announcements
NEW - Take a look at our best value & price ever for unlimited wireless - AT&T Unlimited Starter and AT&T Unlimited Extra plans!

Additional Support