No apps can connect to Internet but laptop says connection is fine

Scholar

No apps can connect to Internet but laptop says connection is fine

I have an Acer netbook that works like a charm on U-Verse at my home.  However, when I take it to my mother-in-law's condo (ATT U-Verse also), the netbook says it has a Wi-Fi connection but no applications (IE, Fire Fox, Skype) can find a way to connect to the outside world.

 

I have powered down the router and rebooted it but it still has the same issue.  The computer that uses CAT5 works fine.  Anyone have any ideas?

Message 1 of 4 (1,057 Views)
ACE - Master
Solution
Accepted by topic author stealth57
‎09-30-2015 1:39 AM

Re: No apps can connect to Internet but laptop says connection is fine

It sounds like one of 2 things to me.  Both are possible, and I have seen both fairly commonly with Windows XP...

 

The first is a DNS issue.  When you try to connect to a site like Google, your computer uses DNS to lookup the IP Address for Google.com and then uses that IP Addtess to connect.  If DNS isn't working properly, then it can never get the address, so it can't ever connect to the site you want.  The easy way to test this is to use a known IP address rather than the name, and see if your connection works.  Another way to check this would be to manually assign a DNS Server for your computer and use a public server like Google's which is at 8.8.4.4.

 

The second issue is a little more obscure to most.  For some reason, Windows XP, (and Windows 7 as well, but I haven't tried any newer Windows versions to see if they still have this) will not assign a proper IP Address to the computer.  In these cases, it gets a "Microsoft Private" address, and when this happens, you will not get any internet traffic routed.  This is easy to identify because when you look at your network connection properties, you see the assigned IP address is usually 169.*.  This one is difficult to resolve because nce your computer gets that address, it doesn't seem to want to give it up.  I have found that if I manually assign an address like 10.10.10.10 then change it back to Dynamic, it often resolves this, but not always...

 

There are many other possible causes, but these are teh two that I see the most.


Jerry B.
"GeekBoy"

--

For additional help, please send a PM to ATTCustomerCare.
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 2 of 4 (1,038 Views)
Scholar

Re: No apps can connect to Internet but laptop says connection is fine

Deleting the automatic login to the router did the trick....at least for now. Thanks.

Message 3 of 4 (992 Views)
Highlighted
Scholar

Re: No apps can connect to Internet but laptop says connection is fine

Well, that trick only worked once. Next day it didn't work.

Now using the Google DNS and it is working...we will see for how long.
Message 4 of 4 (945 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.