Explore & discover

Helpful Links

Why does echo dot keep losing connection?

Anonymous
Not applicable

Why does echo dot keep losing connection?

My Echo dot continuously loses its connection to Wi-Fi. Everything else on my Wi-Fi (laptop and phone) work perfectly fine. Whenever I reset my router or modem it connects just fine but then within 8-48 hours it loses the connection again and will not connect. I've been on the phone with amazon tech support several times and once we reset the router and it connects we end the call and then some hours later it loses its connection again so we never get to the base of the problem. We even looped in AT&T tech support on one of the calls and still nothing as all they did was remotely reset my modem and then when it connected they said great and ended the call. Then about a day later it disconnected again.

 

According to a thread i found on here apparently having the 2.4ghz and 5ghz connections named the same is the problem. But I tried renaming my 2.4 ghz connection and my echo dot has connected to it. Then just like an hour or so later it disconnected. All my other devices are still connected to the wifi.

 

Any suggestions would be awesome! Its so frustrating to buy something cool and not be able to use it!

 

102,642 Views
Message 1 of 86
ACE - Professor

Re: Amazon Echo Dot keeps losing connection to WiFi

Arris provides a decent MAC filtering function which I've used. Whitelist/blacklist by radio band to control how devices connect.  Probably not your problem but something to check.  Good luck .

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 31 of 86
Tutor

My devices keep losing connection to my Netgear router

I have a Netgear router supplied by At&t. We have DSL (fiber not an option at my address). The routher has been replaced twice (with the same model?) due to my complaints of devices dropping connection constantly. The majority of our amazon devices (Fire TV, Echo, Kindles) as well as my google pixel phone constantly lose connection. My phone will reestablish connection easily, however the amazon devices are another story. For example, my Echo will reconnect if i unplug it and then plug it back in, but then after playing a song or two, it loses connection again. HELP! When I contact At&t customer service, I get NOWHERE. Should I purchase a new router? Should I demand a different router be supplied by At&t? My current settings are: Channel 11, Mode: Mixed 11b,11g,11n, Security: WPA2-PSK(AES). Thanks for any assistance you can offer.

Message 32 of 86
Contributor

Re: Amazon Echo Dot keeps losing connection to WiFi

Thanks, that's probably really helpful if you know what RG stands for. No luck yet searching Google. Wish you'd taken just 7 seconds more to help those of us who don't know what you mean

Message 33 of 86
ACE - Professor

Re: Amazon Echo Dot keeps losing connection to WiFi

@Bishkek

Hello,  RG stands for residential gateway. It's the box supplied by AT&T that delivers services such as internet, TV, phone. Can be thought of as a combo modem and router. The router part allows connections to devices such as those from Amazon. These devices work best on 5GHz radio.  This thread attempts to guide folks into making this setup work correctly.

 

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 34 of 86
Contributor

Re: Amazon Echo Dot keeps losing connection to WiFi

Ah, that explains it, thanks gr8sho. I have AT&T wireless and an Echo but
don't have an Rg.

Message 35 of 86
ACE - Professor

Re: Amazon Echo Dot keeps losing connection to WiFi

You're quite welcome. BTW, solutions for making Amazon devices work correctly such as pinning a specific channel on 5GHz radio is not exclusive to AT&T internet. Other ISPs also need these tweaks as well.

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 36 of 86
Tutor

Re: Amazon Echo Dot keeps losing connection to WiFi

I have had same problem for several years and as I tried to add various devices w/o success decided to join this forum. Several replies were helpful and solved problem for me.

 

A few changes need to be made to your residential gateway aka RG (Att modem/router/wifi). Open router controls by typing 192.168.1.254 into your browser address bar. Click on Local Network > WiFi. You will be asked to enter the device password which is on the serial number label on the side of the modem/router. The WiFi window will show the 5.0 and 2.4 GHz radio configurations. I suggest setting the channel for the 5.0 radio to 149 or above and save the change. Keep the pw and name for the 5.0 and 2.4 radios the same as suggested by the warning in red letters. I would also turn ON the Guest network and assign a name and pw to it then save the changes.

 

I found my Nest thermostats now connect and stay connected to the ATT network. Amazon Echo, Google Home and Ring devices at least at my house either wouldn’t connect or wouldn’t stay connected to the ATT network. I connected them to the Guest Network and they connected quickly, stay connected and reconnect when the power is cycled. Apparently the security/firewall or some other setting on the main 5.0 and 2.4 channels prevent these devices from communicating through the modem because they all “see” the network but won’t connect to it. I guess the Guest network is less secure and allows more devices to easily connect.

 

An ATT employee did not recommend using the Guest network in this manner but it is the only solution that has worked so far for me. What a frustrating journey it has been but hopefully I’m on to other puzzles and challenges. Good luck.

Message 37 of 86
Tutor

Re: Amazon Echo Dot keeps losing connection to WiFi

"The WiFi window will show the 5.0 and 2.4 GHz radio configurations. I suggest setting the channel for the 5.0 radio to 149 or above and save the change. Keep the pw and name for the 5.0 and 2.4 radios the same as suggested by the warning in red letters. I would also turn ON the Guest network and assign a name and pw to it then save the changes."

I do not have these options with my RG. Help!

 

Message 38 of 86
Tutor

Re: Amazon Echo Dot keeps losing connection to WiFi

Specifically what option do you not have? Guest/2 radio bands/ability to reset/reconfigure your RG?

Message 39 of 86
Contributor

Re: Amazon Echo Dot keeps losing connection to WiFi

thanks, i don't have an RG, but a fiber optic 1gig internet and a Zhone
modem
Message 40 of 86
Tutor

Re: Amazon Echo Dot keeps losing connection to WiFi

The modem if it is also your wifi radio transmitter/router should be able to be configured with the settings previously mentioned ie static channel above 149 and probably has option for a guest network.
Message 41 of 86
Tutor

Re: Amazon Echo Dot keeps losing connection to WiFi

Amazon told me that the echo dot is not compatible with my router from AT&T.  My 3 fire tablets also will not connect. All 4 products are well over 2 years old, so I can't return them and now they're completely worthless. All products did connect to the WIFI once upon a time.I have 4 phones, Ipad, Firestick, and laptop that all will connect to the WIFI with the same router.  All products did connect to the WIFI once upon a time.  I've stayed on the phone over an hr with AT&T while they changed settings and checked everything on my router, nothing helped.  So frustrating!!!!

Message 42 of 86
ACE - Professor

Re: Amazon Echo Dot keeps losing connection to WiFi

@rebgirl8

Did you ever see the poster where it shows building a railroad from opposite ends but when the tracks meet, they are off by their own width?  That's what you're dealing with here.  And what's truly mind numbing is that after all these years, tech support from both ends are unable to advise customers.  Here's how to make it work.

 

From a web browser while connected to Ethernet or WiFi of your residential gateway, navigate to 192.168.1.254

Click Home Network and then select WiFi.

Click the radio button or selector to choose 5GHz.

Set the channel to 149.  Any value from 149 to 161 will work.

Your Amazon devices should connect to your network on their own.  Worst case is you need to restart them  They will perform better connected to the 5GHz radio.

 

As a precautionary and preliminary step, you could start the process by factory resetting your modem/router/gateway.  Accomplished by pressing the red button in back for more than 10 seconds.

 

I'm going out a bit on a limb as I didn't ask you what make model of RG you have, but chances are good you have one of the 3 newer ones and in their default state will cause havoc with Amazon  devices.

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 43 of 86
Tutor

Re: Amazon Echo Dot keeps losing connection to WiFi

Thank you for your reply!! I will try this when I'm home, but if I'm not mistaken my router only has the 2.5GHz option. Smiley Sad

Message 44 of 86
ACE - Professor

Re: Amazon Echo Dot keeps losing connection to WiFi

@rebgirl8

Not sure what tier of service you have there, but it would be best to have a BGW210,  NVG599, or 5268AC.  These are the latest RGs available and I list them in order of preference.  If you're using your devices to do video streaming, it will work better on 5GHz.

Good luck!

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 45 of 86
Share this topic
Share this topic
Announcements

Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!

Additional Support