Uverse Subnets & DHCP

Tutor

Uverse Subnets & DHCP

ATT Friday forced an upgrade on us from a DSL Line to Uverse Internet.

 

Our prior LAN settings were simple enough and worked great with the ATT Motorola modem/router.

 

The Router Access was 195.10.10.104 (having been changed from the default 192.168.1.254)

Subnet mask 255.255.255.0

DHCP Start Address 195.10.10.105

DHCP End Address 195.10.10.199

 

In trying to change the new router's settings:

Home Network> Subnets & DHCP > Private LAN Subet > Device IPv4 Address

 

When the preferred address is entered (195.10.10.104) we encounter an error of "Address must be on network (195.10.10.0)"

 

Was hoping the setup would be as simple as the previous time?  Any help?

 

Message 1 of 11 (15,725 Views)
Highlighted
Employee

Re: Uverse Subnets & DHCP

It sounds like your subnet mask is not correct.

 

default for (what used to be) a Class C address is the familiar "255.255.255.0"

 

If, for some reason, you subnetted that address, or if the provider gave you a small block of addresses (if you tell us how many, we can tell you the correct subnet mask), the mask will be something like 255.255.255.248 or 255.255.255.240

 

 

Employee Contributor*
*I am an AT&T employee and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 2 of 11 (15,722 Views)
Tutor

Re: Uverse Subnets & DHCP

you are right, I notice that the machine I am on that has been assigned an IP address using the DHCP shows the subnet mask as 255.255.255.240

 

The current settings on the NVG510 read:

 

Subnets & DHCP>

 

Device IPv4 Address: 192.168.1.254

Subnet Mask: 255.255.255.0

DHCPv4 Start Address: 192.168.1.64

DHCPv4 End Address: 192.168.1.253

 

again, I'd just like to alter the Device Address to 195.10.10.104 and change the start and end addresses.

 

 

 

Message 3 of 11 (15,719 Views)
Tutor

Re: Uverse Subnets & DHCP

[ Edited ]
 
Message 4 of 11 (15,708 Views)
Expert

Re: Uverse Subnets & DHCP

Why are you trying to use 195.10.10.x on your LAN? These are registered IP addresses that are used in Europe, they're not supposed to be assigned to your LAN.
Message 5 of 11 (15,696 Views)
Tutor

Re: Uverse Subnets & DHCP

largely because they have been this way for years. 1/2 the machines on the network use a fixed IP address, printers are setup with fixed IP addresses etc. It is an effort to change all of the machines.
Message 6 of 11 (15,692 Views)
Tutor

Re: Uverse Subnets & DHCP

Not sure why it should matter why my private LAN settings are?
Message 7 of 11 (15,683 Views)
Tutor

Re: Uverse Subnets & DHCP

Certainly appreciate all the help.

 

Here is as much detail as I can think of (not networking expert).  Trying to get things back as close to OLD SETTINGS as possible (after DSL switched out for uVerse).

 

OLD SETTINGS (ATT DSL):


Netopia-3000, model 3347-02, software version 7.8.1r2

 

LAN IP Interface >

Enable Interface - checked

IP Address 195.10.10.104 (changed from default of 192.168.1.254)

IP Netmask 255.255.255.0

Restrictions - none

 

no advanced settings, no IP Subnets

 

DHCP Server >

Server mode - Server

Starting IP Address 195.10.10.105

Ending IP Address 195.10.10.199

Lease Period 01:00:00:00

 

WAN IP Interfaces

PPP over Ethernet vcc1

Enable Gateway option -checked

Interface Type PPP vcc1

 

WAN IP Interface (PPP over Ethernet vcc1) settings >

Enable Interface - checked

Address mapping (NAT) - checked

Restrictions - none

ISP Username xxxx

ISP Password xxxx

Connection Type - always on

 

DNS >

Domain Name att.net

Primary DNS 68.94.156.1

Secondary DNS 68.94.157.1

 

***

NEW SETTINGS (ATT UVERSE, as per ATT installer departure from premisis)

 

Device and Broadband settings as per ATT installer & working.

 

Home Network Status >
Device IPv4 Address192.168.1.254
DHCPv4 Netmask255.255.255.0
DHCPv4 Start Address192.168.1.64
DHCPv4 End Address192.168.1.253
DHCP Leases Available197
DHCP Leases Allocated6
DHCP Primary PoolPublic

 

Configure > ports 1-4 all auto

Wireless - working

Mac Filters - none assigned

 

Private LAN Subnet

 
Device IPv4 Address 192.168.1.254
Subnet Mask 255.255.255.0
 
DHCPv4 Start Address 192.168.1.64
DHCPv4 End Address 192.168.1.253

 

Is it possible to replicate what we had previously "OLD SETTINGS" and have the DHCP server issuing IP addresses in the 195.10.10.xxx ranges?  When trying to do so, error message is.

 

Address must be on network (192.168.1.0)

 

 

Message 8 of 11 (15,633 Views)
Expert
Solution
Accepted by SomeJoe7777 (Expert)
‎09-30-2015 1:39 AM

Re: Uverse Subnets & DHCP


lanhlp wrote:
Not sure why it should matter why my private LAN settings are?

 

Because 195.10.10.x is not a private LAN.  Those IP addresses belong to someone else, assigned to them by RIPE (IP addressing registry for Europe).  If you were to try to pull up a web site hosted by the company that owns those IP addresses, you wouldn't be able to because your internal routing wouldn't properly route the request.

 

IP addressing is handled by international numbering authorities and is very specific in the way they're handed out.  You can't just "pick" some addresses at random and use them.  It doesn't matter if your network has been set up this way for years, that still doesn't make it any less wrong.

 

Unless you have hundreds of devices on static IP addresses, renumbering a network doesn't take very long.  I have at least 10 devices on static IPs in my house (another 10-15 on DHCP), and renumbering would take me less than an hour.

 

RFC1918 specifies that you have 3 IP address ranges that are designated for private IP addressing that you can use however you see fit and can subnet however you see fit.  AT&T allows you to use 2 of those 3 ranges:

 

192.168.0.0/16 is one block.  Typically this is subnetted into class C-sized address space, like 192.168.1.0/24.

 

172.16.0.0/12 is the 2nd block.  Same rules apply, usually it's subnetted into class C-sized address space.

 


As an example, you could use 192.168.245.0/24.  This means that you would configure as follows:

 

Router (2Wire gateway): 192.168.245.254

Subnet masl: 255.255.255.0

Static IP addresses: 192.168.245.1 through 192.168.245.63

DHCP range: 192.168.245.64 through 192.168.245.253

 

For static IP devices, just pick an IP address in the static range.  All of those devices also get 255.255.255.0 as their subnet mask and 192.168.245.254 as their gateway.  For DNS, you can use the 2Wire gateway itself (192.168.245.254), or if you want you can use Google DNS (8.8.8.8 and 8.8.4.4) or OpenDNS (208.67.222.222 and 208.67.220.220).

 

 

Message 9 of 11 (15,603 Views)
Tutor

Re: Uverse Subnets & DHCP

I tried this and I get the error Address must be on network (192.168.245.0) Device IPv4 Address 192.168.245.254 Subnet Mask 255.255.255.0 DHCPv4 Start Address 192.168.1.64 DHCPv4 End Address 192.168.1.253
Message 10 of 11 (11,174 Views)
Tutor

Re: Uverse Subnets & DHCP

Sorry I meant for the start and end I used: DHCPv4 Start Address 192.168.245.64 DHCPv4 End Address 192.168.245.253
Message 11 of 11 (11,172 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.