NVG510 - Remote Desktop

NVG510 - Remote Desktop

I have U-verse DSL installed with a NVG510 that connects to a computer that successfully connects to the internet.

 

I need the computer to be accessable using the public IP address assigned to the NVG510 in order to access the computer's various services including Remote Desktop,

 

Following instructions from other posts on this forum and the discriptions in the NVG510 maintenance screens, I have tried various configurations related to Passthrough.  The computer is successfully using the NVG510's IP address, but that address isn't reachable from anywhere.  I've tried Ping and Remote Desktop from my home (which is connected through Comcast) and I've tried from a laptop connected to the same NVG510, but a different ethernet port.

 

What might I be missing?

 

At home, the computer connected to Comcast simply receives a external IP address from the Comcast box.

I had thought that I could replace Comcast with U-verse and retand the same functionality, but how to configurate the NVG510 is the bug question.

Message 1 of 9 (8,233 Views)

Re: NVG510 - Remote Desktop

You should be able to use the "DHCP - fixed" IP passthrough mode:

 

To Enable IP Passthrough DHCPS - fixed

  1. Launch a web browser, such as Internet Explorer, Firefox, or Safari.  Enter http://192.168.1.254 into the address box, and press the Enter key.  The Status page appears. Click the Firewall link from the top menu.  The Firewall page appears. 

Click the IP Passthrough sub-menu link.  The IP Passthrough page appears. 

On the IP Passthrough page:
a.   Allocation Mode - Click the drop-down tab and select Passthrough.
b.   Passthrough Mode - Click the drop-down tab and select DHCPS - fixed.
c.   Passthrough Fixed MAC Address - Enter the MAC address of the device that is designated to be the IP Passthrough client.
d.   Click the Save button.

The Changes saved note appears.  Click the restart link.
The Restart Device page appears.  Click the Restart button.


 

If that is not working, try the "default server" IP passthrough mode:

 

To Enable Default Server

  1. Launch a web browser, such as Internet Explorer, Firefox, or Safari.  Enter http://192.168.1.254 into the address box, and press the Enter key.  The Status page appears.

  2. Click the Firewall link from the top menu.  The Firewall page appears. 
  3. Click the IP Passthrough sub-menu link.  The IP Passthrough page appears. 
  4. On the IP Passthrough page:
         a.   Allocation Mode - Click the drop-down tab and select Default Server.
         b.   Default Server Internal Address - Enter the device's Internal address.
         c.   Click the Save button.

    NOTE: A restart is not required, as the settings will immediately go into effect.

 




__________________________________________________________
How can you be in two places at once, when your not anywhere at all?
------------------------------------------------------------------------------------------------------
I really want to become a procrastinator, but I keep putting it off.
------------------------------------------------------------------------------------------------------
There are three kinds of people, those that can count, and those that can't.
------------------------------------------------------------------------------------
“Our great democracies still tend to think that a stupid man is more likely to be honest than a clever man, and our politicians take advantage of this prejudice by pretending to be even more stupid than nature has made them." :Bertrand Russell

                              

Message 2 of 9 (8,223 Views)

Re: NVG510 - Remote Desktop

Looks pretty straightforward.

 

Won't be untill tomorrow that I can try your suggestions.

 

Are these modes mutually exclusive?

 

Can't remember excectly the settings I used, but *seems* like the IP Passthrough Firewall settings are what I did.

 

The second suggestion for Default server is less clear wheather I may have tried.

 

Hopefully I will se eather that I overlooked one of  the settings that you've suggested or that I have clearly used the same setting for Firewall IP Passthrough and can try your second suggestion.

 

Also, Hopefully I have not "hacked" some other settings in my trial-error attempts.

Message 3 of 9 (8,211 Views)

Re: NVG510 - Remote Desktop


waltersaegir wrote:

Looks pretty straightforward.

 

Won't be untill tomorrow that I can try your suggestions.

 

Are these modes mutually exclusive?  

Yes

 

Can't remember excectly the settings I used, but *seems* like the IP Passthrough Firewall settings are what I did.

 

The second suggestion for Default server is less clear wheather I may have tried.

 

Hopefully I will se eather that I overlooked one of  the settings that you've suggested or that I have clearly used the same setting for Firewall IP Passthrough and can try your second suggestion.

 

Also, Hopefully I have not "hacked" some other settings in my trial-error attempts.



Well, there is the Firewall route as well. If you go to "Firewall" -> "NAT Gaming" you can set up individual port forwards for all kinds of applications. You can forward multiple ports to the same device, but you can't forward the same port to multiple devices

 

The IP passthrough modes will only affect one device on your network, all other connected devices will receive standard DHCP addressing from the NVG.

 

 




__________________________________________________________
How can you be in two places at once, when your not anywhere at all?
------------------------------------------------------------------------------------------------------
I really want to become a procrastinator, but I keep putting it off.
------------------------------------------------------------------------------------------------------
There are three kinds of people, those that can count, and those that can't.
------------------------------------------------------------------------------------
“Our great democracies still tend to think that a stupid man is more likely to be honest than a clever man, and our politicians take advantage of this prejudice by pretending to be even more stupid than nature has made them." :Bertrand Russell

                              

Message 4 of 9 (8,204 Views)

Re: NVG510 - Remote Desktop

Looked at my IP Passthrough DHCPS Fixed parameters and they seemed to agree with your suggestions.

Then I configured Default Server passthrough mode.(used the IP address from IPConfig that DHCP provided, as the server address) then I added the Firewall -> "NAT Gaming" configuration for Remote Desktop.
RemoteDesktop works only if I use the IP address from DHCP (192.168.xxx.xxx) or the machine name (which also is in the NVG Device List.
Can't ping nor RemoteDesktop to the NVG's IP (108.202.74.XXX).
The NVG's IP address seems to be invisible to the public Internet.
Message 5 of 9 (8,179 Views)
Solution
Accepted by topic author waltersaegir
‎09-30-2015 1:39 AM

Re: NVG510 - Remote Desktop


waltersaegir wrote:
Looked at my IP Passthrough DHCPS Fixed parameters and they seemed to agree with your suggestions.

Then I configured Default Server passthrough mode.(used the IP address from IPConfig that DHCP provided, as the server address) then I added the Firewall -> "NAT Gaming" configuration for Remote Desktop.
RemoteDesktop works only if I use the IP address from DHCP (192.168.xxx.xxx) or the machine name (which also is in the NVG Device List.
Can't ping nor RemoteDesktop to the NVG's IP (108.202.74.XXX).
The NVG's IP address seems to be invisible to the public Internet.

I don't think you should be using the "Default Server" mode and port forwards simultaniously to the same device. Try the "Default Server" by itself.

 

I don't think the NVG510 supports "Loopback". In other words, you will not be access your sever using public addresses from behind the NVG.

 

 




__________________________________________________________
How can you be in two places at once, when your not anywhere at all?
------------------------------------------------------------------------------------------------------
I really want to become a procrastinator, but I keep putting it off.
------------------------------------------------------------------------------------------------------
There are three kinds of people, those that can count, and those that can't.
------------------------------------------------------------------------------------
“Our great democracies still tend to think that a stupid man is more likely to be honest than a clever man, and our politicians take advantage of this prejudice by pretending to be even more stupid than nature has made them." :Bertrand Russell

                              

Message 6 of 9 (8,174 Views)

Re: NVG510 - Remote Desktop

Thursday, I can do more testing with your suggestions.

Message 7 of 9 (8,157 Views)

Re: NVG510 - Remote Desktop

192.168.0.2 when it should have been 192.168.1.2.

When I made the correction, everything started working.

Thanks for your help.
Message 8 of 9 (8,097 Views)
Contributor

Re: NVG510 - Remote Desktop

Oddly enough, IP Passthrough worked for me.  Thanks, Computer-Joe!

Message 9 of 9 (1,417 Views)