Explore & discover

Helpful Links

How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Teacher

How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Overview

Most people don't need advanced features that personally owned routers offer and will be just fine using the NVG589 and turning off their personally owned router.  But if you're like me (and I know I am!) then you are probably reading this thread because you have ip cameras, personal clouds, photo servers, guest wifi, VPN's, xbox, QOS settings, et al.  I have an ASUS RT-N66U , a VIP2250, and a wireless reciever with a WAP; but your settings should be similar. 

 

The NVG589 does not have a simple 'Bridge mode' setting so you will need to get into weeds to get this working.  I hope you're ready.

 

First Steps

Make sure you have a laptop or a computer that you can connect directly into the NVG589.

Unplug all ethernet cables from the NVG589 except for the one going into the aforementioned laptop.

Write down the MAC address of your personal router (the WAN MAC address if you see different ones for LAN and WAN)

 

Settings on the NVG589

  • Login to your NVG589 by going to 192.168.1.254
  • Go to 'Home Network' then 'Subnets & DHCP'.  Your password is on the side of the modem.
  • If your 'Device IPv4 Address' is the same subnet as your local router, I suggest changing it.  I changed mine to 192.169.2.254 but you can stick with whatever you like / need.  My subnet Mask remains at 255.255.255.0
  • Change 'DHCPv4 Start Address' to 192.169.2.1 (or whatever your above Device IPv4 address is but with a 1 at the end instead of .254)
  • Change 'DHCPv4 End Address' to 192.169.2.5, Just a few more than the Start Address.  We need these for any WAP extenders for wifi TV's.  It's important that you only have the laptop plugged into the ethernet at this point.
  • Click 'SAVE' at the bottom.
  • Go to 'Home Network'  then 'Wireless' and turn wireless off.  You want to use the wifi on your own router right?
  • Go to 'Firewall' then ' 'Packet Filter'.  Disable Packet Filters.  Again, we want our router to do the work.
  • Make sure you don't have any of your own settings turned on in 'NAT/Gaming' (don't worry if you see 1 in there already that you can't delete).
  • Go to 'Firewall' then 'IP Passthrough'.  For 'Default Server Internal Address', select or type in 192.169.2.1.
  • For 'Allocation Mode' select 'Passthrough' (I had to do it in this reverse order to be able to type for some reason)
  • For 'Passthrough Mode', select 'DHCPS-Fixed'
  • Type in the MAC address for your router under 'Manual Entry', lowercase is fine.
  • Click SAVE.  It will tell you that it needs to reboot.  Hang on for a minute.
  • Go to 'Firewall Advanced' at the top and turn everything OFF.
  • Near the top of your screen, you should see an option telling you to reboot the router. Go ahead and do this now. It takes about 2 minutes.

Personal Router Settings.

 

  • Unplug your laptop and plug in your personal router while the NVG589 reboots.  
  • Plug your laptop into your personal router and login to it.  For me, it was 192.168.1.1 (hence why I changed things above)
  • For the ASUS RT-N66U, I had to go to my WAN settings, then 'Internet Connection'.
  • Change 'WAN Connection Type' to 'Automatic IP'.  This will give your personal router the external IP of the NVG589 and is the key to making this whole thing work. Some folks will have to manually enter in an IP and this can be found under the 'Broadband - Status' section of the NVG589 settings.  If you don't have 'automatic IP' then I feel bad for you since you will have to manually change this every time your IP changes.
  • 'Enable WAN', 'Enable NAT' and 'Enable UPnP' is all set to YES for me.  
  • I recomend Setting your own DNS server.  I use Google's but you use whatever you like.  Google's is 8.8.8.8 and 8.8.4.4
  • 'Account Setting - Authentication' is 'None'.
  • There are no Special requirements from ISP at the bottom.
  • Hit APPLY at the bottom and your router will reboot.

I also changed settings in my IPTV under LAN:

  • Profile was None.
  • Choose IPTV STB port, I set to LAN3 & LAN4.  I plugged my U-Verse WAP for the wireless reciver into the NVG589 and I plugged the ethernet cable going to the VIP2250 into LAN3 on my personal router.  I'm really not sure if this was necessary but I'm having 0 issues with this setup.  I initially tried putting the WAP on my personal router but had issues so I stuck it back on the NVG589 and it's fine.  I could probably just plug the VIP2250 into the NVG589 as well but I'm just enjoying the small victory of using my personal router for now.  
  • Hit apply at the bottom, another possible reboot.

At this point, I checked the internet and everything was working great through the router.  I restarted by 2 TV boxes (the VIP and the wifi ones).  Everything is peachy.

 

Your mileage may vary.  Good luck.

 

 

 

 EDIT to update WAP configuration. 

 

555,921 Views
Message 1 of 280
Contributor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).


@frostcall wrote:

Overview

Most people don't need advanced features that personally owned routers offer and will be just fine using the NVG589 and turning off their personally owned router.  But if you're like me (and I know I am!) then you are probably reading this thread because you have ip cameras, personal clouds, photo servers, guest wifi, VPN's, xbox, QOS settings, et al.  I have an ASUS RT-N66U , a VIP2250, and a wireless reciever with a WAP; but your settings should be similar. 

 

The NVG589 does not have a simple 'Bridge mode' setting so you will need to get into weeds to get this working.  I hope you're ready.

 

First Steps

Make sure you have a laptop or a computer that you can connect directly into the NVG589.

Unplug all ethernet cables from the NVG589 except for the one going into the aforementioned laptop.

Write down the MAC address of your personal router (the WAN MAC address if you see different ones for LAN and WAN)

 

Settings on the NVG589

  • Login to your NVG589 by going to 192.168.1.254
  • Go to 'Home Network' then 'Subnets & DHCP'.  Your password is on the side of the modem.
  • If your 'Device IPv4 Address' is the same subnet as your local router, I suggest changing it.  I changed mine to 192.169.2.254 but you can stick with whatever you like / need.  My subnet Mask remains at 255.255.255.0
  • Change 'DHCPv4 Start Address' to 192.169.2.1 (or whatever your above Device IPv4 address is but with a 1 at the end instead of .254)
  • Change 'DHCPv4 End Address' to 192.169.2.5, Just a few more than the Start Address.  We need these for any WAP extenders for wifi TV's.  It's important that you only have the laptop plugged into the ethernet at this point.
  • Click 'SAVE' at the bottom.
  • Go to 'Home Network'  then 'Wireless' and turn wireless off.  You want to use the wifi on your own router right?
  • Go to 'Firewall' then ' 'Packet Filter'.  Disable Packet Filters.  Again, we want our router to do the work.
  • Make sure you don't have any of your own settings turned on in 'NAT/Gaming' (don't worry if you see 1 in there already that you can't delete).
  • Go to 'Firewall' then 'IP Passthrough'.  For 'Default Server Internal Address', select or type in 192.169.2.1.
  • For 'Allocation Mode' select 'Passthrough' (I had to do it in this reverse order to be able to type for some reason)
  • For 'Passthrough Mode', select 'DHCPS-Fixed'
  • Type in the MAC address for your router under 'Manual Entry', lowercase is fine.
  • Click SAVE.  It will tell you that it needs to reboot.  Hang on for a minute.
  • Go to 'Firewall Advanced' at the top and turn everything OFF.
  • Near the top of your screen, you should see an option telling you to reboot the router. Go ahead and do this now. It takes about 2 minutes.

Personal Router Settings.

 

  • Unplug your laptop and plug in your personal router while the NVG589 reboots.  
  • Plug your laptop into your personal router and login to it.  For me, it was 192.168.1.1 (hence why I changed things above)
  • For the ASUS RT-N66U, I had to go to my WAN settings, then 'Internet Connection'.
  • Change 'WAN Connection Type' to 'Automatic IP'.  This will give your personal router the external IP of the NVG589 and is the key to making this whole thing work. Some folks will have to manually enter in an IP and this can be found under the 'Broadband - Status' section of the NVG589 settings.  If you don't have 'automatic IP' then I feel bad for you since you will have to manually change this every time your IP changes.
  • 'Enable WAN', 'Enable NAT' and 'Enable UPnP' is all set to YES for me.  
  • I recomend Setting your own DNS server.  I use Google's but you use whatever you like.  Google's is 8.8.8.8 and 8.8.4.4
  • 'Account Setting - Authentication' is 'None'.
  • There are no Special requirements from ISP at the bottom.
  • Hit APPLY at the bottom and your router will reboot.

I also changed settings in my IPTV under LAN:

  • Profile was None.
  • Choose IPTV STB port, I set to LAN3 & LAN4.  I plugged my U-Verse WAP for the wireless reciver into the NVG589 and I plugged the ethernet cable going to the VIP2250 into LAN3 on my personal router.  I'm really not sure if this was necessary but I'm having 0 issues with this setup.  I initially tried putting the WAP on my personal router but had issues so I stuck it back on the NVG589 and it's fine.  I could probably just plug the VIP2250 into the NVG589 as well but I'm just enjoying the small victory of using my personal router for now.  
  • Hit apply at the bottom, another possible reboot.

At this point, I checked the internet and everything was working great through the router.  I restarted by 2 TV boxes (the VIP and the wifi ones).  Everything is peachy.

 

Your mileage may vary.  Good luck.

 

 

 

 EDIT to update WAP configuration. 

 


Thank you sooooo much!!!!!

Message 76 of 280
Scholar

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).


@MoInSTL wrote:

 

 

You can leave the NVG IP adress the default if that's easier for you.  Just make sure the router is set to 192.168.2.1 for example.

 


Ok so  in that case what would you want to have the "Default Server Internal Address" set as ? 192.168.1.254 ? My router is already using 192.168.27.1 so i dont need to change the NVG, i just am not clear on what the correct entry should be in the "Default Server Internal Address"...also, any tips for having devices able to "talk" see PC's connected on both sides, from NVG to Router?Thanks

Message 77 of 280
Scholar

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Let me ask this in a better way, should the "Default Server Internal Address" be the same as my "Device IPv4 Address" or my "DHCPv4 Start Address"? Right now after setting ip passthrough it seems to have incorrectly set itself to the ip of a random device on my LAN, and although all is working i need to clarify on how it should be set so i can set it back properly. THANK YOU ALL

Message 78 of 280
Scholar

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

I will be the first to admit i dont know jack about this stuff, especially compared to some of the contributors to this thread, but the lanuage in this description seems TO ME like the "default server internal address" should actually be set to the personal router's IP, or the LAN IP of whatever device you want to receive the "unexpected or unknown traffic"...though i must also admit i am not sure what is meant by that entirely so who knows

 

Screenshot 2014-09-27 07.25.34.png

Message 79 of 280
ACE - Expert

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

The description says it pretty well.  If you have a router behind the RG, then you want the unsolicited Internet raffic that comes from the RG's external port to be sent to your router.  Thus, you give your router's LAN address (WRT to the RG).

Keep in mind that when you have the RG and a router, you have two different address spaces, one is the LAN for the RG and the WAN for the router, the second is the LAN for the router.  It sounds like you want your router's internal LAN address to stay on the 192.168.27.0/32 subnet at 192.168.27.1, and that's fine.  All of your existing equipment can stay on the 192.168.27.0/32 subnet.  Your router and the RG will communicate with each other on the 192.168.1.0/32 subnet.  The RG will use 192.168.1.254 and your router will use another address on the 192.168.1.0/32 subnet, by default it will request it from the RG via DHCP.  If you turn on DMZplus mode with respect to your router, then your router will assigned your external public address its WAN side, which removes double-NAT.

 

Award for Community Excellence 2019 Achiever*
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 80 of 280
Scholar

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Thank you. I am feeling especially stupid/ignorant here so forgive me. I have followed all the steps here & my RG is still set to 192.168.1.254 & my router is 192.168.27.1 with my WAN assigned to it via the IP Passthrough feature. Since i Kept the RG as 192.168.1.254 what should be in the "Default Server Internal Address" Field? In the OP example it uses 192.168.2.1 which is OP's IPV4 Starting address, on my NVG589 the IPv4 Start address is 192.168.1.3 so if i understand correctly that is what i should put in this field? I cant leave it blank either because when i did that it populated it with a random client IP (192.168.1.81) on my LAN as shown below and i just want to be sure of what it should be set as before i change the entry.

 

If you already answered this or alluded to an answer in your first reply please forgive me, it just isnt clear to me from that reply which is likely my own fault for not making it clear what my main question was. 

 

Screenshot 2014-09-27 16.33.17.png

Message 81 of 280
Scholar

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Also, This portion of this post from the 2nd page of this thread is causing me some confusion as to whether that "Default Server Internal Address" Field should be populated with an IP from the RG or the public router, as this post seems to suggest its LAN IP of the personal router which conflicts w/all other instructions. So what IP should go there? Again thank you.

 http://forums.att.com/cng/board/message?board.id=uverse-HSIA&message.id=42005#M42005

 

Screenshot 2014-09-27 16.55.53.png

Message 82 of 280
ACE - Expert

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

A large part of the confusion on 192.168.1.xxx and 192.168.2.xxx is because the OP decided to change his RG from 192.168.1.254 to 192.168.2.254, which means all his references list 192.168.2.xxx for the private LAN between the RG and the router.  To quote

@frostcall wrote:

your 'Device IPv4 Address' is the same subnet as your local router, I suggest changing it. I changed mine to 192.169.2.254 but you can stick with whatever you like / need.

You need the RG's LAN and your router's LAN to be different.  You can change either one.  I recommend you change the router's LAN unless you already have a lot of stuff configured behind your router on 192.168.1.xxx.  You already have stuff configured on 192.168.27.xxx, so you don't need to rename the RG's LAN.  But you could, if you're more comfortable following his instructions that way.  If so, then replace his 192.168.1.xxx with 192.168.27.xxx and rename the RG's LAN as instructed.

Personally, I wish he had not done it that way, but I won't complain too much because he was nice enough to document what he did, that worked for him, and he has an NVG 589 to document and I don't.

 

Award for Community Excellence 2019 Achiever*
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 83 of 280
Scholar

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Thanks that makes sense, but what about the "Default Server Internal Address", what should go in that field for someone who left the RG as 192.168.1.254 ?

Message 84 of 280
Contributor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Add me to the list of those that have managed to get traffic from the NVG589 through a personal router (mine's a Tenda.) However, I'm also unable to get any of my ports forwarded.

 

I had no issue with my 2Wire. My IP cams were successfully forwarded so that I could access from my phone. I upgraded to 45Mbps this week and have been battling this ever since. I've been remoting into my laptop to get on my home network to see my cams.

 

 

My RG Settings

WIFI Off.

 

I left DHCPv4 Address as 192.168.1.254

Subnet Mask: 255.255.255.0

DHCPv4 Start Address: 192.168.1.1

DHCPv4 Start Address: 192.168.1.5

 

Passthrough

Default Server Internal Address: 192.168.1.1

DHCPS Fixed

Tenda MAC address entered

Everything off in Firewall Advanced

 

 

Tenda Router

192.168.2.1

255.255.255.0

 

I forwarded the ports to the proper IPs. There really isn't much to it. I can't see where I'd be missing something on that specific screen.

 

I checked my laptop local IP and it is on 192.168.2

 

I assigned static IPs to my cams. I can see them locally via the Tenda WiFi, but not through the public IP. Canyouseeme.org and the PortForward.com utility both say the ports are not open. I tried forwarding a port to my laptop to see if it was the cams. No dice.

 

I'd just as soon use the NVG alone if those ports would forward, but they wouldn't. Well, at least not consistently/reliably. I did get one to say it was open briefly, and I saw the camera, but it spontaneously closed while I was using it and I lost the connection. The network didn't go down, just the port closed. I verified with canyouseeme that it closed and it never came back while I was trying to see it.

 

I'm open to suggestions as I've been trying for days and every search on the net leads back to this thread.

 

TIA

Message 85 of 280
Scholar

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Starting to wonder if its just a simple matter of nobody even knowing what "Default Server Internal Address" means, & therefore cant really tell me with certainty what should go in that field for a RG that is kept as 192.168.1.254 & a ipV4 starting address of 192.168.1.3...if anyone does please let me know, thanks 

Message 86 of 280
ACE - Expert

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

The answer is wherever you want unsolicited traffic that is not otherwise handled and passes the firewall filter to go.  Probably nowhere.

 

Award for Community Excellence 2019 Achiever*
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 87 of 280
Contributor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

From what I have learned, which could be completely coincidental, the default internal server address should be your 3rd party router's address.  When I had it set to the 192.169.2.1, as OP had suggested, I could not get the internet to work on some of my devices.  When I set it back to my Asus router's 192.168.1.1, then all devices worked properly.  I hope that helped.  I haven't been on this thread in a long time, and I had to reset everything because my Uverse was shut off temporarily.  Now that it's back, I think I'm up to speed on this excellent bookmarked thread.  Good luck with your setup! Smiley Happy

Message 88 of 280
ACE - Expert

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).


@moonatics wrote:

From what I have learned, which could be completely coincidental, the default internal server address should be your 3rd party router's address.  When I had it set to the 192.169.2.1, as OP had suggested, I could not get the internet to work on some of my devices.  When I set it back to my Asus router's 192.168.1.1, then all devices worked properly.  I hope that helped.  I haven't been on this thread in a long time, and I had to reset everything because my Uverse was shut off temporarily.  Now that it's back, I think I'm up to speed on this excellent bookmarked thread.  Good luck with your setup! Smiley Happy


You are correct that the default internal address should be your 3rd party router's address.  If you change the RG's LAN address range to 192.168.2.0/24 (as the OP did), then you would need to configure your 3rd party router to use 192.168.2.1 as its WAN address, and set up the 192.168.1.0/24 as it's LAN address range. The default internal address would be 192.168.2.1 in that case.

Conversely, if you (like most people do who don't already have an established network behind their 3rd party router) leave the RG's LAN address range at 192.168.1.0/24 (as it comes from the factory), then you would configure you 3rd party's WAN address to 192.168.1.1 and use that as the default internal address.

 

Award for Community Excellence 2019 Achiever*
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 89 of 280
Contributor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

I just performed this on the Airport Extreme and it works great!  I'm getting 50Mbps download from the Macbook Air through the new 10.0. network with the NVG in pass-through.  Thanks for this thread.

Message 90 of 280
Share this topic
Share this topic
Announcements...

Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!

Additional Support