Explore & discover

Helpful Links

How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Announcements...
Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!
Teacher

How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Overview

Most people don't need advanced features that personally owned routers offer and will be just fine using the NVG589 and turning off their personally owned router.  But if you're like me (and I know I am!) then you are probably reading this thread because you have ip cameras, personal clouds, photo servers, guest wifi, VPN's, xbox, QOS settings, et al.  I have an ASUS RT-N66U , a VIP2250, and a wireless reciever with a WAP; but your settings should be similar. 

 

The NVG589 does not have a simple 'Bridge mode' setting so you will need to get into weeds to get this working.  I hope you're ready.

 

First Steps

Make sure you have a laptop or a computer that you can connect directly into the NVG589.

Unplug all ethernet cables from the NVG589 except for the one going into the aforementioned laptop.

Write down the MAC address of your personal router (the WAN MAC address if you see different ones for LAN and WAN)

 

Settings on the NVG589

  • Login to your NVG589 by going to 192.168.1.254
  • Go to 'Home Network' then 'Subnets & DHCP'.  Your password is on the side of the modem.
  • If your 'Device IPv4 Address' is the same subnet as your local router, I suggest changing it.  I changed mine to 192.169.2.254 but you can stick with whatever you like / need.  My subnet Mask remains at 255.255.255.0
  • Change 'DHCPv4 Start Address' to 192.169.2.1 (or whatever your above Device IPv4 address is but with a 1 at the end instead of .254)
  • Change 'DHCPv4 End Address' to 192.169.2.5, Just a few more than the Start Address.  We need these for any WAP extenders for wifi TV's.  It's important that you only have the laptop plugged into the ethernet at this point.
  • Click 'SAVE' at the bottom.
  • Go to 'Home Network'  then 'Wireless' and turn wireless off.  You want to use the wifi on your own router right?
  • Go to 'Firewall' then ' 'Packet Filter'.  Disable Packet Filters.  Again, we want our router to do the work.
  • Make sure you don't have any of your own settings turned on in 'NAT/Gaming' (don't worry if you see 1 in there already that you can't delete).
  • Go to 'Firewall' then 'IP Passthrough'.  For 'Default Server Internal Address', select or type in 192.169.2.1.
  • For 'Allocation Mode' select 'Passthrough' (I had to do it in this reverse order to be able to type for some reason)
  • For 'Passthrough Mode', select 'DHCPS-Fixed'
  • Type in the MAC address for your router under 'Manual Entry', lowercase is fine.
  • Click SAVE.  It will tell you that it needs to reboot.  Hang on for a minute.
  • Go to 'Firewall Advanced' at the top and turn everything OFF.
  • Near the top of your screen, you should see an option telling you to reboot the router. Go ahead and do this now. It takes about 2 minutes.

Personal Router Settings.

 

  • Unplug your laptop and plug in your personal router while the NVG589 reboots.  
  • Plug your laptop into your personal router and login to it.  For me, it was 192.168.1.1 (hence why I changed things above)
  • For the ASUS RT-N66U, I had to go to my WAN settings, then 'Internet Connection'.
  • Change 'WAN Connection Type' to 'Automatic IP'.  This will give your personal router the external IP of the NVG589 and is the key to making this whole thing work. Some folks will have to manually enter in an IP and this can be found under the 'Broadband - Status' section of the NVG589 settings.  If you don't have 'automatic IP' then I feel bad for you since you will have to manually change this every time your IP changes.
  • 'Enable WAN', 'Enable NAT' and 'Enable UPnP' is all set to YES for me.  
  • I recomend Setting your own DNS server.  I use Google's but you use whatever you like.  Google's is 8.8.8.8 and 8.8.4.4
  • 'Account Setting - Authentication' is 'None'.
  • There are no Special requirements from ISP at the bottom.
  • Hit APPLY at the bottom and your router will reboot.

I also changed settings in my IPTV under LAN:

  • Profile was None.
  • Choose IPTV STB port, I set to LAN3 & LAN4.  I plugged my U-Verse WAP for the wireless reciver into the NVG589 and I plugged the ethernet cable going to the VIP2250 into LAN3 on my personal router.  I'm really not sure if this was necessary but I'm having 0 issues with this setup.  I initially tried putting the WAP on my personal router but had issues so I stuck it back on the NVG589 and it's fine.  I could probably just plug the VIP2250 into the NVG589 as well but I'm just enjoying the small victory of using my personal router for now.  
  • Hit apply at the bottom, another possible reboot.

At this point, I checked the internet and everything was working great through the router.  I restarted by 2 TV boxes (the VIP and the wifi ones).  Everything is peachy.

 

Your mileage may vary.  Good luck.

 

 

 

 EDIT to update WAP configuration. 

 

543,771 Views
Message 1 of 278
Highlighted
Tutor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

First of all... I also want to thank you for the directions!

 

Following the instructions worked fine except for:

 

  • Go to 'Firewall' then 'IP Passthrough'.  For 'Default Server Internal Address', select or type in 192.169.2.1.
  • For 'Allocation Mode' select 'Passthrough' (I had to do it in this reverse order to be able to type for some reason)
  • For 'Passthrough Mode', select 'DHCPS-Fixed'
  • Type in the MAC address for your router under 'Manual Entry', lowercase is fine.

On my NVG589 gateway the field for the Default Server Internal Address is "greyed out" and not editable. I tried various combinations with the Allocation Mode but nothing seemed to open the field. I could set all other fields.

 

I did continue with the instructions through the local router and, so far, it seems I do get internet through my ASUS RT-N66W. I suppose I'm trying to find out how critical setting the Default Server Internal Address is.

 

One other thing... I set the Device IPv4 Address as 192.168.2.254 not 192.169.2.254 as stated in the instructions.

 

Any suggestions? Thanks again for the help!

Message 31 of 278
Voyager

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

I'm in same boat. That box is greyed out. 

 

Suggesitons?

Message 32 of 278
Contributor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Great explanation and I believe I setup my system in this manner, but I can not get to certain ports from the outside.  If I go to canuseeme.org, it shows my IP as what I set my server to, great.

 

But, if I try the port my web server is on, it does not work.  This leads me to think that the RG router is blocking this.  I thought that the static IP would have full access to all ports and not be blocked, or rather, the port is in use due to the RG - which uses 80 and 443.

 

So the question is, if I get static IP's and do this setup, am I in the same position as port-forwarding from the base RG router, or how do I get to my ports and/or do I need to setup my own router on this public IP and then I am good to go ?

 

Thanks !

 

Message 33 of 278
Mentor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Mine is also grayed out. I "think'" it takes the settings from Home Network-->Subnets & DHCP-->Private LAN Subnet--->Device IPv4 Address

Are the numbers next to Device IPv4 Address the same as the grayed out box? Mine are the same which led me to think this. It just transfers the numbers over.

Message 34 of 278
Tutor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Hello, I have been researching this for a few weeks now and have read a few threads about it.

»forums.att.com/t5/Features-and-H···7BX-9KSN

»NVG589 & Netgear Router for DLNA

I think I have just enough info to get started. I do want to make sure that I have my ducks in a row.

I know that I want to use the NVG in IP passthrough mode. The router will handle the wifi in my house.

The modem will do all the heavy lifting, I have a Netgear Gigabit switch attached to it for added ports. I will not, as I see it now, need the router to do anything other than broadcast a strong signal.

I was lucky, rehabbing a house to hardwire 13 cat6 drops throughout. I have a patch panel set up in the basement. As I said before, the modem will still do all the heavy lifting, such as Uverse TV and my home server running FreeNAS, all of these will be hardwired via direct connection or patched in.

So, I want the router to handle DHCP allocation for my wireless network, but I want to make sure that anything connected to the wifi will have access to the modem attached network (i.e. the server attached to the modem and network printers and such). 

How does this affect my subnets when I allocate my IP addresses? Don't the modem and the router need to be on the same subnet to communicate?  I need to set it up so that the wireless router can access the hardwired parent network that supplies the wireless router with its signal.  Am I making sense?  I could set it up so that 192.168.1.1 is the IP address for both, which would make the RG UI only accessible via hardwired connection.

Thanks so much for this! Very excited to get this going! Cheers!  I welcome any thougts on this configuration.

Message 35 of 278
Contributor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

excellent and detailed documentation. Followed the same steps but still get the same invalid IP error. And also verified in my asus router that i am getting the public IP address 107.xxx.xxx.xx. any more pointers what is missing here ???

Message 36 of 278
Mentor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Is your router and RG on different IP addresses?  For example: 192.168.1.1, 192.168.2.1?

 

Have you double checked all of the settings in the RG, like wireless, off, firewall off, DHCPS-fixed?

 

If worse comes to worse, do a hard reset of the RG by pressing and holding the red reset button the back until all lights are solid red, It does take some time to come back up and make sure you have only one PC plugged into the back.

 

What device is giving you the error? The RG or your personal router?  Which Asus router do you have? I have the RT-N66U.

 

Have you rebooted the router?

Message 37 of 278
Contributor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

So, I just had my old 2Wire replaced with the new NVG589. I had purchased a D-Link DIR-826L and had purchased it for the Wireless N600 dual bands and the Gigabit ports. So, now that the NVG589 has Gigabit ports but only N300, should I just stick with the NVG589 handling everything or pass it all thru to my DIR-826 Router? I've got about 4 Wireless N cameras that of course I wanted to use N signal and the old 2Wire was a B/G, so that's one reason, but now the NVG589 has N. Then with running a DVR Camera System as well as the N Cameras I wanted fast Gigabit speed thruout my network. So, I'm looking for what would be better for me/us?

 

Realized we have tons of Wireless devices these days, so have an XBox, Wii, Cellphones, Streaming devices for Netflix and others, I didn't know if the NVG589 would bottleneck on me to handle about 20 Wirless devices connected to it. So, looking for some help/suggestions. Thanks everyone. 

Message 38 of 278
Mentor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Excellent post...thanks.  Stupid question though...I bought an Asus 1750.  I am not sure how to best to physically configure the wires.  Should I plug the Asus into one of the LAN ports on the NVG 589? Or, can I plug the Uverse internet cable coming in from the ONT into the ASUS WAN port and then out from the ASUS LAN port to the WAN port on the NVG?

 

this is important because I really need all 4 ports on the NVG...one for printer, one for DVR, one for wired computer, and one for the wireless TV boxes...Thus, all 4 ports are used and I wouldnt have one available to plug the ASUS into.

Message 39 of 278
Mentor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Forget my previsous question...

 

Anywho, I tried all of the bridging instructions and none of it worked.  The NVG would never let me changed the IP address to anything that any of the posters suggested.  I ended up having to factory reset the NVG to get everything back to normal since all of the settings got jacked up.

 

So, for anyone else, there is another option...I simply plugged the router into one of the LAN ports on the NVG and it works fine.  Admittedly, I am really only using this for wireless and for a couple of other hardwire connections to make printing easier so this may not be using the router to its fullest, but for me, it doesnt matter.

 

I am getting 220Mbps down on the AC ghz signal...not bad but I thought it would have pushed the full 300 since I have a solid signal.

Message 40 of 278
Mentor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

 Did you use Passthrough Mode, select DHCPS-Fixed?

 

I know it sounds obvious, but did you save your settings? Did you use your personal router MAC address in the NVG589?  Disable NVG wireless, turn off the firewall, etc? For the MAC address, I only had the PC connected and the NVG589 saw it.

 

You can leave the NVG IP adress the default if that's easier for you.  Just make sure the router is set to 192.168.2.1 for example.

 

I just turned 59 yesterday and am female. So if I can do it, you can too! Woman Very Happy

 

I took my time, printed out the instuctions and it worked the first time I thought. My personal router was not seeing my public WAN IP and was double routing (double NAT). If your personal router is showing 192.168.X.X it's probably doing double NAT.  Not a good thing. Since I also wanted to limit the number of DHCP addresses used I started over.  My router then had the public WAN IP set correctly. 104.0.8.2XX  As you can see, that address is different and is what is displayed on the Internet. The public WAN IP is assigned from Uverse and generally speaking cannot be changed.  Only a Uverse tech will cause it to change when moving your connection to another card for example.  

 

Sometimes is helps to see the steps short and sweet. http://www.dslreports.com/faq/17734

Message 41 of 278
Contributor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Hi guys,

 

I did all of the above but I have a slightly different setup.  My time capsule is not not directly plugged into the ATT modem.  But it is plugged into a Netgear 5 Port Switch with the Uverse box and then into the wall of my living room which routes back to the ATT modem.

 

So I was not able to connect the Time Capsule and ensure the 192.168.10.1 IP address.  So when I set the default internal server it is selecting 107.128.xxx.x which is my external IP address.  

 

This is okay and all works fine except every 24 hours or so the Time Capsule just loses it's network settings and I have to reboot it.  Then all is well for another 24 hours so I suspect a DHCP release problem and that I may need a fixed IP.  Any help appreciated.

 

Thanks

Antony

Message 42 of 278
Mentor

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Probably stupid questions, but here goes:

 

1.  Does this process involve connecting a cable between the NVG589 and the personal router at all even when it's completed?

 

2.  When I'm done with the set-up, can I plug my LAN devices into the ASUS, the NVG589 or could I use both?  

 

3.  Should I reset the NVG589's subnet before even turning the ASUS on because isn't it possible they would conflict right off the bat?

 

4.   The Default Server Internal Address for the NVG589 is grayed out unless you switch to Default Mode for allocation.  I assume it's okay to temporarily do that, save, type in address and then switch back to Passthrough for allocation mode?

 

5.  Is the WAN address for the Asus its LAN MAC Address/Wireles 2.4GHz MAC address?

 

6.  Where do I change the Internet connection type to DHCP on the ASUS?  The LAN tab has a DHCP Server tab which reads "Enable the DHCP Server" which is "on" by default.

 

TIA.

Message 43 of 278
Teacher

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

Important fix to frostcall's original post

 

This is a convoluted bridged mode workaround for the NVG589 and I hope AT&T fixes this with a firmware update.  I thought the "Power" tier was supposed to be an upgrade, but this NVG589 firmware is a major downgrade for users with 2nd routers, IP cameras, home automation systems, etc.

 

I couldn't reach the broadband public IP via dynamic DNS services for my security cameras until I made the following fix to the original instructions:

 


 

Personal router settings:

 

Instead of using Automatic IP (DHCP) for your personal router WAN type, give it a static private IP on the same subnet as the NVG589.  For example assign the following:

 

IP: 192.168.2.253

Subnet mask: 255.255.255.0

Default gateway: 192.168.2.254

Primary DNS server: 192.168.2.254

 

Settings on the NVG589:

 

Instead of DHCPS-fixed, select Default Server.

 

After selecting Default Server, you should see 192.168.2.253 filled in automatically in the Default Server Internal Address box.  This also sets the passthrough mode to DHCPS-fixed.  Restart the NVG589.

 



A huge problem remains, the lack of support for NAT loopback.

 

Has anyone figured out a workaround for this?  For example if your security cameras are using a dynamic DNS service to access the cameras from outside home, with port forwarding to route to the correct camera, this won't work while your viewing laptop is connected to the LAN.  In order to access the cameras, the address has to be changed back & forth from the friendly DNS name to the numeric IP address, depending whether you're on the public ISP or local home network.

 

Did AT&T even bother to test the NVG589 with people with 2nd routers and security cameras, home automation, etc. before such a widespread deployment? 

 

If AT&T is reading this, please fix the design flaws in the NVG589 firmware!

Message 44 of 278
Voyager

Re: How to put the Motorola NVG589 in 'bridge mode' (or as close as you can).

No matter what I try, I cannot change the subnet / netmask / DHCP range for the NVG589.

 

 

This is very frustrating....   Why can I at least not disable DHCP?     AT&T is crazy annoying with wanting to take over MY internal network settings so I can run on THEIR EXTERNAL network.

 

I've about had it with this and am extremely close to calling TWC up for an install...

 

The error I get on any network config I use is:

 

Address must be on network (192.169.2.0)

 

I get it no matter what I try...

 

I've tried the following:

 

device IPv4 address: 172.21.0.1
DHCPv4 start IP address: 172.21.0.7
DHCPv4 end IP address: 172.21.0.14
Subnet mask: 255.255.255.240

 

device IPv4 address: 10.0.0.1
DHCPv4 start IP address: 10.0.0.2
DHCPv4 end IP address: 10.0.0.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.168.2.254
DHCPv4 start IP address: 192.168.2.1
DHCPv4 end IP address: 192.168.2.5
Subnet mask: 255.255.255.240

 

device IPv4 address: 192.169.2.254
DHCPv4 start IP address: 192.169.2.1
DHCPv4 end IP address:  192.169.2.5
Subnet mask: 255.255.255.0

 

(I've tried a subnet mask of 255.255.255.0 as well with all configs and increased the DHCP range.

 

Am I doing something wrong that I'm missing or did  AT&T disable this on my firmware?

 

Here's my sysinfo

 

System Information
ManufacturerMotorola
Model NumberNVG589
Serial Number66206465812288
Software Version9.1.0h12d19
MAC Addressxxxxxxxxx
First Use Date2014/03/31 20:00:26
Time Since Last Reboot02:04:51:36
Current Date/Time2014-06-23T17:45:31Z
Datapump VersionA2pv6F038k1.d24h
Legal Disclaimerxxxxx
Message 45 of 278
Share this topic
Share this topic
Additional Support