Explore & discover

Helpful Links

ATT IPV6 tunnel issue solved (Cisco router only)

Highlighted

ATT IPV6 tunnel issue solved (Cisco router only)

Just now I fixed my own problem...for once.

 

If you have a Cisco router behind NVG510 in IP passthrough follow these steps:

 

1: Go to the gateway broadband status page. There you will find an IPV6 address and a border relay address.

 

2: The IPV6 address is a /60 so go to http://www.gestioip.net/cgi-bin/subnet_calculator.cgi and subnet it into /64 networks.

 

3: Create a 6to4 tunnel on the cisco router.

 

Router(config)# interface tunnel (tunnel number here ei 0)

Router(config-if)# tunnel mode ipv6ip

Router(config-if)# tunnel destination (border relay address here ei 1.2.3.4)

 

Ok, so now you will assign the first ip of the first subnet here (2602:x:x:x::1/64)

 

Router(config-if)# ipv6 address 2602:x:x:x::1/64

Router(config-if)# exit

 

4: Add the first ip from the second subnet to your inside facing interface (vlan 2 for me)

 

Router(config)# interface vlan 2

Router(config-if)# ipv6 address 2602:x:x:x:1::1/64

 

Configure the interface for client autoconfig

 

Router(config-if)# ipv6 nd other-config-flag

Router(config-if)# exit

Router(config)#

 

4: Set the default IPV6 route to be the tunnel interface

 

Router(config)# ipv6 route ::0/0 tunnel 0

 

5: Enjoy IPV6

 

Side note: If you have an 802.11N-draft access point, you may need to drop to 802.11g mode in order for ipv6 autoconfig to work on your computers (My experience with Linksys WRT120N)

2,867 Views
Message 1 of 6

Re: ATT IPV6 tunnel issue solved (Cisco router only)

Forgot a few things.

 

1: Set the tunnel source to your WAN interface

 

Router(config)#  int tunnel0 (or whatever your interface is)

Router(config-if)# tunnel source f0/0 (your WAN facing interface)

 

2: Set router advertisements to on (default on my router)

 

Router(config)# int vlan 2 (your LAN facing interface)

Router(config-if)# no ipv6 nd ra suppress

 

3: I probably won't have time to respond to questions about this so...

 

http://www.cisco.com/c/en/us/td/docs/ios/ipv6/configuration/guide/12_4t/ipv6_12_4t_book.pdf

 

Refer all questions to this link

Message 2 of 6

Re: ATT IPV6 tunnel issue solved (Cisco router only)

Last thing... I promise...maybe.

 

Don't forget to turn on ipv6 routing.

 

Router(config)# ipv6 unicast-routing

Message 3 of 6

Re: ATT IPV6 tunnel issue solved (Cisco router only)

Just a little laugh for anyone interested:

 

Screen Shot 2015-01-14 at 2.39.55 PM.png

Message 4 of 6
Contributor

Re: ATT IPV6 tunnel issue solved (Cisco router only)

I upgraded my service to the new AT&T U-verse Power Tier back in October which replaced my old 2Wire 3801 residential gateway with the brand new Motorola NVG589 unit. This unit was deployed with AT&T’s IPv6 6rd tunnel solution enabled out of the box. 300-085 VCE This provided IPv6 access to the segment directly attached to my residential gateway with a /60 netblock assignment. It’s a pretty generous assignment, aside from the fact that it only assigned a single /64 to the local LAN and there was no obvious way to delegate the 15 other /64 networks to a downstream router.

Message 5 of 6
Tutor

Re: ATT IPV6 tunnel issue solved (Cisco router only)

Too bad this won't work with native IPv6 now Smiley Sad. Seems the only solution it to figure out how to bypass the stupid residential gateway (mine is a BGW210-700). Unfortunately this will require the router to authenticate to the ONT. If only AT&T would follow the RFC's properly...

Message 6 of 6
Share this topic
Share this topic
Announcements

Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!

Additional Support