Helpful Links

sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!


sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

sometimes, when i plug in my universe modem, wait for a while, open my web browser, then universe will add cgi-bin/ipdiags.ha to all my web address, such as


no matter how long i wait, i can't get connected to the internet, so i always have to unplug, then plug in the modem adaptor again in order for it to work.


why is that?  

Message 1 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

This message comes up after messages in the gateway log file:

SL: Last Retrain Reason: 0x1 RDI Detector


I then reset the modem, but the ipdiags.ha messages continue because the DNS

addresses seem to be cached...that is, the .../ipdiags.ha append to the name resoution has

been cached.


What I need to know is why is the link "retraining" and then the subsequent processing doesn't clean everything up

so the link appears dead...

I find several places where this problem is reported, but no sign of any work or explanation by ATT as to the




Message 2 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

Hello.  I just getting the same ipdiags/ha yesterday and rebooting the router does not resolve this issue! 


I have Uverse NVG510 for 3 months working perfectly and then all of a sudden cannot go to any website.  If I type in and press enter, the URL is changed to and the IP DIagnostics page of the router displays.


Next, if I login to my work VPN using Cisco app, then I can get to (some) work URLs.  But no msn, google, etc.   They all get the ipdiags/ha extension. 


If I log off the VPN, then all URLs (my work web sites) that were working are then again "redirected" to the router diagnostics page.


My personal home computer is just out of luck -- both computers are attached via ethernet cable here in my office. (not using wireless).  On the personal computer I can go to an ftp site I use at work for customer files.  So, I am "on" the internet somehow.  Just no browsing is allowed.


Any ideas?


Message 3 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

Just guessing here....


You could try doing a factory reset of the gateway.  I don't know how to do this on the NVG510, but there must be a way.  Of course you'll lose any settings you've changed.


Or you could change the DNS server setting from automatic to a specific server address, such as  That might bypass the DNS in the gateway.


As a last resort, call tech support.


Good luck!




Message 4 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

i have the motorola modem.


i don't use the modem 24 hours/day. so i unplug it whenever i don't use it. this thing doesn't happen often, when it does, i just unplug it, then plug it back in again. it always works fine. i just don't know why it is doing this.

Message 5 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

Uverse support was very helpful and this is fixed.  I do not know all the technical points but to resolve the ipdiags.ha issue... when it displays the IP Diagnostics page , down toward the bottom is a button labeled "Do not show".  Click that one instead of "Continue".    Then, go to several urls, close the page then launch again.  After just a few tries my browsing access just worked again on both the laptop and desktop (although the desktop had to be rebooted first as it is rather an old model)

Message 6 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!


All you need to do is clear the browser cache and the issue is gone.

Message 7 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

Obviously the responders to this issue haven't done much research on this issue. Clearing the cache & restarting the modem, etc. are simple quick fixes. This is a pervasive problem related to U-verse & the Motorola NVG510 router/modem. There are NUMEROUS blogs, articles, computer help sites, etc. that people like us with this very same problem, have sought out for answers and help. Alas, as of this post, NONE is forthcoming. I have tried the simple suggestions as well as the very complex; 12 different "cures" thus far. They all work for a short time but none is long lasting. The thing that REALLY angers me about this issue is that it has been complained about, written about, and asked about for almost 2 years now, and AT&T tech support refuses to acknowledge that it exists! The firmware for the Motorola is WAY outdated, and there are volumes of complaints on the internet about the NVG510 & U-verse. I have had numerous service calls to my house and exhaustive hours, day after day on the phone with tech support, and have YET to find one person at AT&T that can supply a remedy for this except to buy another router & bridge it!  I have sent 2 of these Motorolas back for exchange already, but to no avail. VERY FRUSTRATING! I had AT&T DSL with a 2wire gateway for the past 5 years and NEVER had one minutes trouble. This past March, after receiving 10 emails a day telling me how wonderful & fast & efficient & blah-blah-blah U-verse is, I signed on. WORST mistake I've made in a long time! I hope someone out there will read this and actually KNOW a cost effective, meaningful, long lasting fix for this issue. As of today I can assure you that AT&T is NOT the source for help with this problem. I HATE having to cycle my laptop & router on & off 10-15 times a day just to connect to the internet for a few minutes at a time before the IP Diagostic page hijacks my browers. (yes, it does this to Firefox, IE, & Chrome) If I don't get some honesty and some answers from AT&T real soon, I do know a remedy that will permanently fix this issue: Charter Cable internet service!

Message 8 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

my problem is not as bad as yours.


it only happens when i plug in the charger. once in a while, it will show this cig bin thing on the computer screen. i will just have to unplug it, then plug it in again. then the problems goes away. i never have to do it several times in order to get connected to the internet.  

Message 9 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

I recently moved to att uverse. Everytime the service goes down the att router redirects my home page to the cgi bin ha, as well. Sometimes I could fix this by clearing the cache and restarting the router.

Now however, that solution no longer works. Even when you tytpe in the specific address you want, the browser redirects you to the same annoying att page.


For a while I was able to add www to the IP address of my home page ( became and this solved the problem. Now that no longer works. 


Now I do an internet search for my yahoo, select the link to make my yahoo my homepage. This is working for the time being.

Message 10 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

This only happens with port 80 traffic. You can change it to and it should work. If it is unbearable you can try to get the NVG510 swapped for a 5031 modem.

Message 11 of 12

Re: sometimes, universe adds "cgi-bin/ipdiags.ha" on all my web address!

I fixed this by clearing the internet cache and history in my browser and restarting the broswer.  hope this helps.


Message 12 of 12
Share this topic

Welcome to the internet boards! Check out our troubleshooting articles below and don’t forget to search the forums - your question may have been answered already!

Service acting up? Click here to troubleshoot now!

For DSL related issues. We highly recommend chatting with our teams to address this as quickly as possible.

Additional Support