Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

Teacher

Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]

 

Hello.  I am writing this in an attempt to save other customers (and the AT&T staff) from many hours of work and frustration.  I was a long-time DSL customer and had always used my own router behind the DSL modem.  A simple setting on the modem turned it into a "dumb" pass-through and allowed my router to handle all the traffic as I pleased.  Changing over to U-verse required a new modem and at first, that presented a huge problem with my router.

 

What took me about 7 hours of work, online chatting with multiple agents and even finally trying paid support with AT&T (and in both cases being told it's not possible to do), I succeeded in using my own home router with the NVG510 modem under the U-verse service.  The process is fast and simple (in retrospect) and should take you about 10 minutes.

 

See below...

Message 1 of 34 (191,504 Views)
Teacher
Solution
Accepted by ATTDmitriyCM (Community Manager)
‎09-30-2015 1:39 AM

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

You will need to adjust settings on both the NVG510 and your router.  In my example, I'm using a Linksys E3000, but based on how these settings work, I would state that you can use any decent router of choice.  There's nothing being set that's "router-specific"; every modern router should have these settings.

 

The NVG510 (modem)...

 

Step 1:  connect the NVG510 with a computer.  This can be done through a wired or wireless connection.  I won't get into those details here, but you'll want to open the interface to the NVG510 in a browser (e.g. Internet Explorer).  The default IP for the modem is 192.168.1.254.  You will need the access code (on the side of the modem) to make changes in the settings.  Point your browser to "http://192.168.1.254".

 

With the modem's interface showing in your browser...

 

Step 2:  click on "Home Network | Subnets & DHCP".  Here you'll want to use settings similar to the example below.  The key here is that the IP address pattern of your NVG510 and your home router's set of IP addresses must differ in the 3rd offset.  As in:

 

"xxx.xxx.yyy.xxx".  So the "yyy" segment (offset) needs to be different.  I used "1" for the modem (which is how it's defaulted to with 192.168.1.254) and then "0" for my router as in 192.168.0.110.

 

Here are the modem's settings:


 

 

Save the changes, but don't reboot yet.  We have another change to make (if you reboot, it's ok as it won't hurt anything, just takes longer).

 

 

Step 3:  click on "Firewall | Ip Passthrough".  Update the settings as follows:


 

The "allocation mode" should be on "default server".  I tried both "off" and "passthrough" and neither worked.  This seems to be a crucial step.  Note that the "default server internal address" must match the address of our single DHCP one being assigned by the NVG510.

 

Be sure to SAVE the changes.  Don't bother rebooting - just unplug the power cord from the NVG510.  We are moving on to the settings in the router and the next time we plug-in the modem, that will serve as its reboot.

 

 

Home Router (Linksys E3000)...

 

Step 1:  Unplug the NVG510 from your computer (or disconnect if connected wirelessly) and connect to your home router.  In my case, I'm connecting to a Linksys E3000 (again, not really important here on the brand/model you have; everything here should work the same).

 

 

With the router's interface showing in your browser...

 

Step 2:  Find the "setup" page (usually the default screen which comes up) to where you establish the connection type (e.g. PPPoe, static, etc.) and set the connection type to "static IP".  We're going to configure to have a static IP because of the single, static IP coming from the NVG510, the 192.168.1.1It seems the NVG510 handles all the authentication for us:

 


 

 

Notice that the router's IP address has the "0" in the 3rd offset.  Remember, this 3rd offset must be different than that of the modem's.  You can use whatever you want, but the router and modem must differ there.

 

The "default gateway" and "dns" are both set to that of the NVG510 address.  I suppose you can use whatever you want such as Google's "8.8.8.8".  Regarding the gateway address, if you changed yours from the modem's default, be sure to reflect that here as well in the router. 

 

Be sure to SAVE your changes.  That's it!

 

There are no more steps required in your router to operate with the NVG510.

 

To ensure everything takes effect, turn off your router (unplug if no power switch).  Then plug in your NVG510 and power-on the router (at same time is fine; otherwise, do modem then router).

 

The end result of the network setup is depicted here:


 

 

Once again, you can use any IP configurations you want.  Just use this example to correspondingly change the addresses in both the modem and router to meet your liking.

 

I hope this feedback is able to benefit others.  I would hate to learn that someone else is having to spend 7 hours on the chats and phone calls only to have this quick process done at the end.

Message 2 of 34 (187,747 Views)
Highlighted
ACE - Expert

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

This process appears to work for NVG 589 as well.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 3 of 34 (187,718 Views)
Expert

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

This does work for both the NVG510 and NVG589, however, using the Default Server mode results in double-NAT. To get as close to bridge as possible, you need to use Passthrough mode, which will require the WAN interface of your router to be set to DHCP.
Message 4 of 34 (187,712 Views)
ACE - Expert

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

I wonder if someone with a NVG 589 could put together the screen shots of it conifigured that way?

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 5 of 34 (187,710 Views)
Tutor

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

THANK YOU DONLUZ!!! Your solution has solved my problem with terrible upstream when using the NVG510. I set up my E1000 as you described and my upstream has gone from .2 - .3 with the NVG back to .9 that I used to have.
Thank you again.
Message 6 of 34 (187,545 Views)

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]

I'm using gaming systems so I really want to use this gateway/modem as a simple pass through and use my own ASUS router that works great! I saw you (SomeJoe7777) posted about a double-NAT issue and that sounds like it would be an issue with what I want to do. I also noticed on the Home Netowork > Settings & DHCP section of the NVG510 that there's a Cascaded Router option/feature. Isn't this was this is for? Or should I use the method posted by donluz and set my router WAN to DHCP?

 

Thanks,

 

Message 7 of 34 (186,098 Views)
Contributor

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

can we add additional addresses/connections on the ATT router in this setup? i'd like to keep separate the wireless video traffic from the internal subnet.

 

so to restate in your diagram you have a single connection to the ATT gateway can we have additional devices at that level?

Message 8 of 34 (185,263 Views)
Contributor

Motorola NVG510 A/C replacement

Is there an A/C replacement for the Motorola NVG510, which is only wireless N??

Message 9 of 34 (182,545 Views)
Employee

Re: Motorola NVG510 A/C replacement

For RevJeff144, there are currently NO AC routers in Uverse inventory of RGs either adsl2+ circuits using the 510 or vdsl circuits using various RGs.

If desire an AC router, will need to purchase your own and place behind the 510 in DMZ or IP pass through.
Employee Contributor*
*I am an AT&T employee and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 10 of 34 (182,532 Views)
Contributor

Re: Motorola NVG510 A/C replacement

Thank you! :-)
Message 11 of 34 (182,499 Views)
Voyager

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

I was able to connect a personal router to the NVG589 by doing this.

 

1.Configure personal router

a. Set IP to 192.168.2.254

b. DHCP enabled as it was previously with DSL

 

2.Configure NVG589 using a pc connected to a LAN port

a. Set allocation mode to IP Passthrough

b. Set passthrough mode to DHCPS-fixed

c. Enter personal router’s MAC address in the Passthrough Fixed MAC address field

d. Reset the NVG589.  It takes a couple of minutes.

e. After the NVG589 reset I had to restart the phone

f. Connect LAN 1 from NVG589 to personal router’s WAN input

 

3. Plugged all wired devices into LAN ports of personal router and setup wireless LAN.

 

I didn’t disable any of the firewall settings on the NVG589 and also kept DHCP enabled.   Now comes the interesting part, after enabling the NVG589’s wireless LAN it functioned correctly as wireless router.   Without knowing what the NVG589 is doing internally it appears that this setup has two separate networks.    Everything tied to the personal router is behind its firewall.   I think the NVG589’s firewall is set up and protecting the NVG589’s wireless network.   My plan is to configure the NVG589 WLAN as a guest network (192.168.1.x) and the personal router will be the private network (192.168.2.x).  Does someone who knows more about the NVG589 confirm that the guest network is protected by the firewall even it is set up for passthrough mode?    I’m assuming that the NVG’s firewall is not filtering the connection to the personal router, but that doesn’t really matter.

 

Does anyone see any issues with this setup from the perspective of conflicts / speed issues and also from a security perspective?

Message 12 of 34 (181,394 Views)
Teacher

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

I had the UVerse NVG589 installed about three weeks ago, and need to get my security cameras back online, so I can view them remotely.  I was on AT&T DSL prior with a Superstream modem, and now with this new modem I can not find the Port Forwarding Mode to work on this. 

 

After reading this blog, I see others have struggled too, but Steve74123 may have my answer.  I had a D-Link router connected to my old DSL modem; prior to this changeover.  Now I see I need to connect this router to the NVG589 to get my system back to normal. 

 

Seems like I really won't have to change much on my router, just plug it into an open port on the NVG589 and set the NVG589 to Passthrough mode, andset my routers address to the NVG589 access IP address.  I hope this works.  If it does, I'll post some pictures on here next week. 

 

By the way, I  only have internet access and no TV or Phone on this NVG589.  Just fyi....

 

Fingers crossed....

Message 13 of 34 (177,584 Views)
Contributor

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

I tried to change the address in the first step but I don't know if I'm doing it right. I'm using a linksys e1000 behind a nvg589. Do I change the start and ending or do I select cascading and then change it?? I'm so confused. Any help would be appreciated.

 

Message 14 of 34 (177,246 Views)
Voyager

Re: Using your own router with the Motorola NVG510 - it absolutely works and it's easy to do!

[ Edited ]

I got my NVG589 today, just got everything working. It's very simple.

 

Connect your personal router to your computer and login to the administration panel.

 

Change your router IP to 192.168.2.1 you should be able to keep everything else the same.

 

Connect your router to your modem at this point you should be able to connect to the internet, in order to make your router have full control go to 192.168.1.254 on your PC after the modem and router is connected, go to Firewall > IP Passthrough change Allocation Mode to Default Server. Under Default Server Internal Address your router IP will be showing select it from the list, mine was 192.168.1.68

 

Save settings and reboot modem. Once it reboots you should be golden. All my game systems now show NAT Open, and no longer have connection problems. I tried all the post I could find.

 

You may or may not have to disable packet filters, I did since my router has this feature. You may also want to go into  Home Network > Wireless and disable the wireless so you don't have two showing on your laptop.

 

Hope this helps someone else. I did 3 resets until I got my settings right, and it was much more simple than people were making it seem. Smiley Wink

 

Here's my router settings, it's a Linksys WRT150N (yeah its old). I am using OpenDNS servers, you can leave those default. These are the only settings on your router you need to change to make it work with the NVG589 or any other modem. I have been using these for years, 5 different modems. My main issue was the Strict Nat, and very slow connections speeds and the modem settings fixed that.

Message 15 of 34 (176,499 Views)