UV Realtime fails to install; my C++ 2010 version is "newer" than the installer allows

Highlighted
Mentor

UV Realtime fails to install; my C++ 2010 version is "newer" than the installer allows

Installing the latest UV Realtime on a new machine. Install fails "A newer version of Microsoft Visual C++ 2010 Redistributable has been detected on the machine."

 

Advice?

 

Thanks

925 Views
Message 1 of 4
Expert

Re: UV Realtime fails to install; my C++ 2010 version is "newer" than the installer allows

Follow the directions in the following post to get around the Visual C++ runtime issue:

http://forums.att.com/t5/Features-and-How-To/UV-Realtime-Master-Thread/m-p/3337563#M35377

Tags (1)
Message 2 of 4
Teacher

Re: UV Realtime fails to install; my C++ 2010 version is "newer" than the installer allows


SomeJoe7777 wrote:
Follow the directions in the following post to get around the Visual C++ runtime issue:

http://forums.att.com/t5/Features-and-How-To/UV-Realtime-Master-Thread/m-p/3337563#M35377


I'm running into this issue, and when I try to go to this link, I get an error message:

 

You do not have sufficient privileges for this resource or its parent to perform this action.

Click your browser's Back button to continue.

 

 

Could the information from that link be posted in this thread?

Message 3 of 4
Teacher

Re: UV Realtime fails to install; my C++ 2010 version is "newer" than the installer allows

Just found another thread (https://forums.att.com/t5/U-verse-2014-Archive/Ping-Spikes-Internet-Drops/td-p/3609803) that seems to have the workaround instructions from JefferMC:

 

Yeah, if you've installed something with a newer build of the VC++ RT, then that happens.  There's a fix for it if you're willing:

 

What you can do is go into your Programs and Features control panel, and remove the Microsoft Visual C++ 2010 x86 Runtime v10.0.xxxxx. (Usually the version you will have is 40219). Once you remove it, then reinstall UV Realtime. RRDTool will install properly after that and will install the 10.0.30319 version, which is compatible.

 

(You do not need to remove any of the 2005/2008 versions, nor any x64 versions).

Message 4 of 4
You must type a description before you click preview or reply.
Share this topic
Announcements

Welcome to the internet boards! Check out our troubleshooting articles below and don’t forget to search the forums - your question may have been answered already!

Service acting up? Click here to troubleshoot now!

Do you have questions about Internet and Email Security? Have them answered on Wednesday, April 26th at our Knowledge Sharing Session: Hack Attack!

Additional Support