Explore & discover

Helpful Links

Turning off DHCP on ATT BGW210-700 Modem/Router

Highlighted
Tutor

Turning off DHCP on ATT BGW210-700 Modem/Router

I just switched from another ISP with a separate modem and router to ATT Fiber to the combined modem/router unit.  I have an Amahi Linux  server that worked fine under the previous configuration, which entailed switching off DHCP on my previous router (which I still have) and letting the server manage the DNS.  The new ATT setup seemed to be working fine with all my devices connected via wireless, except for the server which was directly connected to the modem/router. However, the server didn't show as a connected device on the modem/router and was unreachable by ping.  I switched off DHCP on the modem router via the web app hoping that this would restore access to the HDA server, and promptly lost all internet access.  With some fiddling I was able to switch DHCP back on and restore internet access, but I still have this problem of having a nonfunctional Linux server.   Can anyone help me?  I'm clearly out of my league here.

640 Views
Message 1 of 8
Administrator

Re: Turning off DHCP on ATT BGW210-700 Modem/Router

Hi @baileyt2

 

Thank you for reaching out! Given the complexity of your issue, we recommend reaching out to our ConnecTech team for more advanced troubleshooting options. We hope this helps!

 

Aminah, AT&T Community Specialist


Need help?
Ask a question to get help from the AT&T Community or support from AT&T specialists. If this reply helped you please use Accept solution to mark it as an Accepted Solution.
*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 2 of 8
Tutor
Solution
Accepted by Administrator (Administrator)
Accepted by Lingoes
‎02-05-2019 1:13 PM

Re: Turning off DHCP on ATT BGW210-700 Modem/Router

I figured this out. The IP address of the ATT gateway was different from my Charter gateway. I changed a setting on my home server to address this, and this fixed my issue. After fixing the gateway IP setting, I turned off DHCP on the ATT modem/router using the web interface, and now my server is handling DNS on my home network. Everything is working fine now. Thanks.
Tags (1)
Message 3 of 8
Administrator

Re: Turning off DHCP on ATT BGW210-700 Modem/Router

Hello again @baileyt2

 

That's great, we're glad you got it sorted out! Thanks for the update and enjoy the rest of your day!

 

Aminah, AT&T Community Specialist


Need help?
Ask a question to get help from the AT&T Community or support from AT&T specialists. If this reply helped you please use Accept solution to mark it as an Accepted Solution.
*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 4 of 8
Contributor

Re: Turning off DHCP on ATT BGW210-700 Modem/Router

I have the same problem.  I had turn the dhcp server back on on ATT bgw210 in order to get internet working.  What did you change?  I have enabled IP passthrough from the ATT bgw210 onto my netgear nighthawk.  Its work but every time I try to turn of dhcp server on ATT bgw210, no internet.  Could you tell me what setting you change?  Is it on your 3rd party router?

Message 5 of 8
Tutor

Re: Turning off DHCP on ATT BGW210-700 Modem/Router

I have an Amahi Linux server. It was set up using the default gateway IP address, which worked fine with my previous ISP, but with ATT the gateway IP changed (which I determined by doing an ipconfig on a Windows client). So, I changed the gateway setting on the server to the new IP, and this enabled me to turn off DHCP on the ATT router without losing internet. My server DNS doesn’t yet resolve external names, so I have another tweak to do, but I have internet service.
Message 6 of 8
Contributor

Re: Turning off DHCP on ATT BGW210-700 Modem/Router

Ah I see.  Did this resolved your double NAT problem?  

Message 7 of 8
Tutor

Re: Turning off DHCP on ATT BGW210-700 Modem/Router

I’m not sure I understand your question, but my remaining issue is that my DNS does not resolve external hostnames.  The strategy that has been suggested to me is to assign non-overlapping DNS IP ranges to both the ATT router and my Linux server (one range each). So, turning DHCP back on for the ATT router, and assigning a range for that, and doing same for a non-overlapping range on the server.  That will be easy to do with the admin app for the router, but I’m a Linux neophyte so  I’ll have to figure that out for the server. If I do and it works (or not), I will respond with an update. I’m traveling and won’t get to it for a bit.

Message 8 of 8
Share this topic
Share this topic
Announcements...
Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!
Additional Support