Explore & discover

Helpful Links

NVG510 Bridge Mode???


NVG510 Bridge Mode???

Just switched from DSL (Motorola 2210) to UVerse (Motorola NVG510). I set the 2210 into bridge mode and ran my home network from an Apple Airport Extreme Base Station (AEBS). I have some complex configurations on my network and figured I'd be able to do the same thing with the NVG510. However, it seems the NVG510 uses different terminology than I am used to.


Under Firewall/IP Passthrough, I set:

Allocation Mode to 'Passthrough'

Passthrough Mode to 'DHCPS-Fixed'

Passthrough Fixed MAC Address to the AEBS' MAC address

And, I left the Lease at the default 10 minutes.


On the AEBS, under Internet/Internet Connection, I switched from 'PPPoE' to 'Ethernet'. I left the Ethernet WAN Port value at 'Automatic (Default)'. And Connection Sharing is set to 'Share a public IP address'.


This apparently is not enough, though. The AEBS reports that the "Wi-Fi base station does not have a valid IP address", and that there is a "Conflicting DHCP Range".


How do I turn off the DHCP on the NVG510? And, what are the correct settings to put the NVG510 into bridged mode?

Tags (3)
Message 1 of 90

Re: NVG510 Bridge Mode???

Hi all, Just been force-marched to uverse, and got stuck with this NVG510. Have read all through this thread and been trying to implement the IP Passthrough work around for my Belkin N600DB. When I get to to firewall settings, the dhcps box is greyed out (can't change) nor can I input the Belkins fixed mac address. Same when I try to change Public IPv4 add., subnet, ect. Says the software is v9.0.6h2d21, and datapump? is vA2pD035b.d23i Went to Mot's web site to see if ther was updates to no avail. Have spent two days on this crap; maybe it's time for xfinity. Any help would be greatly appreciated.
Message 76 of 90

Re: NVG510 Bridge Mode???

"When I get to to firewall settings, the dhcps box is greyed out (can't change) nor can I input the Belkins fixed mac address. Same when I try to change Public IPv4 add., subnet, ect."


Is your "Allocation Mode" set to "Passthrough", @fedup4sure? That setting should allow you to select "DHCPS-fixed" from the "Passthrough Mode" dropdown, enter the "Passthrough Fixed MAC Address", and edit the "Passthrough DHCP Lease" settings (if desired).


For the other settings, make sure your "Public Subnet Enable" is set to "On" - if you want to edit those. That's optional, though. You can stick with just the "Private LAN Subnet" values for a typical configuration.


If you already have the right dropdown values selected, and you still can't edit the associated values, you might try a factory reset. Failing that, you might want to request a replacement or further assistance from AT&T.

Message 77 of 90


I switched to u-verse recently and it came with this gateway.  I quickly discovered it didn't have an option like "bridge mode" I was used to seeing.  I read and tried many internet fixes that did not work.  I was going to be satasfied if my third party router (not the AT&T gateway) could get the public ip assigned to it instead of the NVG510's private ip pool and if I could verify that no ports were being blocked.  I have succeeded and this is what I did; sorry no step-by-step instructions, I'm sure you guys can figure that part out:


made sure my third party router was not using the same subnet for its LAN as the motorola one (anything but 192.168.1.xxx)


disabled the motorola's wireless networking


changed the motorola's home netowrk DHCP to only have 1 ip address avaliable in the start and end section (although in-theory you could skip this step)


in IP passthough settings on the motorola used 'passthrough' under allocation mode and 'DHCP-DYNAMIC' under passthough mode (I have never seen an internet fix use the dynamic option and this might explain why no one seems to have any real results with this, and yes I tried the other options too)


saved settings and let the motorola restart its self


went into my third party router and set its internet settings to 'no login required', 'get ip address dynamically from ISP', and 'get DNS automatically from ISP'


saved settings and let the third party router restart


voila!; when the third party router came back up it had the public ip address!!


now the final test; testing for blocked ports.  used a torrent program that has a port-checking feature in its configuration (previous network configurations on the gateway and router had produced "port is closed") this time, "port is open"!


I declare success; my third party router has been assigned a public ip address on the WAN and the motorola gateway is not blocking any ports





Message 78 of 90

Re: NVG510 Bridge Mode???

I'm on the "9.0.6h2d21" software version on a  NVG510, and IP Passthrough doesn't work... but I know why:


The subnet mask given to my router via DHCP is "", which is f^*#ing impossible.  A /32 subnet (if you can call it that) doesn't have any space for hosts.  In order to have a network, you need space for at least two hosts... yours and at least one peer (like your ISP's router).


I did the math, and manually configured by WAN interface... only changing the subnet mask to define the smallest network that hold both my previously-DHCP assigned IP and the gateway.  That one change did it, and now the public IP on my non-AT&T router works like it should.


I tried calling AT&T technical support to report the problem and ask for a fix.  Unfortunately, this went way over the head of the nice Indian technical support person.  He just told me to push a paperclip into the little hole in the back of the unit for 10 seconds (sigh).


I'm not leasing my IP address from the DHCP server, so I have every reason to expect my IP will be assigned to someone else... causing me an outage.  I'd rather the IP Passthrough just work properly and give the the correct subnet mask, but getting the Death Star to listen to the Little People is a likely exercise in futility... no?

Message 79 of 90


But for your non-pseudo bridge mode - does it resolve the DNS timeout issues the same way the other method does?


And, shouldn't the short DNS timeout problem with this modem have been resolved by now? I mean, it's been going on since 2011...

Message 80 of 90


I agree; AT&T should work with Motorola to solve their customers' concerns about this.  Honestly, I haven't had any of these DNS timeout issues.  This is just a guess but, some people might be having problems like this because of a setting on their routers and not the motorola gateway. 

Message 81 of 90


Some people, maybe; but the gateway definitely has a problem. It's been known now for a very long time, and Motorola says they made the Gateway the way AT&T told them to. (The Motorola tech noted also that they had never seen a setup like this one before on any modem/router they've made, and were shocked that AT&T designed it that way.)


One firmware update has come out in the life of this gateway. It fixed a couple of things related to port forwarding and VPN, but rare AT&T techs have even admitted that they're aware of a long list of issues with this gateway, including the DNS problems.


I'm sure AT&T has tons of people with only one or two computers on their network and no special setup - thus needing no second router or other special settings. The rest of us are probably just flies buzzing around their ears. We apparently don't make enough of a financial dent to make it worth the company's while to get this fixed ASAP.


Message 82 of 90


Very sorry to hear this. 


In my case, I connected the RG to my AEBS which sets DHCP/NAT to multiple devices. The AEBS warns me about "Double NAT", but everything was working...except for the baby cam. I have a Foscam IP baby cam on a reserved NAT address, and it no longer is accessible on the dedicated web page. I can only view the cam on the LAN. I am not a network expert but I assume the double NAT is not allowing the web site to find the IP address of the camera on the WAN. 


I assume I am going to have to try the pseudo bridge mode and hope that resolves the problem.


I was using AT&T DSL with dumb Speedstream modem and all was fine. Now, I "upgrade* to U-verse and expect everything to be better....instead, problems.


Very sad.

Message 83 of 90

Re: NVG510 Bridge Mode???

Motorola recommends using Passthrough Mode of DHCPS-Dynamic, not Fixed:




In this case, what IP address is actually passed through?


I need to set up a bridge mode so I can access my IP camera from a web page using my WEBS. Will this do it, or do I need to use Fixed?

Message 84 of 90

Re: NVG510 Bridge Mode???

You need to change one of your devices (either the gateway or another router) to operate on different subnets.  Its the first step on many of these "fixes" to avoid problems like that from the get-go.

Message 85 of 90

Re: NVG510 Bridge Mode???

It is indeed possible to do this; I am doing it right now using a Linksys E3000 as the router and the Motorola NVG510 as a pass-through.


I did the following:


- I set the IP of the router to and then use a different subnet for my internal home network (e.g.


- key setting on the NVG510 is under "Firewall | IP Passthrough".  Settings (default address of NVG is in order to make these changes):


allocation mode:  default server

default server internal address:


- you'll need to reboot NVG once saving these settings.


- you'll also want to turn OFF the wireless signal for the modem just to reduce potential interferance from your router. 


Hope this helps!

Message 86 of 90

Re: NVG510 Bridge Mode???

So your solution is to manually set the settings. As for the missing stuff you can just connect directly to the modem or get the settings from the modem b4 you set it to Passthrough. I'm not using an Airport device but rather a Dlink router and saw some of the same weird thing.

When surfing on WIFI using phones when opening the pages it always took long, quite annoying, and seeing this I tried it and boom its fine now. lol you know what is funny too. I had my router set to clone the same MAC as a PC on the network and while that PC was directly connected to the ATT modem/router it was getting the IP address too and surfed. getting no IP conflict at all. it was fine...weird right? After changing that though I still had the issue until using a manual config for the router's (a Dlink DIR-825) WAN settings.

Also weird is the ATT router is giving out that 1 address to a device that I cannot find. I disconnected all cables from it and it still showed up. I assumed it to be my DLINK but nope.... It says it is on Ethernet and using DHCP but while nothing at all is connected to it, it still shows up even after a reboot. Weird stuff.
Message 87 of 90

Re: NVG510 Bridge Mode???

For what its worth, I was able to get this to work just by changing the Firewall settings to passthrough with DHCPS-fixed and supplying the mac address of my router. After the reboot of the NVG510 I also rebooted my router.




Message 88 of 90

Re: NVG510 Bridge Mode???

This worked for me with a 4th gen AEBS. Thanks so much!

Message 89 of 90

Re: NVG510 Bridge Mode???

I had been using Jordan Earl's hack for years on these modems to achieve "true" bridge mode, but recent updates by AT&T have been causing problems with modems I've set up that way.  I finally changed one of my clients to the setup posted by lisfolks at the beginning of this thread and ran it successfully that way for the last couple of weeks.


After revisiting the problem and reading this entire thread today, I tested some more configurations and came up with the following setup (starting with NVG510 defaults):


1.  You don't need to change anything in Home Network -> Subnets & DHCP if you don't want to: the NVG510's DHCP server will hand the public IP off to the device specified below (which is presumed to be connected to one of the LAN ports of the NVG510).  Any other devices connected directly to the NVG510 (either wirelessly (if you don't disable it in step 2. below) or via the other LAN ports on the NVG510) will get IP addresses in the default subnet (192.168.1.nnn) and will be able to access the internet but NOT see any devices behind your "real" router (assuming you have it set up on a different subnet!!).


2.  Disable NVG510 Wireless in Home Network -> Wireless.


3.  In Firewall -> IP Passthrough, use the same settings originally suggested by lisfolks:

  • Allocation Mode: Passthrough
  • Passthrough Mode: DHCPS-fixed
  • Passthrough Fixed MAC Address: <MAC address of the home router>
  • Passthrough DHCP Lease: (see paragraph below for possible change)

4.  It is no longer necessary to configure your home router with a static IP address; the NVG510 will now honor the IP Passthrough setup and pass the WAN IP settings through to the device specified by the Fixed MAC Address.  This resolves the issue originally mentioned by ktalley back in post #15 of what happens when the public IP of the NVG510 changes (which as most of you know, almost NEVER occurs!).


One more caveat: when I changed my router (DLink DIR-330) setup from a static IP to using a dynamic WAN IP address, everything appeared to work EXCEPT a site-to-site VPN tunnel I had configured would get torn down and rebuilt every few minutes.  I "fixed" this one issue by changing the "Passthrough DHCP Lease" time (under Firewall -> IP Passthrough) from the default (10 minutes in my case) to the maximum (99 days!).


I'm guessing this now works (as opposed to NOT working back in 2011 when this thread was started) because of firmware updates (2d30 or 2d45) made by AT&T over the last couple years (As of today, the current firmware rev on the NVG510 is v9.0.6h2d45).


Hope this helps anyone still struggling with this modem,


[Third party link removed]


Message 90 of 90
Share this topic
Share this topic

Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!

Additional Support