NVG510 Bridge Mode???

Mentor

NVG510 Bridge Mode???

Just switched from DSL (Motorola 2210) to UVerse (Motorola NVG510). I set the 2210 into bridge mode and ran my home network from an Apple Airport Extreme Base Station (AEBS). I have some complex configurations on my network and figured I'd be able to do the same thing with the NVG510. However, it seems the NVG510 uses different terminology than I am used to.

 

Under Firewall/IP Passthrough, I set:

Allocation Mode to 'Passthrough'

Passthrough Mode to 'DHCPS-Fixed'

Passthrough Fixed MAC Address to the AEBS' MAC address

And, I left the Lease at the default 10 minutes.

 

On the AEBS, under Internet/Internet Connection, I switched from 'PPPoE' to 'Ethernet'. I left the Ethernet WAN Port value at 'Automatic (Default)'. And Connection Sharing is set to 'Share a public IP address'.

 

This apparently is not enough, though. The AEBS reports that the "Wi-Fi base station does not have a valid IP address", and that there is a "Conflicting DHCP Range".

 

How do I turn off the DHCP on the NVG510? And, what are the correct settings to put the NVG510 into bridged mode?

Message 1 of 90 (182,587 Views)
Teacher

Re: NVG510 Bridge Mode???

If you still need a solution, I've got one. Just did this myself. Took all bleepin' week before I got it worked out. If you have a block of public static addresses DO NOT bother trying to get "passthrough" mode to work, it is not necessary.

 

Simply do the following:

 

On the NVG510, go to Home Network tab, then Subnets and DHCP under that.  Go to Public Subnet Enable, and turn it On.

 

Place the last available address in your static public subnet in the "Public IPv4 Address" field. This is now the router's address in your public subnet block. Set the Subnet Mask appropriately (I have 5 usable in a subnet of 8, so I put 255.255.255.248). You can put the range of addresses in, not sure if it is necessary or not. I set the primary DHCP Pool to Public, but in hindsight that is most likely unnecessary, and perhaps even a bad idea. The KEY thing is that you turned it ON and set the IP address of the router... This lets the router know what the public address block is, and allows traffic to flow to devices on the LAN side that are assigned (by DHCP or statically) addresses in that block. I think if you leave that "Primary DHCP Pool" at private, you could leave the wireless option ON and devices could then get to the internet that way, but be given addresses from the "private" DHCP pool. They won't really be on your real private network, though, because that's setup on your other "real" router... And this NVG510 has NO static routing capability, at least none that you are allowed to set, so you cannot send traffic from its wireless clients back to your other router... But I digress...

 

Now, I have a Cisco 877, and I plugged FastEthernet0 port into the back of the NVG510 router. I then manually configured a vian with the rest of the addresses in my public block, and set the default route to the address you put into the NVG510's "Public IPv4 Address" field. Well, here are the details, including the fact that I had a site-to-site VPN setup (crypto map), and that is indeed working once again with the new default address of vlan2 below. For demonstration purposes, assume my public IP block is the 1.1.2.56 255.255.255.248 block...

 

Here are the relevant sections of my configuration:

crypto map myMapKey local-address Vlan2

!

...

interface FastEthernet0

switchport access vlan 2

no cdp enable

!

...

interface Vlan2

 description internet

 ip address 1.1.2.57 255.255.255.248

ip address 1.1.2.58 255.255.255.248 secondary

ip address 1.1.2.59 255.255.255.248 secondary

ip address 1.1.2.60 255.255.255.248 secondary

ip address 1.1.2.61 255.255.255.248 secondary

ip nat outside

ip virtual-reassembly

crypto map myMapKey

!

...

ip route 0.0.0.0 0.0.0.0 1.1.2.62

...

ip nat inside source list 110 interface Vlan2 overload

ip nat inside source static tcp 192.168.1.10 80 1.1.2.57 80 extendable

ip nat inside source static tcp 192.168.1.20 80 1.1.2.58 80 extendable

ip nat inside source static tcp 192.168.1.30 80 1.1.2.59 80 extendable

 

You'll have to figure out how to do this similarly with your router, I don't know anything about that one... Hopefully this is relevant and useful for setting that router up as well...

Message 46 of 90 (50,505 Views)
Teacher

Re: NVG510 Bridge Mode???

There is also a "Cascaded Router" option that may work for you as well, I have firmware 9.0.6h0d48, and the Home Network Subnets and DHCP page looks like this: 

 

And instructions look like this:

 

That sounds exactly what a lot of users could use!  I didn't try it, but it may be easier to configure for some people than the way I explained in my previous post.  Hope you find this helpful.  I spoke with someone at Motorola (1-877-466-8646 ) and they don't have much additional documentation on this feature. I asked that they consider writing it up and making it easily accessible.  They have a site http://motorola.com/mygateway where I found several documents about the NVG510, but they look out of date by a few months and the firmware is getting better and better...

 

Message 47 of 90 (50,500 Views)
Highlighted
Voyager

Re: NVG510 Bridge Mode??? and E2000 routers

[ Edited ]

Great help, thanks all. 

 

Switched to AT&T to save a few bucks and guess I learned why/how they can do that after spending a day of my life reconfiguring the home network.

 

Anyway, just wanted to add or maybe emphasize a couple things that might be helpful, particularly to those using Cisco Linksys E2000 routers:

 

1.  Yes, you DO hook it up through the physical INTERNET port on the back of the unit.  There are nice pictures posted that show this in this thread, and while you might get internet to work with the RG plugged into ports 1-4 (I did), it really needs to be in INTERNET port for important reasons (Other pass-through capabilities).

 

2.  On the E2000 In Advanced Routing make sure that NAT is switched ON, and Dynamic Routing is turned OFF.

 

Generally, when making all the changes it's helpful to make sure everything wireless is turned off.  I had a wireless print server, a wireless security camera and some Blackberrys all getting assigned local IP addresses during setup which was annoying, as I focused on getting reliable Bridge AND most importantly, VPN to work properly through the bridge, which I did.  Next on the list is Remote Desktop.  Not working yet, but hopeful.  Smiley Happy

Message 48 of 90 (50,406 Views)
Contributor

Re: NVG510 Bridge Mode???

Thank you for the solution. Is this still the way to go? I saw there was a cascaded router option, but I'm not sure why that might be better if it would would at all.

Message 49 of 90 (49,851 Views)
Mentor

Re: NVG510 Bridge Mode???

I tried using the cascaded router option 1st thing, since that seemed like it would make the most sense. However, I couldn't get it to work. That's when I came up with the solution here. I haven't seen any better solution so far (nor have I seen the firmware update AT&T's support was promising to come in late December!).

 

Good luck!

Message 50 of 90 (49,841 Views)
Contributor

Re: NVG510 Bridge Mode???

i changed all the same settings on the nv510 that you did. 

 

Under Firewall/IP Passthrough, I set:

Allocation Mode to 'Passthrough'

Passthrough Mode to 'DHCPS-Fixed'

Passthrough Fixed MAC Address to the AEBS' MAC address

And, I left the Lease at the default 10 minutes.

 

on my airport extreme with the newest firmware and the newest airport configuration utility 6.0. i set this. 

 

on the internet tab

ip address : 192.168.1.1

subnet255.255.255.0

router address  192.168.1.254

 

and i used different DNS settings because for some reason this nvg510 will fail on DNS

so i put in the open DNS servers

 

primary DNS  208.67.222.222

secondary DNS  208.67.220.220

 

under network tab. i picked DHCP only.  

with the default DHCP ranges of 192.168.1.2 - 192.168.1.200

 

now each and every device connects to my AEBS, and gets the open DNS  servers so i don't have pages or images not loading on the page anymore.

 

what's really bad is that i tried taking the airport extreme out completely and i still got the DNS issues where pages wouldn't load certain images and stuff.  the NVG510 needs a firmware update pronto.

 

Message 51 of 90 (49,629 Views)
Contributor

Re: NVG510 Bridge Mode???

ok i did some more experimenting.  i put the at&t DNS servers in manually on my airport extreme.  and it seems like it's fine.   the only time DNS fails is when the nvg510 provides the DNS servers.     when i manually specified the DNS servers on my airport extreme then it works fine.  

Message 52 of 90 (49,621 Views)
Mentor

Re: NVG510 Bridge Mode???

Yes, the NVG510 has known DNS issues. The DNS values listed in the settings are fine, but the NVG510 doesn't use them correctly. Putting them into your setup manually works great. Another thing they were supposed to fix with a firmware update promised to be put in late last December - that we haven't seen yet...

Message 53 of 90 (49,582 Views)
Contributor

Re: NVG510 Bridge Mode???

Here's what we were able to do to get multiple static public IP's to pass through a Motorola NVG510 to our own router with AT&T U-verse:

 

1) Get your static public IP(s) and subnet information from AT&T, this is NOT what is listed under the Broadband tab in the NVG510 router, you may have to call AT&T to find out if they didn't send you the information when you signed up.

 

For the following examples, let's say you ordered 5 static IP's:

Static Public IP(s): 108.77.55.1 through 108.77.55.6 (I know that counts as 6 IP's and not 5, but read ahead)

Static Public Subnet: 255.255.255.248 (or /29).

 

Your entire subnet range is actually 108.77.55.0 through 108.77.55.7 (because .0 is used as network/subnet address, .7 is used for broadcast, and 1 out of the other 6 IP's are reserved to be used as a gateway with this U-verse setup).

 

2) Access the NVG510 web management interface and go to "Home Network" then "Subnets & DHCP"

 

3) You can probably leave the private address to whatever you want (however, depending on your router that you will have connected behind the NVG510, you may or may not have conflicts if you set it up on the same subnet. It's probably safer to NOT have the NVG510's private address set on the same subnet as any other subnet your other router is using.

 

4) Using the example IP's above, set the following:

 

Public Subnet: Enable/On

Public IPv4 Address: 108.77.50.6 (last usable is what we used, but you can probably use any of the usable IP's .1 through .6)

Public IPv4 Subnet: 255.255.255.248

Public Subnet DHCPv4 Start Address: 108.77.50.5 (Just did this to satisfy the router saying it can't stay blank, it can probably be any of the usable IP's)

Public Subnet DHCPv4 End Address: 108.77.50.5 (Just did this to satisfy the router saying it can't stay blank, it can probably be any of the usable IP's)

Primary DHCP Pool: Public

 

5) On your own router, you'll need to change the WAN/external connection to the following:

 

Connection type: Manual

External IP: 108.77.50.1

External Subnet: 255.255.255.248

External Gateway: 108.77.50.6

 

* You can also add in the additional public IP's into your routers external configuration as secondary IP's if it allows so, using the same subnet and gateway.
6) Now you'll just need a cable going from the NVG510's yellow/local ethernet ports to your own routers WAN/external port.

Message 54 of 90 (49,503 Views)
Contributor

Re: NVG510 Bridge Mode???

When they initially tried selling me U-Verse and mentioned they'd be sending me a new modem, I *specifically* asked if it was compatible with my Airport Extreme, an dI was told "Oh, yes, and if you have any problems setting it up, just call us and we'll be able to walk you through it." Which turned out to be a LIE.

 

I am going through this right now, and SO frustrated.

I don't quite understand all the instructions on this thread, but I'm going to try to make it work.

 

This is after they failed to mention that my DSL was going to be deactivated a week before the U-Verse was to be installed. Completely ridiculous.
~T

Message 55 of 90 (49,012 Views)
Contributor

Re: NVG510 Bridge Mode???

Ok I am a little lost on the instruction on how to do this.  Had to bridge my DSL modem before but att walked me all the way through.  Tried contacting them but they would not help me to do it this time.  So can someone please explain to me how to bridge my nvg510 with my netgear wnr834b.  I am finding nothing helpful on google that I can understand.

Message 56 of 90 (48,148 Views)
Explorer

Re: NVG510 Bridge Mode???

I've been trying to bridge my 2701 to the uverse 3800 gateway. I have been successful in doing so but cannot access my security cameras remotely anymore. I had 2 phone lines with dsl service on both. Then I switched my main line to uverse tv & internet (without the voip phone). Well they turned my dsl off my second line!!!!! This was running my cameras and 2 ethernet computers. I have been calling them for over a week, and they transfer me around and then disconnect me. Now i have 2 computers not even hooked up because the 3800hg only has 4 lan ports and they are using some of them already. They also said dsl is not available in my area

HE HELPS THOSE WHO HELP THEMSELVES
Message 57 of 90 (48,123 Views)

Re: NVG510 Bridge Mode???


qb55 wrote:

I've been trying to bridge my 2701 to the uverse 3800 gateway. I have been successful in doing so but cannot access my security cameras remotely anymore. I had 2 phone lines with dsl service on both. Then I switched my main line to uverse tv & internet (without the voip phone). Well they turned my dsl off my second line!!!!! This was running my cameras and 2 ethernet computers. I have been calling them for over a week, and they transfer me around and then disconnect me. Now i have 2 computers not even hooked up because the 3800hg only has 4 lan ports and they are using some of them already. They also said dsl is not available in my area


 

If you're talking about a 2WIRE 2701, don't waste your time, just buy a switch like this one :http://www.newegg.com/Product/Product.aspx?Item=N82E16833122111  $50 after rebate. A lot fewer headaches than trying to "dumb-down" the 2701 to act as a switch.

 

 




__________________________________________________________
How can you be in two places at once, when your not anywhere at all?
------------------------------------------------------------------------------------------------------
I really want to become a procrastinator, but I keep putting it off.
------------------------------------------------------------------------------------------------------
There are three kinds of people, those that can count, and those that can't.
------------------------------------------------------------------------------------
“Our great democracies still tend to think that a stupid man is more likely to be honest than a clever man, and our politicians take advantage of this prejudice by pretending to be even more stupid than nature has made them." :Bertrand Russell

                              

Message 58 of 90 (48,116 Views)
Contributor

Re: NVG510 Bridge Mode???

Fun, looking like I now get to go through all this. Smiley Sad

 

Going from a SpeedStream DLS Modem to the NVG510

I'm using DynaDNS for a testing server, and this Testing Server is also the DNS For the house (That way any computer in the house can access my internal pages)  

My Connection has been bouncing up and down all day as I try different configurations, time to reread this thread & have another go.

 

Message 59 of 90 (47,152 Views)
Explorer

Re: NVG510 Bridge Mode???

Well, I dumbed down the 2701. Changed the router name to the same as the 3800, gave it another address, used the same network key as the 3800, enabled bridge mode and VOILA!! All cameras working except my Foscam on 3g when I'm away from my wireless at home. Just gotta figure that out. Will the netgear you mentioned let me do that?

HE HELPS THOSE WHO HELP THEMSELVES
Message 60 of 90 (47,113 Views)
Share this topic
Announcements

Welcome to the AT&T Community Forums!!! Stop by the Community How-To section for tips on how to get started.