How can I enable UPnP on my wireless router?

Contributor

How can I enable UPnP on my wireless router?

 
Message 1 of 19 (118,731 Views)
ACE - Expert

Re: How can I enable UPnP on my wireless router?

If you mean your AT&T provided RG, then you cannot.

 

If you mean your personally provided Router, then follow the manufacturer's instructions.

 

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 2 of 19 (118,532 Views)
Contributor

Re: How can I enable UPnP on my wireless router?

That's some crap, I knew 2 wire made cheap equipment but no NAT-PMP or UPnP in this day and age is just ridiculous..

 

The whole router behind router works if you don't need any of your devices on the same network as your gateway, so if you don't want to use the wireless receiver or iOS apps as a remote you're set but if you want all the U-verse features and NAT-PMP or UPnP you're screwed.. hopefully they come out with new RG's that support this soon..

Message 3 of 19 (118,313 Views)
Community Support

Re: How can I enable UPnP on my wireless router?

@blizzario, visit this thread for more information: http://forums.att.com/t5/Receivers-Battery-Backup/Does-the-ATT-UVERSE-suppied-modem-fully-support-UP...

Did a post have a solution that worked for you? Help other people find solutions faster by marking posts that helped you as an "Accepted Solution". Learn about accepted solutions here.

Employee Contributor*
*I am an AT&T employee and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 4 of 19 (118,267 Views)
ACE - Expert

Re: How can I enable UPnP on my wireless router?


vcdx71 wrote:

That's some crap, I knew 2 wire made cheap equipment but no NAT-PMP or UPnP in this day and age is just ridiculous..

 

The whole router behind router works if you don't need any of your devices on the same network as your gateway, so if you don't want to use the wireless receiver or iOS apps as a remote you're set but if you want all the U-verse features and NAT-PMP or UPnP you're screwed.. hopefully they come out with new RG's that support this soon..


UPnP is a security hole waiting to happen.  It is a poorly conceived band-aid for improperly conceived connection setup protocols.

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 5 of 19 (118,230 Views)
Highlighted
Contributor

Re: How can I enable UPnP on my wireless router?

I'm having issues with connecting to XBOX Live via my ATT Uverse Wireless Gateway. I can sometimes connect to XBOX Live, but not all the time, and the main problem is that I cannot regularly connect to multiplayer games or hear other people chat that I am playing with. This could be an issue with running too many wireless devices in my home at one time, because I can sometimes connect to multiplayer games, but other times not.

 

To correct this issue, XBOX recommends enabling UPnP, but it seems that enabling UPnP is not only impossible with the ATT Uverse router, but also a potentially dangerous security hazard. Is there anything you can recommend that I do in order to make my connection to XBOX Live stronger and more regularly sucessful? 

Message 6 of 19 (117,901 Views)
Contributor

Re: How can I enable UPnP on my wireless router?

I found this thread while I was looking for the answer to a warning/message I got when I  signed into xBox Live for the first time with my new Uverse account.    I am that hermit referrred to above, I use my xBox for Netflix and Hulu and a couple Arcade games (single player)  I only keep Live active for my son, up at college and I never join online multiplayer games.   The error was the NAT error spoken of in this thread ....it says my setting is on Moderate and may affect my game play experience.  It said to enable uPnP or open a certain port.  my question, after all that, is:  Will the few things I listed above all have full functionality without opening a port or enabling anything?   That way I can wait for him to come home to do it himself *grin*   I really don't want to think about this if I don't have to  Smiley Happy   thanks, in advance, Vinni

Message 7 of 19 (103,618 Views)
Expert
Solution
Accepted by JefferMC (ACE - Expert)
‎09-30-2015 1:39 AM

Re: How can I enable UPnP on my wireless router?

See the following post for detailed instructions on how to configure the 2Wire routers for the XBox 360:

http://forums.att.com/t5/Residential-Gateway/XBox-Live-problem-2wire-NAT-is-not-open/m-p/3449081#M93...

Message 8 of 19 (103,608 Views)
Contributor

Re: How can I enable UPnP on my wireless router?

I have purchased a chromecast which will allow me to watch movies on my ipad on my tv.  But I get an error saying that I need to enable Upnp on my wireless router.  Can someone explain to me how to do this?  Thanks

Message 9 of 19 (102,298 Views)
ACE - Expert

Re: How can I enable UPnP on my wireless router?

[ Edited ]

As you may have read above, you cannot enable UPnP on the AT&T provided Residential Gateway.  If you want UPnP, you'll have to acquire another router which does have that and install it behind the RG.  You can look see post 2 in this thread on how to do that.  Then you can follow the instructions in the box with the router you bought to enable UPnP.

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 10 of 19 (102,125 Views)
Contributor

Re: How can I enable UPnP on my wireless router?

This would be more helpful if i didn't get "Sorry, you do not have sufficient privileges for that action.

Please click the Back button on your browser." when i click the link. trying to set up a small home buisness server and i want to adjust my router settings so that the server can set all the ip address not the router

Message 11 of 19 (86,163 Views)
ACE - Expert
Solution
Accepted by JefferMC (ACE - Expert)
‎09-30-2015 1:39 AM

Re: How can I enable UPnP on my wireless router?

[ Edited ]

devildogwillbur wrote:

This would be more helpful if i didn't get "Sorry, you do not have sufficient privileges for that action.

Please click the Back button on your browser." when i click the link. trying to set up a small home buisness server and i want to adjust my router settings so that the server can set all the ip address not the router


Sorry, the post the Accepted Solution turned into a flame war later on and has been closed and retired.  Here is a post from SomeJoe7777 that addresses the issue in that thread:

 


SomeJoe7777 wrote:

It's a convenient feature, but it's a band-aid on the real problem:

 

• Firewall holes wouldn't be necessary with properly designed protocols in most cases.  There is no reason that a client application behind the firewall should have to have an inbound port opened.  Only server applications should need that functionality.  FTP is a prime example of a poorly designed protocol.

 

• NAT is the root of all evil. :smileywink:  Once IPv6 becomes commonplace, NAT will get it's long-overdue burial.  Without NAT, the network design is simpler and many firewall problems are eliminated.

 

• UPnP is a security nightmare.  One clever piece of malware on one computer just allows it to open the door for every other piece of malware to walk in.

 

 

As for specifically why 2Wire chose not to support UPnP, I don't know.  But really, a properly designed network shouldn't need it.

 


*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 12 of 19 (86,146 Views)
Contributor

Re: How can I enable UPnP on my wireless router?

i cant see the page
Message 13 of 19 (83,945 Views)
ACE - Expert

Re: How can I enable UPnP on my wireless router?

Please see my post right above yours.  It contains all the information you would need to see from the hidden page.

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 14 of 19 (83,938 Views)
Contributor

Re: How can I enable UPnP on my wireless router?

Why is it there is an answer but i dont have clearance to see it? Wow what a great help this forum is. 

Message 15 of 19 (82,982 Views)