Explore & discover

Helpful Links

BGW-210 IP Passthrough speed slowdown

Tutor

BGW-210 IP Passthrough speed slowdown

I have successfully configured my new BGW-210 to use the IP passthrough feature so I can use my own router (ASUS RT-AC1750).  The functionality is there no problem (I can access my internal network and the internet just fine), but the speeds are slowing down from over 900mbps to around 500mpbs.  I've verified that the firewall and the wifi of the modem are both turned off.  I've also verified my LAN speeds are not bottlenecked by my router (getting around 900mbps no problem from one computer to another).  Using the same computer, wired, through the modem is fine, but simply switching the cable to go through my router slows it down by 400mbps.

 

Any successes with maintaining gbps speeds through the IP Passthrough feature?

 

Danny G

4,078 Views
Message 1 of 11
Tutor
Solution
Accepted by topic author
Accepted by dlgrasse
‎01-29-2019 5:24 AM

Re: BGW-210 IP Passthrough speed slowdown

After scouring the internet again and re-reading everything I could find, I decided to try an idea I saw in one of the forums...set up my own router in Access Point mode.  This ended up being a better option that I was originally expecting.  The end result was that 1) all wired traffic gets the expected 940mbps+, and 2) I get to use all ports in both devices.

 

For anybody else who looks for a solution, here's what I did:

  1. Reset the ATT device (BGW-210 modem) to factory settings
  2. Disable all wi-fi
  3. Restart it
  4. Plug whichever ethernet cables you want into it, but including your own router
  5. Log onto router and change it to Access Point mode
    • Mine asked if I wanted to keep all wi-fi configurations, so I did
  6. Restart router
  7. Plug whatever ethernet cables you want into it

Speed tests are now showing full speed through the router and modem alike.  I had to reconfigure my static IPs and port-forwarding in the modem, but that's a one-time config task, and well worth it to keep the gbps speeds and double my port availability.

 

Danny G.

Tags (1)
Message 2 of 11

Re: BGW-210 IP Passthrough speed slowdown

May I ask what router did you use and basically the only reason im thinking of obtaining a rourer/access point is to plug into my BGW210 (Modem/gateway/router) and allow my wifi speeds to be faster and increased distance due to only being able to get in the 200s however my old provider spectrum I could get 400 through there modem and separate router equipment. If my BGW210 is wired i get 900s

Message 3 of 11
ACE - Professor

Re: BGW-210 IP Passthrough speed slowdown

I have read in other forums that turning on QOS can limit wired speeds. If you try connecting it as a router again, try turning off QOS. In access point mode, is your router iworking as a gigabit switch for wired?

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 4 of 11
Tutor

Re: BGW-210 IP Passthrough speed slowdown

Mine's an ASUS RT-AC1750.  I'm still getting 900+ wired through their modem/router and mine both.

Message 5 of 11
Tutor

Re: BGW-210 IP Passthrough speed slowdown

My QoS was definitely turned off, and I don't expect to need with with gbps internet speed.

 

And yes, in AP mode, my router's wi-fi and wired ports are all working.  That's what I was referring to in my original response/solution about doubling my ports.

Message 6 of 11
Scholar

Re: BGW-210 IP Passthrough speed slowdown

I too have scoured the Internet for a resolve.  Using the BGW210 I was getting hardwired speeds consistently at 920 up until August of last year.  Now can only get 250 to 350 on two different computers hardwired trying different Ethernet cables, different locations etc etc etc.  I gave all my routers away because this worked, now it doesn't.  So your saying I need to get another router and use this method to get my speeds back?  A technician is coming back Friday after installing a new, replacement BGW210 and testing twice and getting 940 Mbps down.  He left.... and so did the speed.  I have tried dozens of suggestions to no avail and was preparing to switch back to cable.

Message 7 of 11
Scholar

Re: BGW-210 IP Passthrough speed slowdown

Might I ask you to confirm that you were once getting 900 speeds with the BGW210 and then you weren't?  Thus the reason for installing another router and using pass through? They keep showing me 1000 Mbps to the gateway, but now (since last August, apparently) I haven't gotten over 350 down on my qualified gaming laptop.  I used to consistently get 920 down and up.

Message 8 of 11
Contributor

Re: BGW-210 IP Passthrough speed slowdown

The marked "Solution" on this thread is not really a solution. Using your 3rd party router in AP mode is a different way to set this up that I agree will solve the speed problem, but then you lose the ability to have a 3rd party router handle the routing and security and the MUCH better functions you can get with a higher end router. Putting your 3rd party router in AP mode means all of the routing/security is being handled by the Arris which is very different than bridge mode. If you just want to add a 3rd party wifi access point then this works, but that is not the point of bridge mode/IP Pass through. With IP Passthrough, the modem should only be doing the security hand off and then your router should be handling all of the networking and security without any interference or double NAT. A simple Google search shows that this is a very prevalent problem regardless of the 3rd party router being used and nowhere have I seen an actual solution that allows you to approximate bridge mode on the Arris and not lose speed. I can't believe I'm saying this, but it has me considering Comcast since AT&T clearly doesn't care.

Message 9 of 11
Contributor

Re: BGW-210 IP Passthrough speed slowdown

I've got this problem resolved and am getting 900+ Up/Down using IP Passthrough.

 

I agree with @pasmulli - this shouldn't be marked Solved. Putting the router in AP mode isn't the solution.

 

The solution is to not turn off all the Firewall settings on the BGW210. Seems contradictive, but for whatever reason it works. I reset them to default (which leaves some of them On and some Off), turn off Packet Filter and setup IP Passthrough using DHCP-fixed. That's it. Speeds back to normal, and my router is getting a public IP on its WAN.

 

Hope this helps.

Message 10 of 11
Scholar

Re: BGW-210 IP Passthrough speed slowdown

Hopefully this will be resolved on the router in the future, so those of us who have no idea what your taking about can take advantage of services offered... but not delivered.

Message 11 of 11
Share this topic
Share this topic
Announcements

Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!

Additional Support