Explore & discover

Helpful Links

Why is my device assigned an 108.x.x.x IP address?


Why is my device assigned an 108.x.x.x IP address?

I have 4 desktops and 3 lap tops connected to the LAN in my home.  From time to time, one of my machines will appears to be "isolated" from the rest of the net work. That machine can access the internet fine, but I can't be seen by the rest of the machines on the network. Remote desktop and network access all fail.  I finally figured out why.  The reason is that machine is assigned an ip address starting with 108.x.x.x.  I got this by checking the Device/Status page of my RG.


Device IPv4 Address / Name




Does anyone know why this happens and how to fix it?  I don't want any of my machine to be assigned an 108.x.x.x IP address.  My understanding is that 108.x.x.x is the public IP address as seen by the internet.  

Tags (2)
Message 1 of 5

Re: Why is my device assigned an 108.x.x.x IP address?

The routers and so on communicate using  ipv4 ip addresses, even though it is a local network. (Hence the term LAN or local area network.)

Those are completely independent of the actual live internet addresses.

Typically, they call the device that provides the main conection from the NID to the house, the Residential Gatemay,  or RG, and in this sence, it is quite litteral.  The router part of it is the gate keeper that allowes all connected devices access.

A particular brand of gateway will use a particular set of ip numbers for assining address, and a differant maker could use an entire set of numbers. 

Unless a device is not propperly communicating with the router, the actual numbers assigned to a particular device are mostly random, but consistant.


Hmm.. re-reading your origional post I see I missed the detail of the 108 device not communicating with other devices on the network.  My bad, I missed that.


One of our wi-fi router guru's is gonna have to help you with that one.. it's a bit over my head, sorry.

Message 2 of 5

Re: Why is my device assigned an 108.x.x.x IP address?



Try factory resetting your gateway.


Make sure the device having this happen isn't running any kind of software that can change the network settings on the device and confirm that your device's LAN hardware has the setting set to automatically get DHCP settings from the gateway.

Note: If your issue has been resolved, please mark the post that resolved your issue as the solution. Click "Post Options" and select "Accept as Solution" to help others with the same issue find an answer.
Message 3 of 5

Re: Why is my device assigned an 108.x.x.x IP address?

Sorry. I am not going to reset my gateway and lose all my settings for a shot in the dark solution.  If you can explain to me the problem and why this solution works, then I'll be glad to do so.


Here are more facts:

1) All my devices are set to DHCP assignment.  Thst is confirmed on the Device/Status page, including the device assigned the 108.x.x.x IP.


2) Every time I reboot my gateway, a different device gets assigned the 108.x.x.x IP address, including my DVR.


3) I just did an internet IP look up from my workstation, my public IP address matches the 108.x.x.x IP assigned to one of my devices.


4) I kept on rebooting my gateway until my cellphone got assigned the 108.x.x.x IP address.  I then allocated each of assigned DHCP IP to my devices.


If I understand that function correctly, each time my device asks the DHCP server for an IP, the one allocated to that device will be assigned.  Hopefully, this will lock all my devices to the private 192.168.1.xxx IP range, except my cellphone.  I prefer not to, but if I have to, I rather leave my cellphone exposed to the internet than my computers.


This is a stop gap solution. I really want to know why the DHCP server is allocating a public IP to one my devices.  Am I the only one having this problem?  Is this how the RG normally behaves?

Message 4 of 5
Accepted by topic author
Accepted by rchiang22
‎10-26-2015 8:25 PM

Re: Why is my device assigned an 108.x.x.x IP address?

Finally figured it out. 


In the Firewall main tab, under IP Passthrough sub-tab, there is an option "Allocation Mode". According to the help text, the default option is "Off". Mine was set to "Passthrough". The help text for Passthrough: 

  • Passthrough: Allows the device's public IP address to be assigned to a single LAN client.

I don't recall ever messing with this setting and I have no idea how it got changed.  I set it back to Off and no more public IP assigned to my device.

Tags (1)
Message 5 of 5
Share this topic
Share this topic

Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!

Additional Support