AT&T SMTP now enforcing "From" email address

Mentor

AT&T SMTP now enforcing "From" email address

I posted earlier about not being able to send email via SMTP and have now figured out the problem. Starting within the last day or so, they are now checking to see that the "From" address on outgoing email matches your AT&T email address and, if not, are rejecting it. This is probably an anti-spam measure, but can cause problems.

 

This is a problem for me since I have my own domain so that I can publicly use an address such as "me@mydomain.com" and have it forward to "me@att.net". The advantage is that I can switch ISPs (which I have done a couple times) without having to change my email address in dozens of places around the web, notify contacts, etc. Email addresses are often used as account logins these days, so changing it is a huge honking deal!

 

I could still use "me @mydomain.com" as the "Reply-to" address, but this can confuse people since they will still see both this and my att.net address and probably not know which is which. So I am going to have to use a different SMTP server to send from my AT&T account in my client email program, which is doable but a hassle.

 

For what it's worth, Gmail's SMTP servers also do not like this, but they will actually change the From address to match the account used to log onto the server (the reason why that's not a solution for me either).

Message 1 of 28 (5,419 Views)
glr
Tutor

Re: AT&T SMTP now enforcing "From" email address

[ Edited ]

rochrunner, thanks to you, I can now send emails through 1&1 using an email account associated with my website....thanks

 

I still need to be able to send email from my personal ***@Outlook.com account...am I doomed?

 

[edited for privacy]

Message 16 of 28 (5,178 Views)

Re: AT&T SMTP now enforcing "From" email address

That's not really an option when AT&T also blocks port 25 - which is what many of the other ISPs use

Message 17 of 28 (5,165 Views)
ACE - Expert

Re: AT&T SMTP now enforcing "From" email address


glr wrote:

rochrunner, thanks to you, I can now send emails through 1&1 using an email account associated with my website....thanks

 

I still need to be able to send email from my personal ***@Outlook.com account...am I doomed?

 

[edited for privacy]


You can use Outlook.com's own SMTP servers, they can use port 587 if 25 is blocked.

 

See http://windows.microsoft.com/en-us/windows/outlook/send-receive-from-app

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 18 of 28 (5,156 Views)
glr
Tutor

Re: AT&T SMTP now enforcing "From" email address

Outbound is suddenly working fine...

Message 19 of 28 (5,076 Views)

Re: AT&T SMTP now enforcing "From" email address

After spending two hours with support and getting nowhere, I decided to call it a night and talk with a specialist the next morning.  Somehow, during the night, my Thunderbird started working again as well.  But no, the problem wasn't anything that got changed on their end. Smiley Frustrated

Message 20 of 28 (5,038 Views)
Highlighted
ACE - Expert

Re: AT&T SMTP now enforcing "From" email address

Someone may have misconfigured something that they weren't supposed to put their fingers in.

 

Apparently, there is no such policy shift to require an ATT.NET from address to send via ATT.NET SMTP servers at this time.  

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 21 of 28 (5,023 Views)
Mentor

Re: AT&T SMTP now enforcing "From" email address

Well its a week and counting for me and still the crack tech staff at AT&T can't figure out why their email server now sometimes rejects my outbound emails sent from my email client Agent.

 

Two clues:

 

1. They (AT&T) admit they didn't set up my AT&T email correctly on their end.

2. Agent clearly shows it makes a connection and reports "connection refused".

 

You don't have to be a technical guru to figure out something is obviously wrong on AT&T end.

 

Lets see what we can find out. Agent also shows the IP address it is trying to connect to which is 98.139.211.230. OK, lets do a whois lookup for this IP.

 

Results:

 

OrgName: Yahoo! Inc.
OrgId: YHOO
Address: 701 First Ave
City: Sunnyvale
StateProv: CA

 

So in spite of being told to enter outbound.att.net as the email server to connect with the IP address resolves to a Yahoo location. So...

 

1. that's the incorrect email server to point to

2. AT&T and/or Yahoo still don't have my correct email address set up.

Message 22 of 28 (4,918 Views)

Re: AT&T SMTP now enforcing "From" email address

THANK YOU SO MUCH for taking the time to post your solution!!! So many people post their problems, begging for help, but never post anything when they find the solution, leaving the rest of us still begging for help. U-Verse was just installed in my house and I thought it was great, really excited, loved the internet speed and HD quality, much better than the best Brighthouse services... until I realized my entire days "sent" emails were stuck in the outbox on whatever device they were sent from. Not good. U-Verse was about to get a very angry phone call because I could not send outgoing mail via Outlook or any other email program from my business email domain through GoDaddy on the computer, laptop, or smartphones that were connected to this U-Verse internet modem or via the wi-fi. Email worked fine on the smartphones when disconnected from U-Verse wi-fi, using only Sprint's service. Clearly a U-Verse issue. Big problem, as 90% of my work is internet/email based communication, and clients apparently have not been receiving my emails all day. My email HAS to work 24/7.

 

Customer support, clearly in Uganda or some similar foreign country, barely speaks english beyond reading his cue cards, helped by offering to sign me up for "advanced support" for only an additional 15.00 a month. Wonderful.. thanks.. Probably would have paid that 15.00 a month just to be transferred to  "advanced" support in Nicaragua to be told that I would have to pay for some other service or equipment to get my email to be compatible with U-Verse. I honestly don't understand why these companies that offer "better customer service" with "live support" seem to think that live support from another country is an upgrade from the competitions automated support. I would rather push buttons and deal with the robot that leads to nowhere. Large companies want to hire foreigners for less money than they would pay an American company to handle their customer service, when in reality, they are losing money from fed up, potentially lifetime customers, that can't get a real answer and cancel their services. Could we get live American support that is actually familiar with the products? That would be awesome. Products are great, but really wish the customer service quality would be equivalent to that of the products. Whatever.. until then, I will stick with "Google support".. searching the web is free and always provides a solution. 

 

Anyhow, after the failed attempt of using customer support for a solution, I tried U-Verse help links.. only tells you how to setup their ATT mail on Outlook. No advice for using other domains, which is terrible, as this is apparently a very common problem/complaint with this service. Tried searching Google, found this is a widespread problem that has existed for years with thousands of posted pleas for help and recommendations that failed (including the original post on this thread that I found by searching Google, as they have changed everything in their email in the 5 years since 2009 when posted..). About 5 minutes away from giving up and making an angry phone call back to Uganda to cancel this service, scrolling through the threads following the original post here.. still dreadfully hoping for an answer so I don't have to cancel my new service over such a ridiculous problem.. I finally came upon this post and checked the GoDaddy site. They also support SSL outgoing port 465 as mentioned in the post. I changed all computer/smartphone outgoing server settings to SSL 465, and suddenly the 20 emails I have sent today are going through perfectly from all devices.

 

3 hours of troubleshooting, for a 2 second fix... They should really teach their installers and customer service reps to point that out to new customers. Thank God I am patient and computer literate enough to know how to troubleshoot, research problems, and also know how to manage my own server settings. I can't imagine what those who are less technical have to go through to resolve it. I am sure there are others doing crazy things trying to get their email to work, wasting hours, wasting money on IT help, calling domain providers, messing up all kinds of computer settings, putting their computers through the wall, and causing more problems for themselves. Who even knows what "advanced support" in Nicaragua is telling the people paying for extra service to do to their computers to fix it. AT&T's U-Verse has surely had to lose some business over this one, seemingly large, yet very small technical issue, as I almost joined them had I not became so angry with the customer service and taken the time to try and figure it out for myself. AT&T U-Verse should give you a free year of service for doing their job and keeping their business from losing their customers that were lucky enough to stumble across your post on their site. Your advice will probably save a lot of business for them. I know it just saved one new customer from cancelling..  You are awesome. Thank you, thank you, thank you!! 

Message 23 of 28 (4,870 Views)

Re: AT&T SMTP now enforcing "From" email address

What worked for me, was to use the advice someone posted earlier. If you are using Outlook or some other email program, set your outgoing server in Outlook or whatever program or app you are running your email through, to SSL, then change outgoing Port 25 to say Port 465 and save the changes. I can now send email from my GoDaddy mail server through outlook and my android phone while connected to AT&T U-Verse internet and wi-fi. Hope your problem is the same issue I was having, and that simple solution helps you.

Message 24 of 28 (4,864 Views)
ACE - Expert

Re: AT&T SMTP now enforcing "From" email address

Why on earth would you expect AT&T to tell you how to setup e-mail to someone else's e-mail server?

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 25 of 28 (4,858 Views)
Contributor

Re: AT&T SMTP now enforcing "From" email address

5-16-2014 and the fingers are still there. After the "new" ATT mail was automatically installed on my sbcglobal.net account, my outgoing mail usually but not always is defaulted to the canoelac2@yahoo.net that I dont want to use. No answers in the community that I can find.
Message 26 of 28 (4,162 Views)
Contributor

Re: AT&T SMTP now enforcing "From" email address

Why is ATT forcing me to use a return address that is NOT my primary sbcglobal.net address???

Message 27 of 28 (4,162 Views)
ACE - Expert

Re: AT&T SMTP now enforcing "From" email address

canoelac - If you are using SMTP you are using an app such as outlook or macmail, there are a number of opportunities to select what address is used.

Check out you computer default.
Check out how your list of options to apply when sending is presented
When actually sending be sure you have the one you want.
There could be an option to use the original one on replies.

It is great to manage multiple mail accounts with these apps, but it is possible to apply the wrong account when sending an e-mail. Ask me how I know.
*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 28 of 28 (4,155 Views)