AT&T SMTP now enforcing "From" email address

Mentor

AT&T SMTP now enforcing "From" email address

I posted earlier about not being able to send email via SMTP and have now figured out the problem. Starting within the last day or so, they are now checking to see that the "From" address on outgoing email matches your AT&T email address and, if not, are rejecting it. This is probably an anti-spam measure, but can cause problems.

 

This is a problem for me since I have my own domain so that I can publicly use an address such as "me@mydomain.com" and have it forward to "me@att.net". The advantage is that I can switch ISPs (which I have done a couple times) without having to change my email address in dozens of places around the web, notify contacts, etc. Email addresses are often used as account logins these days, so changing it is a huge honking deal!

 

I could still use "me @mydomain.com" as the "Reply-to" address, but this can confuse people since they will still see both this and my att.net address and probably not know which is which. So I am going to have to use a different SMTP server to send from my AT&T account in my client email program, which is doable but a hassle.

 

For what it's worth, Gmail's SMTP servers also do not like this, but they will actually change the From address to match the account used to log onto the server (the reason why that's not a solution for me either).

Message 1 of 28 (5,411 Views)
Employee

Re: AT&T SMTP now enforcing "From" email address

Was not aware, thanks for posting findings.
Employee Contributor*
*I am an AT&T employee and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Message 2 of 28 (5,348 Views)

Re: AT&T SMTP now enforcing "From" email address

"Starting within the last day or so, they are now checking to see that the "From" address on outgoing email matches your AT&T email address and, if not, are rejecting it. This is probably an anti-spam measure, but can cause problems."

 

I really appreciate this post, but I have to say this "can cause problems" is an understatment.

 

If this is true as of this moment I'm paying for an ISP to:

 

-Force me to use their outgoing SMTP servers when using an email client because they don't want to be responsible for SPAM

-Have me go through a convoluted setup through Yahoo setup so I can use my business domain instead of att.net because they've outsourced to Yahoo, who themselves apparently can barely handle it.

-And then shut everything but att.net with no notice because it's all too difficult.

 

Time Warner starting to sound really good right now and I'm well out of "special" customer rates. As of this moment, I'm litterally unable to email out of my client because I have no use nor have any plans to go to att.net emails.

 

Honestly, I'm really hoping this isn't true and there's a hiccup with the server. Otherwise there's much pain in my future and U-Verse possibly just lost a client.

Message 3 of 28 (5,302 Views)
glr
Tutor

Re: AT&T SMTP now enforcing "From" email address

I am the exact same boat and am certainly an unhappy camper.

 

I attemped but was unable to send an email even though I populated the Reply To box w/ my ATT email address.  Did I misunderstand what the workaround is?

Message 4 of 28 (5,289 Views)
glr
Tutor

Re: AT&T SMTP now enforcing "From" email address

[ Edited ]

I think I misunderstood...you are suggesting that I add my desired email address to the Reply To parameter.  But the email has to be sent from my ATT.net email address.  Yes - that is ackward and confusing to the recipient.

 

Like you, I am desperately trying to avoid tying my commonly recognized email address to a specific internet provider but I do not know what my alternatives are.

Message 5 of 28 (5,285 Views)
ACE - Expert

Re: AT&T SMTP now enforcing "From" email address

If you want to use a From address that doesn't use the ATT.NET domain, then submit your e-mail to that domain's SMTP server.

 

*The views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.
Message 6 of 28 (5,269 Views)

Re: AT&T SMTP now enforcing "From" email address

glr - I haven't had time to investigate or contact anyone at ATT support. This could be a server outage.(Although I have had 10 minutes to look at other ISP options at this point.).

 

If the above post is true, one option that I've read about but haven't tried is calling and asking for the automatic block on Port 25 to be removed. Once that happens you can use your own SMTP servers, usually supplied with the Internet hosting package that also supports the email.

 

I want to use a local email client and the domain names I've paid for. Sending from my ATT email (used only as a userid for ATT) is just not an option.

 

You'd think the company that was instrumental in the development of the Internet could handle outgoing email. Other ISPs can and do. This is extremely frustrating.

Message 7 of 28 (5,265 Views)

Re: AT&T SMTP now enforcing "From" email address

You can't *get* to most other SMTP servers when your logged on ATT's network. They block Port 25 automatically. That's why this situation stinks. Other ISPs monitor Port 25 rather than just throw their hands up in air and make you deal with it.

 

When I'm on the road, I always switch over to my host's SMTP servers. It always works - I don't "submit" the name, just authenticate my user id.

Message 8 of 28 (5,266 Views)
Mentor

Re: AT&T SMTP now enforcing "From" email address

I've switched to the SMTP server at my web hosting company that hosts my domains (1&1 Internet). It's a secure SMTP connection that uses port 587 -- not 25. Sending on port 25 is probably a classic way that spam gets sent, whereas my port 587 connection requires a username and password.

 

This is working now, but introduces another potential problem. This particular web host has been known to be used by spammers, so once in a while I can run into a situation where certain big ISPs just start rejecting all email sent from 1&1's IP addresses. That's why I preferred using AT&T's servers, but apparently I now can't win for losing!

Message 9 of 28 (5,261 Views)
Highlighted
glr
Tutor

Re: AT&T SMTP now enforcing "From" email address

Rochrunner...I am interested in your current solution.  1&1 hosts my site.  Can you give me a highlevel idea of what I need to do to implement the workaround.

Message 10 of 28 (5,251 Views)

Re: AT&T SMTP now enforcing "From" email address

I'll look into Port 587, that may help if ATT is not doing an automtic block. Thanks for the tip.  For the record, using Port 25 also required a userid and password at my hosting company. It was never open. In the end, there's nothing magical about any particular port number. Port 25 is/was indeed the customary SMTP port but once Port 587 becomes "customary", we're back to where we started.

Message 11 of 28 (5,250 Views)
glr
Tutor

Re: AT&T SMTP now enforcing "From" email address

An interesting observation...I can successfully send emails from my HP Touchpad (webos) even though Outlook2013 on Win7 can not.

Message 12 of 28 (5,247 Views)
Contributor

Re: AT&T SMTP now enforcing "From" email address

Same problem here. Had this issue when 1st signing up for U-verse last year. Several phone calls and much time involved with a thoughtful U-verse rep finally fixed it. However, we knew something changed over the weekend as outgoing stopped working Sunday night. Regardless of it's nature(port blocking, etc), if I don't find a solution this week, I'll be forced to drop U-verse altogether as I can't send email.
Message 13 of 28 (5,245 Views)

Re: AT&T SMTP now enforcing "From" email address

Success! I looked into the email settings at my own hosting company, which is Hostgator. In CPanel, I accessed the email I use and then selected "Configure Email". It gave me settings for Outgoing SSL, which used Port 465. I also had to use the name of an SMTP server that was specific to my account and Hostgator, which I won't bother with posting because it won't help most people. I have to authenicate outgoing email, but had to do that anyway.

 

So the more generic solution is to check with your hosting company and see if they offer an SMTP server using a port other than 25 if you don't want to wrestle with ATT support.

 

I have to admit I'm still adding looking for an another ISP to the "to do" list. It's only a matter of time before 587 (and 465) become overrun unless there's an upgrade to the technology I don't know about. (Totally possible given that I'm in a different field now. Smiley Happy ) At any rate, the automatic block on 25 was never the way to solve the issue nor was turning off everything but ATT.net and letting us mere customers find out about it by letting it break.

Message 14 of 28 (5,239 Views)

Re: AT&T SMTP now enforcing "From" email address

@rochrunner- Thanks for the tip - it led to my returning to sucessful outbound email. My solution at my hosting company is basically the same but with a different port number. Good luck! Smiley Happy

Message 15 of 28 (5,236 Views)