Explore & discover

Helpful Links

iPhone wifi slow on AT&T fiber

Tutor

iPhone wifi slow on AT&T fiber

Looking for a solution to an issue with wifi on my home AT&T Fiber network 1000 Mbps. This only occurs with iPhones connected to the my home wifi. The majority of the time my iPhone X is very slow when connected to my home wifi (10 mbps or less). The exact same behavior occurs on my wife's iPhone X as well. Only if I disconnect and reconnect to the wifi via the phone directly or resetting the router does the connect start off fast for about 5 minutes or less.  Does not matter what the signal strength is or where in the home the phone is located.

Other connected devices, such as my Macbook, TVs, Firestick, etc. do not get a slow connection. They get 200+ Mbps over wifi.

Connecting to other wifi spots that are not our home wifi the wifi works as expected and extremely well on the iPhones, which leads me to believe there is a setting / recognition from AT&T router or service that  is specifically slowing the iPhone. Does anyone else have this problem?

- iPhone connects to the 5ghz band

- Tried manually specifying the DNS server to use, such as 1.1.1.1, on the iPhone

- Tried assigning IPV4 address to iPhone when it connects, rather than letting the router choose

- Changed channels of wifi and used AT&T mobile app to auto-optimize channel selection

- Reset of router does not resolve (ARRIS BGW210-700, Software version 1.8.18)

- When wifi is turned off on iPhone to disconnect from home wifi, LTE connects and is instantly faster

1,156 Views
Message 1 of 18
Tutor

Re: iPhone wifi slow on AT&T fiber

Also, router info:

ARRIS BGW210-700

Software version 1.8.18

Message 2 of 18

Re: iPhone wifi slow on AT&T fiber

I’m having the same problem. I just recently got AT&T Fiber 1Gb and it’s only effecting my iPhone X. While everyone else has cheap phones and seems to work better than my phone...

Message 3 of 18
Contributor

Re: iPhone wifi slow on AT&T fiber

Exact same situation here. My computer and iPad do just fine, as does my roommate’s pixel phone (usually well over 200 mbps). My iPhone XS Max and the Apple TV, however, are incredibly slow. I usually get around 2-6 mbps on my iPhone, and I’m not sure about the Apple TV, but ever since I switched to att fiber a couple of weeks ago it requires very frequent buffering. Has anyone been able to figure this out?

Message 4 of 18
Highlighted
Contributor

Re: iPhone wifi slow on AT&T fiber

Hey! I think I figured out what was going on! It looks like the “band steering” feature of the AT&T router was consistently sending my iphone and Apple TV  to the 2.4 ghz band instead of the 5 ghz band. You can check that by going to the “advanced device configuration” address on your router and you can see which band each connected device is using. If this is what’s happening for you, go in to your WiFi advanced settings and change the name of one of the networks (I just put 2.4 on the end of the default name for the 2.4ghz). Then you’ll have a choice of which to connect to! Some older devices can’t connect to 5ghz, so I wouldn’t recommend turning it off completely, but this has solved my iPhone and Apple TV problem for the time being!

Message 5 of 18
Tutor

Re: iPhone wifi slow on AT&T fiber

Thanks @Jenn0772 - unfortunately that's not the case for me. The iPhone X is connecting to the 5GHz band. I've confirmed by looking at the router configuration and confirming which band each device is connected to. 

Message 6 of 18
Tutor

Re: iPhone wifi slow on AT&T fiber

I'm seeing the same thing on multiple iPhones. Interesting that the SpeedCheck app (speedspot.org) on the iPhones consistently shows a good speed of at least 100 Mb/s although it goes up and down (100 to 300) much more than other wireless or wired devices. iPhones streaming video frequently stop to buffer where they never did with 50 Mb/s AT&T copper.

Message 7 of 18
Contributor

Re: iPhone wifi slow on AT&T fiber

I am having the exact same issue on the 5ghz band

Message 8 of 18
Tutor

Re: iPhone wifi slow on AT&T fiber

I turned off IPv6 on the router and the problem went away. I'm not seeing any side effects. To try this, log into the router,then "Home Network" tab, then IPv6 sub-tab, then IPv6 to Off and Save. Please post if this also helped you, thoughts on why this helps, or any information on downsides of doing this.

Message 9 of 18

Re: iPhone wifi slow on AT&T fiber

I will try this once I get home. But you know what’s the reason for this IPv6 being on or off ? 

Message 10 of 18
Tutor

Re: iPhone wifi slow on AT&T fiber

Turning off IPv6 shouldn't be necessary but doing so forces devices to use the older but perfectly adequate IPv4. This seems to avoid some bug with IPv6 either in the router or the iPhone. That's my best guess at least.

Message 11 of 18

Re: iPhone wifi slow on AT&T fiber

I checked it and it was already turned off so idk... I need to get this fixed because this is getting very upsetting. 

Message 12 of 18
Tutor

Re: iPhone wifi slow on AT&T fiber

Same, checked IPv6 and it's already off on the router.  

 

Yeah, very upsetting! I pay for 1G fiber in my home and then I have to use my iPhone AT&T data plan (LTE) if i want to access anything on the internet on my phone rather than use home wifi. Every other device in my home seems to work fine at the expected high-speeds on my home network, but the device I use most often doesn't.  WHY!??!?

 

There has to be something the iPhone is looking for via the router and is not getting it so it times-out and goes elsewhere, thus the lag, or the router itself recognizes the iPhone device and is doing the same. Like I said, I tried changing the DNS server, but that hasn't resolved the issue. 

Message 13 of 18

Re: iPhone wifi slow on AT&T fiber

It has to be on the iPhone and apple products itself with the problem I think. No other device and even cheap phones experiencing this issue... We need to raise the issue to apple so they can take a look at it. 

Message 14 of 18
Tutor

Re: iPhone wifi slow on AT

I saw this problem on both an iPhone 6 and iPhone 7 as soon as I upgraded to fiber. On my new AT&T Router, model BGW210-700, turning off IPv6 was adequate to avoid the problem. From this thread and other threads outside of AT&T forums, it sounds like a non-trivial conflict between router and iPhone. It might be configuration or it might be a bug. This is something best addressed by getting Apple and AT&T to talk to each other. That may not be easy, but someone with an iPhone within the 90-day free support period might have the best luck. Get an AT&T senior technician on-site and Apple on the phone and let them fight it out.
Message 15 of 18
Share this topic
Share this topic
Announcements...

Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!

Additional Support