Explore & discover

Helpful Links

Latest Firmware for Arris BGW210-700

Tutor

Latest Firmware for Arris BGW210-700

Does anyone know what the latest firmware is available for the Arris BGW210-700 Gateway?  Additionally, if my router needs the latest firmware, where can I download it and update my router?  Thanks

26,344 Views
Message 1 of 49
Teacher

Re: Latest Firmware for Arris BGW210-700

My AT&T Arris BGW210-700 Uverse Gateway's current software (firmware) is version: 1.8.18. Apparently, AT&T pushed it out, because I have never updated the device. Where do you find firmware documentation for v1.8.18?

Message 46 of 49
Guru

Re: Latest Firmware for Arris BGW210-700

AT&T doesn't issue any documentation/change log on firmware updates. 

 

Plus, they just recently started rolling out version 1.9.15 and some of the "lucky" recipients are now reporting frequent loss of service.  Some of those people have manually rolled back to 1.8.18 to solve this and are hoping that the updater doesn't push 1.9.15 back on their RGW.

Message 47 of 49
Contributor

Re: Latest Firmware for Arris BGW210-700

I have 1.9.15 and have to reboot about once a week. I've had this router for a few years, and this is a new problem.Traffic gets slower and slower, until it's so slow it's intolerable or services are timing out. Looks like something with the NAT tables. I've had some luck resetting all sessions, but half the time I have to reboot the router.

 

Any know of a 3rd party firmware that will work?

Message 48 of 49
Scholar

Re: Latest Firmware for Arris BGW210-700

No 3rd party firmware would work sadly because it would lack the 801.x authentication certs that are signed by AT&T and required for your gateway to connect and get service. You can flash older version of the BGW-210 firmware (you can find them easy on DSLreports u-verse forums). I have 1.8.18 on my computer and am considering rolling back to it. Here is the link to AT&T's update server for it if you want it http://gateway.c01.sbcglobal.net/firmware/001E46/BGW210-700_1.8.18/spTurquoise210-700_1.8.18.bin

 

Anyways yeah 1.9.15 has a bug that causes loss of service randomly. There is a thread on dslreports of multiple people experiencing the same thing and saying its only started since this update. Just had it happen for the second time to me since I got 1.9.15 about 20 days ago. Connection just stops working (lights on gateway stay green). If I go to the BGW-210 diagnostics page it fails at "ping default gateway". Tried the IP reset option, no go. Tried reset connection, my VDSL2 connection successfully disconnected and re sync'd but then it could not get a IP address. Requires a full reboot. Hope a update comes soon that fixes this. I have zero doubt its a firmware bug, I was sitting at over 45 days uptime before this update.

Message 49 of 49
Share this topic
Share this topic
Announcements

Are you having trouble logging in? Is your email password not working? Let us show you how to Reset your Email Password using myAT&T!

Additional Support