Helpful Links

Painfully slow connection

Participant

Painfully slow connection

Since starting my U-verse account in November, my internet connection is remarkably, painfully, and consistantly slow. I've been told by 2 onsite repair people and a tech person via telephone that it's a problem in the area, not with my equipment.

 

I switched to U-verse from Comcast because AT&T seemed to offer service and technology suited to the 21st century. Instead I'm reminded of AOL and external modems of a decade ago.

 

Has anyone else experienced this? Anyone have AT&T's CEO email?

 

Thanks!

Tags (1)
684 Views
Message 1 of 2
Highlighted
Expert

Re: Painfully slow connection

Search for the CEO's snail mail address online (we can't post it here), there is no know email address that we know of.

 

Might want to contact Alex, the AT&T Community Manager, by Private Message (his response, blue letter in upper right are PMs):

http://forums.att.com/t5/user/viewprofilepage/user-id/318276

Let us know how things work out if you can after contacting Alex, who has helped many users. Smiley Wink

 

Chris


Please NO SD stretch-o-vision or 480 SD HD Channels
1-800-288-2020, After he gets acct info, press # a bunch of times, get a menu from Mr. Voice recognition
Your Results May Vary, In My Humble Opinion
I Call It Like I See It, Simply a U-verse user, nothing more

Tags (1)
Message 2 of 2
Share this topic
Announcements

Learn how connect your AT&T holiday gifts at Unwrapped on Wednesday, 12/27 (1-4pm ET)!

Service acting up? Click here to troubleshoot now!

For DSL related issues, we are here to chat!

Additional Support