Announcements
Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 3/31. See all protection plans.

New Member

 • 

2 Messages

Sun, Jan 19, 2020 4:07 PM

IMO request access site not working/granting me an ID

I have filed two applications to IMO Request access and both applications have been returned to me with separate rejections, now I've been trying to submit a third but every device I try and re-enter the information on tells me the PIN I am entering to create a PIN are inaccurate due to "containing sequential numbers or number sequences" despite me having entered a plethora of numbers including numbers created by a random number generator to no avail. I have the dealer code and that part works but now the website to request access itself has turned against me. Any help would be greatly appreciated.

Responses

Brand User
ATTHelp

Administrator

 • 

108.6K Messages

a month ago

Hi @starwars9820,

 

Thanks for reaching out to us! We'd love to assist.

 

Please walk us through everything you've tried so far. Is it safe to assume that you have also attempted to create a PIN which doesn't contain a sequence of 3 digits of the same number? If you input an acceptable PIN, it should be generating your ID for you. Any additional information will help us.

 

Thank you!

 

Collin, AT&T Community Specialist

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

New Member

 • 

2 Messages

I have attempted several different numbers the two I used initially that got declined were [EDITED] , neither of which were declined the first time when I was attempting to set it up but after IMO declined my application twice (which took two weeks for me to get declined each time), it started telling me any number I input is invalid due to "sequential numbers or number sequences." The first time I applied they told [EDITED] me denied as a valid PIN due to the reason aforementioned above, however the second declination stated it was "false information" that I provided despite it being the exact same information as the first time. I attempted finding a solution to this issue by calling AT&T customer support but none of the departments I was sent to could assist me in finding a solution. I have been a faithful AT&T customer for years (my account has only been with AT&T since August but I was on my mothers plan for 10 years prior), and I have done nothing but rave over the customer service for years but as I am finding out the employee and indirect agent resources are a lot more difficult to navigate. I have an unlimited plan and two lines on my account and I'd like to enroll in discounts so I can continue feeling satisfied with my service.

(edited)

Brand User
ATTHelp

Administrator

 • 

108.6K Messages

Hello, @starwars9820,

 

Thank you for the further information. For assistance on issues with your IMO request, please reach out to your AT&T Field Account Representative.

 

Have a great week.

 

James, AT&T Community Specialist

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.