Skip to main content
AT&T Community Forums
E

New Member

 • 

1 Message

Thu, Aug 6, 2020 11:00 PM

Lost trade in

I opted to trade in my device when I upgraded my phone. I never received a return label. A few weeks went by and I called AT&T and requested a label be mailed to me. I received the label and mailed in my device. This was in June of 2020. I still have not received a credit on my bill. I called AT&T and spent 42 minutes on hold and once someone answered she could not assist me, and my return could not be located. I do not have any copies of my tracking number and was told another department could provide me with the number. She transferred me to another department that could "assist" and the line disconnected. 

Responses

Brand User
ATTHelp

Community Support

 • 

132.7K Messages

a month ago

Hi @eri1912,

 

Thank you for bringing this to our attention! We'd love to help.

 

Did you not receive a tracking number when you initially returned the device? Did you visit our Order Management Portal to check the current status on your return? If you haven't, please do so and let us know what you see. Any additional information will help determine what's going on.

 

Thank you!

 

Collin, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Get started...

Ask a new question