Skip to main content
AT&T Community Forums
Announcements
Learn how to Get the iPhone 12 Now!

Contributor

 • 

2 Messages

Fri, Jun 26, 2015 9:38 AM

Wrong promotion put on account?

I'm hoping that someone can help me fix my problem. On Sunday, June 21, 2015 ( after about a week of disecting every promo being offered) I placed an order online. I ordered a Triple play which included U300, 18mb internet, and voice 200. The base cost was $119/month + $300 in reward cards. I added HD services($10/mo), 2 additional receivers($9 each/mo), and I'm "renting/leasing" the gateway($7/mo). This brings my grand total to $154/mo + $300 in reward cards, all of which I confirmed numerous times, online before submitting my order.

The services were all installed by a great technician on Wednesday, June 24, 2015. Everything is working well and I have zero complaints with that. This morning, Friday June 26, 2015 I'm having trouble sleeping. Based on the suggestion of the installation tech to download and get familiar with the myAT&T, I do so. While looking around on the different tabs I find the tab that shows my promotion I received with my order asking if I would like to redeem it. The problem is, it shows that I only get $150 in reward cards, this obviously being HALF of what I'm supposed to get. I did not redeem this since it is obviously incorrect....

Has anyone else had this problem and if so, can you please tell me the steps I need to take to correct this? Given that you only get a limited amount of time to redeem this, I am looking for the "easiest" and most direct path to take. Being that I signed a 1 year contract for this, does anyone know if I am able to cancel my service without penalty if they do not correct this?


I'm very sorry that this is so long winded, but I didn't want to leave any info out that might make it difficult to respond quickly. I hope that you all have a great day and I thank you in advance for any assistance!

Regards,
Ed [edited for privacy-please do not post personal or unique information such as but not limited to full names, employee ID numbers, email addresses, phone numbers, account numbers, etc.]

Responses

Accepted Solution

Official Solution

browndk26

ACE - Professor

 • 

3K Messages

5 years ago

Click on the rewards card link under the faq's on the first page of the forums. You may need to login on the rewards card site to see the other $150. You have to have the service for 30 days to get the rewards. Call if you don't see the other $150. You can cancel before 30 days but you still pay for the services you used and have to pay install fees. Read your service agreement for details.
Award for Community Excellence 2020 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

2 Messages

5 years ago

Thank you both for your response, I was hoping that another uverse employee would see this and have a clear cut answer. But, I'll look into both of your responses and see what I can find!

Thanks again,
Ed

Contributor

 • 

1 Message

3 years ago

[Julie *****]: acct#*****/ Reward-Card Claim Number:#*****...I  recently activated  AT&T Internet/cable/tv service(5/25/2017)...was quoted $150 Reward-Card. When accessed to begin process, it showed only $50? I understand there is a "waiting-period" for my card to be  "availibile"...but want to confirm (for my records) that I will be issued the $150 amount?!   Thank-you! Julie [edited for privacy-please do not post personal or unique information such as but not limited to full names, employee ID numbers, email addresses, phone numbers, account numbers, etc.]

Get started...

Ask a new question