Announcements
Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 3/31. See all protection plans.

Contributor

 • 

3 Messages

Thu, Dec 12, 2019 5:59 AM

Cannot use HBO Go on Apple TV

I changed my AT&T plan to AT&T Unlimited Elite(SM) which comes with HBO GO however I cannot sign into the HBO Go app on the my Apple TV.

 

When I go to a browser on my computer and sign into HBO GO I have three choices for AT&T Providers:

AT&T TV

AT&T U-Verse TV

AT&T Wireless / WatchTV

 

I selected AT&T Wireless / WatchTV and then it allowed me to sign into HBO GO fine (after creating an HBO GO account).

 

When I go to my list of TV Providers on my Apple TV I only have two choices for AT&T Providers:

AT&T TV

AT&T U-Verse TV

 

I selected AT&T TV and that does NOT allow me sign into HBO GO. It states:

 

We're having trouble verifying your access to HBO GO with your TV Provider.

0033-The customer is not authorized for this content requested.

 

So as far as I can tell the problem is that the Apple TV does not have the correct option for the provider? Is there any sort of work around for this?

 

Responses

bcbsncjlj

ACE - Expert

 • 

19.2K Messages

2 months ago

Using Apple's Single Sign On option? If so delete the provider from settings, restart device then add it back.

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

New Member

 • 

2 Messages

@bcbsncjlj This did not work for me. Interestingly hbogo works with my iPhone but not Apple TV or fire tv and new ways around this?

Contributor

 • 

3 Messages

2 months ago

Yup, tried that. I deleted the HBO GO app, signed out of the "TV Provider" option in the Apple TV settings, re-downloaded the HBO GO app, but when I go to sign in, it is forcing me to sign back into the "TV Provider" option in the Apple TV settings. And without that AT&T Wireless / WatchTV option it doesn't work. 

bcbsncjlj

ACE - Expert

 • 

19.2K Messages

2 months ago

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Employee

 • 

287 Messages

2 months ago

Hi! I did not have the issue you are describing when I tested just now. I just installed HBO Go. After selecting sign in there was a pop up(Apple Single Sign on) with options yes to use or no don;t use. I selected NO at this point. Then I was provided a code and asked to visit hbogo.com/tvsignin. After typing in the code on a computer I was provided the list of tv providers. AT&T Wireless / WatchTV was available.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

New Member

 • 

2 Messages

@ATandTForLife This did not work for me. Interestingly hbogo works with my iPhone but not Apple TV or fire tv and new ways around this?

Contributor

 • 

3 Messages

2 months ago

Yup, that did the trick. Here are the steps I took. 

 

Deleted HBO GO app

Restarted the Apple TV

Reinstalled the HBO GO app

When I started the HBO GO app I can choose Sign In or Don't have an account

I selected Sign In

I could then choose Allow or Don't Allow to allow the app to use TV Providers subscription

I selected Don’t Allow

It then gave me a code to enter on the hbogo.com/activate site

Went to my computer and used the activation code

It then asked me to choose my TV provider so from there I was able to select AT&T Wireless / WatchTV (it didn’t ask me to sign in as I already had previously)

The HBO GO app signed in after

 

So @ATandTForLife you were right. That's SUPER lame way of having to go about it, but it worked so thank you for the solution!