The Samsung Galaxy S24
Frustrated80's profile

New Member

 • 

4 Messages

Thursday, July 13th, 2023 10:42 PM

Unlock device code did not work but prompt will not reappear

Hi, I have an AT&T Samsung A32 which I requested to have unlocked through the AT&T’s Device Unlock Portal. I received my e-mail, done the confirmation and received my approval e-mail within minutes that included the unlock code. I followed the instructions per the e-mail turning the phone off, inserting an active non-AT&T SIM card, turned the phone back on and got the prompt to enter the unlock code which I done so and the prompt disappeared after I entered the last digit so I assumed this meant all had went well and I should have been ready to start using my unlocked phone. Well that was not the case. It appears that nothing has changed, it’s like the code did not work. I have not received any onscreen messages stating that my entry was unsuccessful (or that it was successful either for that matter) so I tried going through the steps once again making sure I had not missed anything but the prompt to enter the code does not come back up on my screen. So I seem to be stuck. I contacted AT&T customer support and of course I was told the exact same things I had already done and I tried to explain that. The best he could do was tell me to take it to an AT&T store with my code and they would be able to unlock it for me as long as I had my information. So that’s what I done this morning, and the closest AT&T store to where I live is about a 35-45 min drive. When I got there and explained my problem the people in the store looked at me like I was utterly stupid and I was told they could not do that there and I showed them my e-mails from AT&T and I was told that they would never send e-mails like that which I know is bull**** just from reading the forums here, that’s how everyone else has received their approved unlock status and code. So at this point I am at a complete loss as to what to do. Any help would be greatly appreciated.

Accepted Solution

New Member

 • 

4 Messages

9 months ago

@formerlyknownas 

Sorry it took me two days to get back here and answer your question, my husband had the broken phone with the US Cellular SIM card in it and I had the phone in question, and I never could get the 2 together long enough to check it again because I couldn’t remember what it had said when I tried putting the card into the phone when it wasn’t working. But fortunately while I was checking on that I did some trial and error on some different settings and went into connections/mobile networks where it seems to always be set on automatic which of course was set automatically to AT&T. I actually tried something similar the other day where I was able to choose the US Cellular network but I still got nothing but noticed it said it was in Roaming in that same menu area. This time when I went there I turned off international roaming (have no use for that anyway) hoping that had something to do with it, then turned off the checkbox for automatic network selection and done a scan for networks and then chose US Cellular once again and after I done all that it suddenly started working. Hopefully that little bit (if it made sense lol) helps someone else in the future. NOW, I have one more question concerning the whole selecting the network I want to use. It seems that it doesn’t want to stay connected to the US Cellular network when you turn the phone off and back on even after turning off the automatic selection and choosing it to connect on the US Cellular network. When it starts back up it still say’s AT&T which I figured was just because that’s who the phone was originally locked through but I figured if it did indeed unlock as I thought it didn’t at first, why I’m having to go and manually select US Cellular each time the phone is restarted when it has that SIM card in it and works fine otherwise. It’s not really a huge deal because the phone isn’t turned off or restarted very often but my husband is going to be using the phone and I’m lucky he knows how to turn one on and off let alone have him remember how to get back to that network selection area lol, so it would be nice if it would just stick to US Cellular. I tried automatic on and off after it started working and no matter what I had to manually choose. I can start a new thread for that question if necessary but was hoping you or someone here might have a quick fix that one. Thanks for everyone’s fast replies when I first started this!

Accepted Solution

ACE - Sage

 • 

117K Messages

9 months ago

@Frustrated80 

Well at least it's unlocked, otherwise it could not work on u.s Cellular at all.

But it sounds like maybe US Cellular is not the best coverage in your area.   

Any further questions might be best addressed by US Cellular, because they are now your service provider.

Former Employee

 • 

32.9K Messages

9 months ago

What makes you think it didn’t work? Have you tried actually using the phone with a different provider? Does the phone still work on an AT&T account? 

ACE - Sage

 • 

117K Messages

9 months ago

Have you checked with your new provider to make sure that the phone is capable of working on their network?   

What network are you trying to use? 

New Member

 • 

4 Messages

9 months ago

I said in my post that I put my NON AT&T SIM card in the phone.. the sim that I have active through US Cellular. And of course I tried to use the phone after I done it. That’s how I knew it did not work 

Community Support

 • 

231.3K Messages

9 months ago

Hello Frustrated80, we're here to help with your unlock code 

 

Let's meet in a Direct message to review your account. Please check you Direct Message inbox (it's the chat icon next to the bell icon in the upper right corner of the forums).

 

Looking forward to speaking with you soon.

 

Thank you for visiting AT&T Community Forums!

 

Carlton, AT&T Community Specialist

ACE - Sage

 • 

117K Messages

9 months ago

@Frustrated80 

Most service providers have an IMEI check. Just because the phone is unlocked does not mean it will work on another service provider.  

With an incompatible SIM card installed, an AT&t Samsung phone that is locked would say 'SIM not supported' in notification bar.   Is this the case?  

Or does it say something else? 

New Member

 • 

4 Messages

9 months ago

@formerlyknownas 

Actually US Cellular is about one of the only coverages in our tiny town lol. Technically AT&T is the one that’s not suppose to cover our area but we’re so close to the WV border where they do have coverage that it’s worked well for me here. I personally prefer AT&T myself and that’s who I have my phone through. But in the more remote locations of the county, because we have a lot of mountains, and are set right in the middle of them then US Cellular picks up best in those places. I don’t like going up in the mountains so I’m good lol but my husband on the other hand spends a lot of time in those locations so he has to use US Cellular or he’d have no reception at all. An ATTHelp rep gave me a good idea to try so I’m going to do that and see if it works and if not I will take the question to US Cellular. I appreciate your assistance with my situation and I think I’ll leave my account here on the forums should I ever need any help with my own AT&T service. Thanks! 💜

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.