Skip to main content
AT&T Community Forums
B

New Member

 • 

1 Message

Mon, Jun 1, 2020 8:10 PM

Software Update Issues

My phone Samsung Galacy S10e isn't updating to the latest software which 2.1 and my brother got it already. We are living at the same place so I concluded that the problem isn't because of the location. I am still in 2.0 software version and my phone keeps telling me that it is up to date which isn't. I hope you can help me with this

Responses

Brand User
ATTHelp

Community Support

 • 

124.1K Messages

a month ago

Hello, @bryan_knowsart,

 

Thank you for reaching out. Here's information about updating the software on your device through AT&T. Here are the requirements to receive the update:

 

  • It must be an AT&T branded device.
  • The device must be on the AT&T network to receive the update.
  • It must be compatible with the update.
  • The device should be on a Wi-Fi connection.
  • The device must have space to receive the update.
  • If the device wasn't originally on the AT&T network, the update may fail.
  • The device will need to be up to at least 80% power.

If it meets those requirements, it should be able to receive the update when it's ready. If it meets the requirements, follow the steps and link via the preceding link to update your S10e.

 

have a great week.

 

James, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Get started...

Ask a new question