Announcements

For the latest on our response to Coronavirus (COVID-19), click here.

Contributor

 • 

1 Message

Fri, Aug 17, 2018 11:51 AM

Samsung S7 network problems

Good morning,

with this message I'd like to report a problem concerning my Samsung Galaxy S7. I've recently bought an ATT model on the web, but I've noticed that it was previously "debranded". When I insert the SIM, it is recognized without problems, but it's not allowed to connect to any network operator. In detail, if I go through "Connections"> "Mobile Networks"> "Network Operators", whenever I press "Search Networks" I get the message "Error while searching networks" or "Can not connect ...". I checked the IMEI and it's ok. So my question is this: is there some kind of blocking by ATT? In case, could it be possible to unlock?

Responses

Accepted Solution

Official Solution

Brand User
ATTHelp

Administrator

 • 

113.9K Messages

2 years ago

Hi @trezzo,

 

We've got just the information for you!

Since the device was debranded, it may be running into these service issues due to incorrect Access Point Name (APN) settings. To update these settings:

  1. Access the Settings menu.
  2. Locate and select either Wireless & Networks, More Networks, or Connections.
  3. Select Mobile Networks > Access Point Names.
  4. Locate and select the option to add a new APN, usually by a + symbol or tapping the menu button.
  5. Program with the following settings for Smartphones:
  6. Save the changes to return to the APN's menu and select the new APN.

You can reference these steps and further information by checking out the support article for Programming Data Settings for Non-AT&T Devices.

 

Enjoy your weekend!

 

Trace, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Contributor

 • 

5 Messages

a year ago

*Update* since this site is 1st in Google search ...currently this issue has resurfaced but for a different reason.  My guess is the last OS/Android patch is not compatible with current firmware. Anyway...the work around is now this (at least for me):

 

1. Navigate to Settings>Connections>Mobile Networks and uncheck the Mobile Data ticker box

 

2.Restart phone

 

3. Navigate to Settings>Connections>Mobile Networks and check the ticker box 

 

4. Navigate to Settings>Connections>Mobile Networks>Enhanced LTE Services and check the ticker box. (Note * check this setting often as it disables after restarting)

 

You should now have access to internet/mms...if not...try resetting the APN 1st then maybe repeat these steps.

 

Good luck,

BDC

Contributor

 • 

5 Messages

a year ago

Another issue I am seeing is the Wi-Fi to APN switch isnt working...disabling Wi-Fi manually sometimes allows the network to connect as well.

Contributor

 • 

5 Messages

2 months ago

I wrote a KB for this issue:

ATT Samsung Galaxy S7 Internet Connection Issues

*Note – changing or resetting the APN or refreshing the entire phone does not resolve this issue; nothing does permanently…as ATT has made this phone incompatible with any other services period. This phone will continue to lose connectivity every time the phone battery dies or whenever you reboot it; so you will be following the instructions below every single time you lose connectivity until you buy another phone. This is the only resolution I have found for this issue:

1. Navigate to Settings>Connections>Mobile Networks

2. Select “Mobile Data” and Uncheck the ticker box

3. Navigate back one and this time select “Enhanced LTE Services” and ensure/Uncheck this ticker box as well

4. Hold in the side button on your phone and restart

5. After phone logs back in navigate back to Settings>Connections>Mobile Networks

6. Select “Mobile Data” and CHECK the ticker box

7. Navigate back one and this time select “Enhanced LTE Services” and again, CHECK the ticker box

8. You should now be receiving a 4G signal and have internet access again

AT&T TV – All Your Entertainment In One Spot.  Learn more…