Skip to main content
AT&T Community Forums
Lilybell2

1.8K Messages

Fri, Feb 6, 2015 6:57 AM

Samsung Galaxy S5 Wi-Fi Connectivity Problems After 4.4.4 Update

My Galaxy S5 has had no connectivity issues at all.  This morning I installed the 4.4.4 update and immediately began having wi-fi connectivity issues.  The S5 keeps dropping the connection and then reconnecting.  This is constant. 

 

Obviously, the signal was strong enough and constant enough that I was able to download the 487 MB update with no connectivity problems whatsoever.  Now, however, when I check Wi-Fi networks, I note the S5 is constantly scanning.  Is that normal? 

 

None of the other devices using Wi-Fi on this home network are experiencing connectivity issues, including a netbook, a tablet, and a Kindle Paperwhite e-reader.  According to the S5, the signal is "strong," yet it continues to drop and then reconnect. 

 

I have tried the S5 on other networks and the same problem exists.  Others are experiencing the same problem after installing 4.4.4.  Unfortunately, a number of us posted in an earlier topic, which had been marked solved; therefore, our posts may likely go unnoticed. 

 

http://forums.att.com/t5/Samsung-Discussion-Support/Galaxy-S5-WiFi-keeps-dropping-and-reconnecting/m-p/4190686#M2825

 

Note: If your issue has been resolved, please mark the post that resolved your issue as the solution. Select "Accept as Solution" to help others with the same issue find an answer.
Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Responses

Contributor

 • 

2 Messages

6 years ago

I am having the same issue after updating on wednesday. at first I thought the problem was at my work wifi but I then realize is everywhere i go with wifi.

Contributor

 • 

1 Message

6 years ago

Same problem here although I did not update and I'm still on 4.4.2.  I have not updated in ages but this just started happening a few days ago.  It absolutely destroyed my battery today.  Turned off "smart network switch" for now to see if that helps.  This serisouly needs an official fix...

Contributor

 • 

2 Messages

6 years ago

Same Issue, Galaxy S5 Active. Issue started 3 Days or so ago, unintalled most everything new. Thought it may be issue with my Fitbit app. Downloading update now, or atleast trying. Looks like very common Issue. 

Contributor

 • 

1 Message

6 years ago

Thank you Glimmerman76!!! It worked perfectly!!! God bless you!!

Contributor

 • 

1 Message

6 years ago

I am the same problem since updating to 4.4.4. I keep seeing the wifi being connected and reconnected and also my battery draining quickly. 

Is there a way to go back to 4.4.1 or whatever was the previous version?

 

I don't see any benefits of going with 4.4.4. 

 

Someone has mentioned a factory reset will solve the problem. Is that true?

 

 

Contributor

 • 

2 Messages

6 years ago

me too, same issue.

 

Constant dropping and reconnecting of wifi network is really draining my battery life.

 

 

Contributor

 • 

2 Messages

6 years ago

This is Perfect Solution thank you Glimmerman

 

 

I will repeat this so word is out.  Keeps smart switching on, and I haven't lost ocnnection since.

---

 

EDIT... after about 5 minutes of good connection, I have reverted back to constant dropping of connection.

 

Oh well...

majesstik

Tutor

 • 

10 Messages

6 years ago

same issues here on the new update. i thought my windows phone was bad, but at least i had wifi

Tutor

 • 

6 Messages

6 years ago

Initally the symptom was my phone battery draining about 4X faster than expected.  I checked several times for a software update but it indicated there wasn't.  Wifi connection cycled through about every 30-40 seconds.  When I read there was an udate I tried again but was unsuccessful.  I booted the phone in safe mode and cleared the aprtition, it picked up the update after that.  The wifi connection issue persists (and across multiple wifi networks).  Are there any other references to this issue that have a realisitc answer (smart switching isn't the solution)?  Given the ineffective battery life and annoying connection messages I might as well go to Verizon.....  At least they have lollipop on thier S5 Smiley Frustrated

Contributor

 • 

1 Message

6 years ago

Same problem.  On 4.4.2  

Contributor

 • 

2 Messages

6 years ago

I created name just to reply here to show how widespread this problem is.  I am still using 4.2.2 and I use T-Mobile, not att.  Samsung S5.  Identical problem and not willing to do factory reset.

Voyager

 • 

3 Messages

6 years ago

Try this fix, go to Settings, Wi-Fi, uncheck or turn off Smart network switch. This became glitchy after the 4.4.4 update.

Contributor

 • 

2 Messages

6 years ago

Turning off 'smart network switch' temporarily solved the problem for me.  Samsung needs to solve this.  I am tmob user having same problem and I am using 4.2.2

 

jerryo21

Tutor

 • 

6 Messages

6 years ago

I also have the same issue! I have tried everything but the factory reset ( Which I am not doing). The smart switch helps a bit but its not the fix!! Can we get some help att/samsung?

jerryo21

Tutor

 • 

6 Messages

6 years ago

I have tried this but still bounces every 30 secs or so! Plus some of my apps that continually run always crash. Tried to uninstall them and reinstall and still bad!

Get started...

Ask a new question