The Samsung Galaxy Z Flip4
qingram's profile
qingram
#1 Star!
25,000 views
50,000 views

Tutor

 • 

18 Messages

Wednesday, October 22nd, 2014 5:03 PM

Galaxy S5 won't remember wifi passwords

I recently had to send my phone Galaxy S5 to Samsung for a screen repair. When I got it back it will no longer remember any wifi passwords consistently. Sometimes it does for awhile, but then I discover I've been using data for days at a time when I thought I was on wifi. I have just turned off the Smart Network Switch as I have found other posts about older versions of the Galaxy having this same issue, but I'll have to wait and see if this works. This is happening with mulitple routers, not just my home wifi. It is very irritating. Is there any way to fix this?

 

The other things that changed when my phone was repaired is the "Security notices" notifications that I now get 100 times a day. "Unauthorized actions have been detected... Restart to undo any unauthorized changes". There aren't any unauthorized actions, how do I shut off the notifications?

 

As far as I know all Samsung did was restore factory setting to wipe out all of my personal information. I don't know why these new issues popped up after that. Thanks for the help!

johninsj

Professor

 • 

3.1K Messages

8 years ago

 

Check for software updates - just in case there are some pending

You can try wiping the dalvic cache - see http://www.pcnexus.net/2014/03/how-to-enter-recovery-mode-galaxy-s5.html

 

Just be sure to NOT "wipe data factory reset" - just wipe the dalvic cache and then reboot.

 

 

qingram

Tutor

 • 

18 Messages

8 years ago

Unfortunately since the phone won't remember my wifi password, everytime it tries to update, it is interrupted because it is no longer on wifi. I have tried to update via Kies, but it says the phone is up to date. If that were true, why is the phone trying to update itself over wifi? This is beyond irritating. 

qingram

Tutor

 • 

18 Messages

8 years ago

I also just wiped the cache. Entered wifi password, connected, restarted phone and wifi password was gone. I see I could possibly side load the update, but where would I find it in the first place?

Contributor

 • 

1 Message

8 years ago

I have a Galaxy S5 Active from AT&T, and I have a similar if not same issue. Whenever I toggle wifi off and back on, all wifi networks and passwords are forgotten. The same occurs if I restart the phone. I have not updated the security policy, so perhaps that is the issue.

 

This is somewhat frustrating given that I connect to many networks, and I occasionally like to turn off wifi to save battery while camping or spending the night at a friend's. Also, there are the inevitable lock ups or slow performance of the phone that require reboot. Please respond with any recommendations if you have knowledge about this.

 

Thank You

Michael

 

[Edited for privacy-please do not post personal or unique information such as but not limited to full names, employee ID numbers, email addresses, phone numbers, account numbers, etc.]

jonna0812

Teacher

 • 

20 Messages

8 years ago

IMHO the two confirmed solutions so far are:

(Root Required) delete the file /data/misc/wifi/wpa_supplicant.conf and allow the phone to recreate it
or
(no root required) go into settings -> Wi-Fi -> Wi-Fi direct, and rename your device

both worked for me on my S5 active. I suggest AT&T add an update to permanently fix the issue, because not so many people knowing how to root their phone, and the issue is really annoying.
qingram

Tutor

 • 

18 Messages

8 years ago

Thank you jonna0812. Be careful with this fix. I was able to get it to work, but...

 

First let me say that I did root my phone, but be forewarned, this voids your factory warranty so proceed with caution. 

 

I deleted the supplicant file as the previous post said to do, but it did not recreate itself. So then I had no wifi at all. I finally found the stock ROM that worked and didn't take 12 hours to download. 

 

This was really pretty easy once I had the right files and there are tutorials on the web that explain how to do this.

 

Ultimately, my wifi password is saved after restarting my phone. :smileyhappy: It was quite a few hours of work to get there, but it is done! 

Contributor

 • 

3 Messages

7 years ago

I had the same problem. I renamed the device under wi-fi settings, changed the clock to after 24 hours, tried it again, and it worked!!. You have to have enough space, and make sure, you rename the device. My device is at ver 5.5.1 now.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.