Skip to main content
AT&T Community Forums

Contributor

 • 

2 Messages

Tue, Apr 23, 2019 8:02 AM

Galaxy j3 2017 phone

Can't create a contract on phone. It only shows numbers no names. All my other contact in phone are showing only numbers and no names also. How do I fix this. Do not know who's calling anymore.

Responses

Accepted Solution

Official Solution

Brand User
ATTHelp

Community Support

 • 

140.1K Messages

2 years ago

Hello, @Joyceguillory56,

 

We'd love to help with this. Do you have the AT&T Call Protect app on your Galaxy phone? There's a known issue with caller ID when the device also has the app on it. You might be able to restore your caller ID by going into Apps and find AT&T Call Protect. In Settings, you should be able to disable the app. After doing that, press and hold the Power/Lock button, then select Power Off. Select Power Off again to confirm. After, press and hold the Power/Lock button again until the screen lights up.

 

Let us know if this helps.

 

James, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Contributor

 • 

2 Messages

2 years ago

Accepted solution . It works great . Thank you 

Get started...

Ask a new question