Skip to main content
AT&T Community Forums
Announcements
Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 8/31. See all protection plans.
duuderyan

Tutor

 • 

5 Messages

Tue, Oct 21, 2008 8:30 PM

Closed

8525 Backlight lag after power button pressed

I have had my AT&T 8525 for about a year and a half. Warranty is definitley out. Every time I press the power button to turn on the backlight for the screen, it takes about two seconds to respond to the button press. It is extremely aggrivating and it makes me not want to use my phone. This started to occur a couple days ago and I am experiencing any other major issues. If anyone has any idea what is going on or how to potentially fix it, please let me know.

Responses

Accepted Solution

duuderyan

Tutor

 • 

5 Messages

12 years ago

Well, I figured out what was wrong.  My microSD slot was not reading my card and it must have been causing some sort of problem turning on the screen.  I removed the card, the screen responded in a reasonable amount of time after the button was pressed.  I blew into the SD slot and I must have cleared some dust or something.  I put the microSD back in the slot and everything seems fine.
BRYAN B

Scholar

 • 

185 Messages

12 years ago

Batteries do wear out, if you know someone who has the same phone as yours, see if you can swap out batteries to test it. It could be time for a fresh one. More likely though, your hardware button is worn so the connection has lost some of it's crispness. 
duuderyan

Tutor

 • 

5 Messages

12 years ago

Unfortunately, I don't know anyone who has the same phone to switch out the battery. 

I have a feeling that it's not the battery though.  The battery has lasted just as long as it always has since I've had the phone.  The screen is just as bright and the battery lasts me all day. 

The problem is when I push the button (which doesn't seem worn down to me since it still has a "clicking" noise when I push it) the screen takes forever to respond.  Could there be some other sort of fix?  Has anyone else had this issue?  It is only with the power button.  Every other button responds almost immediately.  I'm trying to hold out a couple months to purchase a new phone.  Thanks.

Get started...

Ask a new question