Skip to main content
AT&T Community Forums
Announcements
Protect your device against loss, theft, damage and get expert technical support. Open Enrollment Ends 3/31/21.
plumberinaskirt's profile

Tutor

 • 

1 Message

Mon, Jun 17, 2019 2:28 PM

Login issues for Att Premier & Myatt.com

This is the second month I'm having to call support & spend 1 hour trying to figure out with the rep whether I"m considered a business account or not. According to the representative if you have less than 25 lines- they decided to change your account out of Premier business to my att. However neither logins work. I've tried resetting password and now i'm locked out.

 

AT&T has really messed up with this new platform change. This is a mess, I can't see my bill, can't pay them & if you call support get ready to hold b/c everyone is experiencing the same issue.

 

Please get this fixed or we will have to look for a new provider.

Responses

Brand User
ATTHelp

Community Support

 • 

147.6K Messages

2 years ago

Hi @plumberinaskirt

 

Thank you for reaching out to us today. We'll be happy to review this issue for you. For your privacy, it would be best if we continue the conversation privately. I am sending you a private message (PM). Please check your forums private messages by clicking the envelope in the top section of this page or click Forums Inbox. Locate the PM from ATTCares and reply to my message with the requested account details. Thank you.

 

Darais, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Contributor

 • 

1 Message

2 years ago

I'm having issues again with AT&T Premiere website. I always had issues with our AT&T premiere and My AT&T business account.

I log in to different vendor websites but AT&T sites are just the worst. It keeps redirecting on loop. Doesn't get me anywhere whether I have to pay online or just view the bill - same. I think this started happening when AT&T decided to "upgrade" the "look" of their website from a year or so ago. To me functionality and convenience of the website is priority. Without those, an aesthetically pleasing design is NOTHING.

 

Please resolve this "redirecting-on-loop" problem. 

Get started...

Ask a new question