Skip to main content
AT&T Community Forums
Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 8/31. See all protection plans.



3 Messages

Tue, Jun 11, 2019 1:25 AM

I can't login into my AT&T account

From what I see, there are others who have suffered the same fate. I seem to be stuck in the same cycle that you see in these threads (among others):

It almost seems as if my IP has been tagged as problematic - I use Sonic for my Internet access here in Berkeley, CA with a public facing IP address in the 135.180/16 range. I tried using a VPN to connect to the AT&T site from a 184.23/16 ip range, and presto, everything works!!! If there's a problem emanating from my IP address, I would appreciate being informed of the issue. Otherwise, I don't expect my home IP address to be blocked by your site! 

Please let me know how we could resolve this problem.



Brand User

Community Support


127.6K Messages

a year ago

Hi @mazikhan


Thank you for reaching out to us today. We'll be happy to assist you. Have you tried clearing the cache and cookies in your browser? Sometimes that resolves the login issue. If that doesn't work, please let us know and we can proceed from there.


Darais, AT&T Community Specialist 

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.



3 Messages

a year ago

Yes, I've tried that. It doesn't help. As I mentioned, if I just turn on a
VPN, I can connect just fine. Unless my home IP address has been flagged
for some reason, I see no reason why connecting from a VPN should be
advantageous to a direct connection. If I am flagged for some reason, I
would like to be notified so that I could investigate if someone is making
unauthorized use of my wireless network. FYI, only AT&T is blocking me. So
either you guys are way ahead of the curve on something, or you have some
issues with your blocking rules.
Lastly, I'm a pretty tech savvy individual and have tried all the regular
hoops to jump through. I would appreciate your escalating the matter to
someone who can actually look into your firewall blocking rules.



2 Messages

a year ago

I just experienced this same problem. I've been a professional web developer since 1995, and I know a lot about web apps, VPNs, load balancers, DNS, HTTP headers, etc.


In short, this is really weird and seems to be breaking depending on what IP address you use to access it.


When I attempt to log in, I can see the website sending XHR requests (aka "AJAX") to


On my normal work IP address (which goes through New York), this requests results in a 404 from This is the error code reserved for when the requested resource could not be found. And indeed if I look at the response, it's a generic Apache Tomcat 404 HTML page.


However, if I use a VPN service to locate myself to literally anywhere else, the same exact XHR payload, with the same headers and cookies results in a 200 response, and a JSON response object.


From both locations, I'm connecting to the same IP address for My browser is sending the same headers (including cookies), and the same request body. Literally nothing about the request is different... except the IP address it is originating from.


So, I think that has some sort of logic that blocks certain IP addresses from making certain requests. But it's doing this in an odd way. Normally, if you're banning someone, you'd issue a 403 response, not a 404 response. And normally you'd include some information about why. Not just barf out a generic Apache Tomcat 404 HTML page to some Javascript that is requesting a JSON response.


I hope any AT&T employee reading this thread can escalate this issue to the team that is in charge of Send them this post. And please tell them to have the site return a useful error message in this case, that tech support knows how to interpret. The account technical support people have no idea what is going on here, and will just uselessly reset your password over and over.


To anyone experiencing this issue: try from a different internet connection. Use your phone (with Wi-Fi off). Go to Starbucks. Use a VPN. Go to the library. Etc.

Get started...

Ask a new question