rachelm920's profile

Contributor

 • 

2 Messages

Thu, Jun 13, 2019 8:41 PM

Suddenly bad service

Over the last month my cell service in South Windsor CT has gone from mediocre to non existent. I'm consistently on 4G and cannot even send an iMessage without it taking 5-10 minutes to go through. Is there something wrong with the tower in the Ellington Road/John Fitch Blvd. area of South Windsor? I have an iPhone XS Max that I pay a fortune for.

ATTHelp

Community Support

 • 

180.5K Messages

3 y ago

Hello @rachelm920,

 

We can definitely provide you with some troubleshooting steps for these wireless signal issues that you've been experiencing. We aren't seeing any service issues in that area at this time. We recommend using our Troubleshoot & Resolve Tool to fix this. Simply select your device and the issue, then follow the steps to find a solution. If you're still having any issues, please use the AT&T Mark the Spot app to report dropped calls, network issues, and receive network improvement notifications. You can also take advantage of Wi-Fi Calling from AT&T to talk and text over any active Wi-Fi connection. Let us know if this helps.

 

Sean, AT&T Community Specialist

Contributor

 • 

2 Messages

3 y ago

None of these worked. I just had a dropped call and had to return their call via landline. I reported it via "mark the spot". Is there some sort of signal booster I can purchase? I came across Microcell but they're no longer available. WiFi connectivity is not an option for me, as I am at work when this is occurring and there is no WiFi in my area. 

Need help?
Fix, replace or check device delivery
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.