Check out AT&T's Valentine's Day Gift Guide for ideas & deals on the new Samsung Galaxy S23!
Check for service outages
manishj's profile

Tutor

 • 

2 Messages

Thursday, August 17th, 2017 8:40 PM

"No service" at home and "wifi calling" stops working too

I have very weak ATT (1 bar) signal at home. So, I did turn on the "wifi calling" feature in my phone (iPhone 7). However, there are times when even the "1 bar" signal disappears and phone shows t "no service" message. In that situation, the phone calls just drop and I am unable to make any call, even though "wifi calling" is on, until "1 bar" comes back. So, it appears to me that even for "wifi calling" feature to work, the cellphone needs some minimum connectivity to phone towers. 

 

So, is there any solution in such scenarios other than changing provider?  I spoke to ATT customer service once and they told me that they have stopped giving out microcell. 

Tutor

 • 

4 Messages

5 years ago

Hello, I'm having exactly the same issue. I recently moved to a new house, which, according to the AT&T coverage map, has service. Unfortunately sometimes I've 'no service' and sometimes just one dot. I enabled Wi-Fi calling, and this does help, but only during the times I've service. I've read Wi-Fi-enabled calling is the way to go, but it doesn't solve my issue 100%. 

I work from home, so any help would be greatly appreciated. 

sandblaster

ACE - Expert

 • 

62.1K Messages

5 years ago

@NigeHitch There is no requirement for your phone to have some cellular connection for wifi calling to work. When your cellular connection drops, your phone should switch to wifi calling automatically. There might be an issue with your phone. However, what you can try is to force your phone to use wifi calling by putting the phone in airplane mode and then turn wifi back on. 

Mentor

 • 

8 Messages

5 years ago

Something I have found helpful in general is a signal strength app (plenty available for free). The one I'm currently using measures both cell signal and wifi signal. While there is nothing you can do about cell signal, you may be able to relocate your wifi router to get better coverage.

Tutor

 • 

4 Messages

5 years ago

Thanks for the quick response. Your explanation makes sense, but first my wife and I both have different models of an iPhone and we have the same issue. Our other devices connect to wifi, as do our iPhones, and yet we often get the no service icon at the top of the screen. It's very inconsistent, and I don't think we should have to regularly reboot our phones to make this feature work. It's a pretty important feature!! I did take a picture of my screen when it showed Wi-Fi and 'no service', but I can't upload it!

Tutor

 • 

4 Messages

5 years ago

I just quickly tried putting my phone in airplane mode and turned on Wi-Fi. AT&T Wi-Fi showed up, but when I went to make a call, I got a message saying to make a call I had to disable airplane mode!!!

Tutor

 • 

2 Messages

5 years ago

I have also tried this - putting my phone in airplane mode - and then turn wifi ON. I can confirm that I also get the same message "disable airplane more to place a call".

I also told this to the ATT contributor who contacted me a few days ago.

 

I am convinced that WIFI calling does NOT work when there is NO phone signal. 

sandblaster

ACE - Expert

 • 

62.1K Messages

5 years ago

@manishj Sorry I can't convince you but I have used wifi calling in airplane mode often. I absolutely guarantee you don't need a cellular signal. If you can't place calls when in airplane mode, that means your phone is not connecting to the ATT network through your wifi. Unless you see "AT&T Wifi" on your phone display, you are not connected to ATT's network. You may have to wait 30-60 seconds for your phone to connect but if it still won't, you have a home network problem.

Tutor

 • 

4 Messages

5 years ago

I tried again the airplane mode, while putting Wi-Fi back on. I was able to make and receive calls. I'm beginning to think that 'no service' comes up because the phone is constantly switching between cellular and Wi-Fi. I think I can fix this by always opting for Wi-Fi enabled calling when at home. My concern is that I'll forget to turn off airplane mode when I leave home - then I won't get calls!

 

So I think I've a solution for home, but it's far from perfect. 

Teacher

 • 

7 Messages

5 years ago

I have the same issue, I have used in airplane mode but recently it doesn't work and says I have to turn it off to make calls. Sometimes the WiFi calling works and sometimes it doesnt. I think it's att since I haven't had this type of problems with other carriers. Also my wife's phone works great on WiFi calling on Google fi. Att seems to not care too much and unfortunately this is my work phone so I'm stuck for work calls. So if u can switch providers since att doesn't seem to care.

Contributor

 • 

1 Message

5 years ago

I have the the same issue with T-mobile.  So not Att May just be the phone tech and switching between WiFi and cell.  

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.