5GB of Hotspot Data With an Unlimited Plan
melishina's profile

New Member

 • 

3 Messages

Monday, December 5th, 2022 8:14 AM

Mobile roaming not working

I've been using a prepaid and just a month ago when I'm in Mexico data isn't working. It has an exclamation mark. I already tried restarting my phone and network. I don't know what else to try.

ACE - Sage

 • 

104.3K Messages

2 months ago

Did you turn on data roaming?

Are you on the $30 plan? The $30 plan does not roam for free but instead roams at pay per use rates for call, text and data. You would have to add funds in order to use the pay per use feature of the $30 plan. Or change to the $40 plan until you return to USA.

New Member

 • 

3 Messages

2 months ago

I have the $40 plan for 2 years and only started having problems with data a month ago.

ACE - Sage

 • 

104.3K Messages

2 months ago

Again, is data roaming on?  If you have replaced your phone since the last time you were in Mexico data roaming is off by default and you must manually turn it on in settings.    

You may also manually select a different service provider if the option is available to you in settings

ATTHelp

Community Support

 • 

207.8K Messages

2 months ago

Hello, @melishina. Thank you for reaching out to us about your international data and roaming not working. We know it is important to stay connected. We want to help.

 

Thank you, @formerlyknownas for your accurate and helpful suggestions to resolve this issue!

 

As our ACE stated, we definitely want to start by making sure that data roaming is enabled on your device. With device support, you can select your device and see accurate steps on how to make sure data roaming is enabled.

 

We also have a support article that should help you troubleshoot International Cellular Data Issues.

 

Let us know if this works!

 

TT, AT&T Community Specialist

New Member

 • 

3 Messages

2 months ago

Data and roaming are enabled and still not working, I already restarted and even removed the chip and back on to see if it helped. There's an exclamation mark at the end of the signal bar icon. 

I do have data in the US, I just don't have any data in Mexico.

ATTHelp

Community Support

 • 

207.8K Messages

2 months ago

It would be our pleasure to help you with your mobile roaming @melishina.

Could you tell us the model of your phone? This information will allow us to determine if your device is compatible, and to provide you specific guidance for your device. 

Have you tried clicking on the exclamation mark? Knowing what error message you received will help us determine our next steps. 

You can also try these steps to change your preferred network:

  • Go to Network settings.
  • Mobile network.
  • Change the preferred network to 3G.
  • Wait until the exclamation point disappears, now it should work on the 3G network.
  • Switch back to 4G.

If you require additional assistance, to best serve you while out of the country, please call +1.314.925.6925 (free from device) or chat https://www.att.com/contactus/index/wireless.html?tab=1

 

Thank you for reaching out to our AT&T Community. 

 

Marilyn, AT&T Community Specialist

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.