Announcements
HBO Max - where HBO meets so much more!

Teacher

 • 

10 Messages

Wed, May 3, 2017 1:24 AM

how to remove + sign from incoming calls

I really need your help folks.
AT&T SIM on a unlocked Verizon Samsung S7. Incoming calls are coming in with a "+"

Responses

David606

Employee

 • 

3.5K Messages

3 years ago

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Teacher

 • 

10 Messages

3 years ago

Prefixer is working fine for outgoing calls on my Samsung S7. Can't get it to work on incoming calls. + precedes each number. Anyone have a fix?

David606

Employee

 • 

3.5K Messages

3 years ago

Use  \+[0-9]+ instead of the usual \+* or whatever in Prefixer on the incoming calls section. 

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Teacher

 • 

10 Messages

3 years ago

still not work on the incomming call. please see the pic for setting thanks 

 

https://ibb.co/ivPND5

 

https://ibb.co/nQhnfk

Teacher

 • 

10 Messages

3 years ago

anyone know HOW?

Tutor

 • 

6 Messages

8 months ago

Hi, KingClub. 

I know this thread is more than 2 years old, but I thought I would check to see if you ever found a solution to the Verizon Galaxy S7 adding a + sign to your incoming calls. I just switched from Verizon to AT&T and my 2 Galaxy S7 phones have the exact same problem. I would try Prefixer, but it is no longer available from the Google Play Store. If you recall what solution you found, I would be most grateful! Thanks.

Contributor

 • 

1 Message

6 months ago

Prefixer is still available, but you need to go through another avenue like Aptoide.  Seems to be working well for me on outgoing calls on my Galaxy S7, but the incoming calls are still getting the + sign with both \+ and \+[0-9]+ options.  Anyone else have ideas?

Tutor

 • 

6 Messages

GalaxyD,

I found a copy several months ago and loaded it on the Galaxy S7 phones. I used the rule I found online to strip the "+" from all outgoing calls and it works perfectly. I have not tried to write a rule to strip the "+" sign from incoming calls. I actually LIKE seeing the plus sign and country code on incoming calls..., and those don't seem to create any problem for me. Why are you wanting to remove the plus sign from incoming calls?

One thing I noticed when creating the rule for outgoing calls is that the app (or perhaps my KEYBOARD) seemed to automatically put a space after the "\", so I initially had "\ +" which did not work. It took me a while to recognize that there was a space between the two characters. You might want to make sure that did not happen in your rule.

Blessings,

jimmy

New Member

 • 

2 Messages

The problem is not the + persay, but the fact that + is there when there is no country code, it distorts the call. If a call comes in from 555-123-4567 it is displayed as +55 51234567. If the + would go away, or a country code like 1 injected (+1 555-123-4566) that is the goal.

I think the issue stems from the inability to have a country selected in the phone app settings. My phone SM-935V fails to find current country, and does not allow me to enter one. I have the same issue as original poster. I have had the phone for a year and only recently dropped the 1 in caller ID.

New Member

 • 

2 Messages

I did find a solution between many forums. The problems stems from the network, not the phone or ROM. The solution really was the Prefixer app, but you will no longer find it on the play store. I used this link: https://apkpure.com/prefixer/com.tftbelow.prefixer it will prompt you because it is technically an 'untrusted app'. It still works even though it is dated.

I created a rule for incoming calls which searched for .\+ and removed the object \+ and it worked. However, because so many of my contacts were prefixed with 1 or +1, I had to briefly download an app from the Play Store and strip my contacts of the + and the 1.

This resolved the problem.

Tutor

 • 

6 Messages

Glad you got resolution! I did too...., and it also invoked use of Prefixer.